Search the Community

Showing results for tags 'database'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Exile
    • Changelogs
    • Feedback
  • Exile Community
    • General Discussion
    • New Feature Voting
    • Problems & Bugs
    • Cat Walk
    • Recruitment
    • Small Talk
  • Exile Mod XM8 App
    • XM8 Server Administration
    • XM8 Android App
    • XM8 Discord Bot
  • Exile Mod Server Administration
    • Ask a Game Server Provider
    • Hosting
    • Operating Systems
    • Installation
    • Database
    • Security
    • Maintenance
  • Exile Mod Customization
    • Downloads & Releases
    • Content
    • Environment
    • Gameplay
    • Look & Feel
    • Tech Talk
  • Exile Life Mod
    • Visit forum on exilelifemod.com

Categories

  • Knowledge Base
  • Items
  • Constructions
  • Traders
  • Vehicles

Categories

  • Servers

Categories

  • Devblog

Found 64 results

  1. Hello Everyone, So I have been running my servers on my own dedicated server in the US for over a year now and have recently gotten a EU dedicated server and want to transfer the database from one of my servers over to the new EU one. Does anyone know of way that I can transfer all player data over without them losing their bases and vehicles? I will be grateful for every. Thanks in advanced. -wetNreckless
  2. Hello Exile Community, Today I want to present to you my go at extb3 implementation. Take note that this is by no means official. But, with that being said I have a server running it right now and have thoroughly tested it and made sure to our best that there were no database issues. When submitting an error report please provide the following; A brief description of the issue, The FULL Server RPT File, The FULL ExtDB log, and any other information you feel is pertinent to the issue. Installation : New GUIDE (Easier to follow/Setup): https://github.com/BrettNordin/Exile
  3. I would like to know if it is possible to find a way to be able to write vehicle ammo count to the database without using AVS. Im having a lot of issues trying to make AVS work with my current rearm/repair scripts, and I really only want the feature that logs a vehicles ammo count to the db when put in the virtual garage. Im noticing a lot of players are flying back to their bases to instantly rearm for free by putting the vehicle in their VG. any help would be greatly appreciated :]
  4. I can't seem to edit my database, I want to remove a player from my database but the option to "Delete Row" is greyed out. Any solution?
  5. When i start the server it loads "normally" up until it gives me this error. however i am able to connect to the server but i am stuck in the ground and unable to hit esc to bring the menu up to respawn until the server eventually crashes.
  6. Hey so small question and needing a little help. So when loading up my Server ( i run my server from a server i have here in my home.) and i connect to it right when i click it under "Expansions" it shows all the arma mods such as "marksman, kart etc.." all in red. Now i know i don't need to worry about those but it only shows 2 of my mods "Cup weapon, Exile" not the other 3 mods that i have running on the server. So it's hard for other players to see what they need to join. Dose anyone know a fix? can i just add them to "-servermod=Kart; etc..." if not is there another way i can hide these mods since they are not needed?
  7. Hey. I'm setting up a new server. And i am getting the following error. I already have one server that runs fine. So what could be causing this issue? Appreciate it! https://pastebin.com/CiBfPSnG
  8. Okay, i have my server temporarily on a VM (Virtual Machine) under Linux with the operating system as Ubuntu 64bit, until i set the server up with all of the mods and trader things i want, then i will send it over to a 24/7 host server The server has the exile client and exile server missions.. Its a arma 3 exile server on the tanoa map, completly stock, no mods at all. I got the server to show up and im able to log in, and then the problem happened... i start the server and it loads me into the server, as one of the ghost characters/bunny half into the ground, my screen is covered with grass. And then it kicks me to the multiplayer list again... so i join back, and then im stuck at connecting, so i disconnect by pressing the Esc button. But when i do that... a error is thrown up on the screen where i launch the server... "NetServer : : finishDestroyPlayer : DESTROY immediately after CREATE, both cancelled" ....Any idea what that problem is and how to fix it? I want to look and see if its trying to load me as a different faction other than independent but i dont knwo where or how to look.. any ideas?Im new to this server running, and new to programming, so if at all possible, please include the commands to the fix or the help you suggest if you can.. if not thats alright also.
  9. Okay, i have my server temporarily on a VM (Virtual Machine) under Linux with the operating system as Ubuntu 64bit, until i set the server up with all of the mods and trader things i want, then i will send it over to a 24/7 host server The server has the exile client and exile server missions.. Its a arma 3 exile server on the tanoa map, completly stock, no mods at all. I got the server to show up and im able to log in, and then the first problem.... "SteamAPI initialization failed. Steam features wont be accessible!" .....Then after the server loads up and i join, after a while i get the error.... "No more slot to add connection at... " it use to freeze right there, but i gave the VM more memory and it could pass past the error. But then it loads me into the server, as one of the ghost characters half into the ground, my screen is covered with grass. And then it kicks me to the multiplayer list again... so i join back, and then im stuck at connecting, so i disconnect by pressing the Esc button. But when i do that... a error is thrown up on the screen where i launch the server... "NetServer : : finishDestroyPlayer : DESTROY immediately after CREATE, both cancelled" ....Any idea what those errors are? if they effect anything? and how to fix the errors or atleast help fix the destroy player error so i can play on my server? Thank you.Im new to this server running, and new to programming, so if at all possible, please include the commands to the fix or the help you suggest if you can.. if not thats alright also.
  10. I'm suddenly having a problem with vehicles rolling back to positions as back as 20 min before restart. There may be 6-10 of them depending on how many players were on. In my RPT I'm getting these at startup: I'm not getting and errors in my database, haven't edited my exile_server.pbo, and don't have any overrides for this file in my mission file. Any ideas?
  11. My server has really long restart times. From all of the other threads I've looked at, everyone suggests that it is related to the mods/addons/scripts being used, but I am convinced that it is related to the database, specifically the Constructions and Containers tables. I have a test server that is identical to my main server in terms of addons, extra scripts, etc. and that server can fully boot within 1-3min, but the main server still takes 10-15min. The only difference between the two is that the test server has a blank database. After reviewing the RPTs over several restarts, I've noticed that the main culprits seem to be the Construction and Container tables within the database. Families, Territories, Vehicles, and World Spawn Vehicles all take about 20-30sec each, but Constructions takes about 7min and Containers takes about 4-6min every restart. My territory size has a maximum construction limit of 300 pieces (which is less than other servers I've played on that boot quickly). The only thing that I can think of is maybe it's got something to do with loading non-Exile buildings from Extended Base Mod? Same for containers maybe? There are some giant cargo containers that hold about 5x more than Safes...but I wonder if having 5 Safes that are full would make any difference compared to 1 Cargo Container that is full...I don't really know too much about databases, so I was hoping someone can help me out. Any ideas on how to improve this? I'm also running the server on 32bit, do you think upgrading it to 64bit would improve this a lot? I feel like it might, but like I said there are plenty of other servers that seem more heavily modded and/or have bigger construction limits than mine and they've all been able to restart quickly on 32bit all this time...I just don't get it. I'll list the mods/addons below, but I'm still 90% sure it's related to the database, but maybe I'm wrong? Hopefully someone here knows a solution...
  12. Hello, I have a problem running my server with Exile. Attached are the console logs. I am on a dedicated server Linux and I installed Arma3 with LGSM because I am a beginner and it worked perfectly for the vanilla mode. Now I add @ExileServer + @Exile (client) to the serverfile folder and I do a nano arma3server to add in mod: @Exile and in serverside: @ExileServer I created the database and I load the .sql without error apparently. Then I run the server with the command ./arma3server start. And when I join the server, I'm stuck on the grass view and nothing happens. The console shows these errors ::::> There are no logs in the extDB / logs folder. it's empty. I reinstalled several times with several different methods but I still get the same problem ... I'm really tired.
  13. I'm willing to hire someone who can fix the virtual garage function on my server. I do not understand how to use SQL stuff. If someone could input the SQL query for me, i'll pay for the services. Edit: Complete, already finished thanks to the help.
  14. Hello, I'm new for making Exile server but I have a problem when player trying to join my server second time. First time they can join successful and play but they get stuck and return to server list screen when they try to joining server second time. But if I close TADST and close server and open again, they will have no problem to join. Its look like there is a problem when player trying to join server second time. I have Xampp running as server and MySQL. This is TADST's monitor message. "ExileServer - ERROR! ERROR! ERROR! ERROR! ERROR! ERROR!" "ExileServer - You have added weapons to your server that spawn in with attachments." "ExileServer - This will allow duping and money farming!" "ExileServer - To solve this, please remove the following weapons from your loot tables and trader config OR replace them with their non-attachment equivalent:" "ExileServer - [""arifle_SPAR_02_blk_F"",""arifle_SPAR_02_khk_F"",""arifle_SPAR_02_snd_F""]" "ExileServer - Example: Use arifle_Katiba_F instead of arifle_Katiba_ACO_pointer_snds_F." "ExileServer - Installed extDB2 version: 70" "ExileServer - extDB2: Error extDB2 is already setup & locked !!!" "ExileServer - Check your server rpt for errors, your mission might be stuck a loop restarting" "default/BIS_fnc_log: [preInit] ExileServer_fnc_preInit (163.025 ms)" "default/BIS_fnc_log: [script] initServer.sqf" "default/BIS_fnc_log: [postInit] BIS_fnc_missionFlow (0 ms)" "default/BIS_fnc_log: [postInit] BIS_fnc_initParams (0 ms)" "default/BIS_fnc_log: [postInit] BIS_fnc_initRespawn (0 ms)" "default/BIS_fnc_log: [postInit] BIS_fnc_reviveInit (0 ms)" "default/BIS_fnc_log: [postInit] ExileClient_fnc_postInit (0 ms)" "ExileServer - Job with handle 10000 added." "ExileServer - Job with handle 10001 added." "ExileServer - Job with handle 10002 added." "ExileServer - Job with handle 10003 added." Weather was forced to change "ExileServer - Job with handle 10004 added." "ExileServer - Job with handle 10005 added." "ExileServer - Initializing game world..." "ExileServer - Loading families from database..." "ExileServer - Database Error: Error Unknown Protocol" Error in expression < to _numberOfClans - 1 do { ((_clanIDs select _i) select 0) call ExileServer_sy> Error position: <select _i) select 0) call ExileServer_sy> Error Generic error in expression File exile_server\code\ExileServer_world_loadAllClans.sqf, line 25 c:\w\stable\futura\lib\network\networkserver.cpp NetworkServer::OnClientStateChanged:NOT IMPLEMENTED - briefing! Attempt to override final function - bis_fnc_storeparamsvalues_data "default/BIS_fnc_log: [BIS_fnc_preload] ----- Scripts initialized at 20540 ms -----" "ExileServer - Player pors (UID xxxxxxxxx) connected!" "ExileServer - Database Error: Error Unknown Protocol" Error in expression <se_handleBig; }; }; ((_result select 1) select 0) select 0> Error position: <select 0) select 0> Error Generic error in expression File exile_server\code\ExileServer_system_database_query_selectSingleField.sqf, line 27 Error in expression <se_handleBig; }; }; ((_result select 1) select 0) select 0> Error position: <select 0) select 0> Error Generic error in expression File exile_server\code\ExileServer_system_database_query_selectSingleField.sqf, line 27 Mission id: 58d96df44b6f59c6752cdc840e4c9f16812885b6 NetServer::SendMsg: cannot find channel #46315194, users.card=0 NetServer: users.get failed when sending to 46315194 Message not sent - error 0, message ID = ffffffff, to 46315194 (pors) "default/BIS_fnc_log: HandleDisconnect : R Alpha 1-1:1 REMOTE" Warning: Cleanup player - person 2:1988 not found and this is log from @exileServer/extDB/logs extDB2: Found extdb-conf.ini extDB2: Detected 4 Cores, Setting up 4 Worker Threads [00:50:57:473371 +00:-1] [Thread 8912] extDB2: Database Type: MySQL [00:50:57:499966 +00:-1] [Thread 8912] extDB2: Database Session Pool Started [00:50:57:501859 +00:-1] [Thread 8912] extDB2: SQL_CUSTOM_V2: Loading Template Filename: E:\SteamLibrary\steamapps\common\Arma 3 Server\@ExileServer\extDB\sql_custom_v2\exile.ini [00:50:57:502021 +00:-1] [Thread 8912] extDB2: SQL_CUSTOM_V2: Version 12 Detected, Latest Version 12 Available Please help me to solve this. Thanks
  15. bump
  16. Around 1 in 10 locked vehicles disappear from my server. I've done some testing and after a reboot, those vehicles simply aren't in the database any more. Some of the vehicles were in safe zones, some weren't. 100% of the missing vehicles were locked. unlockInSafeZonesAfterRestart = 0; ^ I've turned off unlocking vehicles in safe zones. Is anyone else seeing this on their servers?
  17. I'm currently trying to setup an arma 3 Exile server on a virtual machine, the VM is running Ubunutu Server 16.10, with MySQL 5.7 for the database. At first I was unable to get exile working with extDB2 (the arma 3 serer and MySQL server weren't connecting), I was recently able to get the server to connect to the database by using extDB3. When I attempted to join the game however I was greeted with a longer then usual loading time (frozen load bar) and eventually when I loaded in my camera was stuck onto the ground like so: I went back to see what the problem was, and found a few thing that I suspect might be the culprits, I'm just not able to find a fix myself. The first thing I was unsure of was the creation of my database through phpMyAdmin, using the unaltered exile.sql, at first when I tried to run the .sql file I got the error; "#1215 - Cannot add foreign key constraint". If I unchecked the "Enable foreign key checks" I seemed to work, but i'm unsure if that is the correct way to address the aforementioned error. Here is a picture for reference: Also here is an album containing pictures of the messages I get when the database is created successfully: http://imgur.com/a/opgor Other than that the only other idea I have is to take a look at the log files, the RPT log seems to have a lot of errors that occurred between the time where my client froze and it loaded in stuck to ground. On the other hand I can't find anything wrong with the extDB3 log but i'm hoping it might help someone else help me. RPT Log: extDB3 Log: Thanks in advance to anyone who takes a look at my problem, any suggestions are much appreciated!a FIX: Switching back to extBD2 fixed this problem, and most of my other problems had been fixed by either switching MySQL to non-Strict mode, or using the arma 3 performence binary MySQL Strict mode Disabling: https://dev.mysql.com/doc/refman/5.7/en/sql-mode.html Arma 3 Performance Binary: https://forums.bistudio.com/forums/topic/160288-arma-3-stable-server-168-performance-binary-feedback/
  18. Hello, survivors! I am having issues with uploading/importing the exile.sql file provided with the @ExileServer download. When I attempt to import or even copy & paste the sql file into PHPmyAdmin, I get a bunch of errors, noted in the screenshots provided. It would be greatly appreciated if somebody could provide me help or advice on how to fix said issues.
  19. Can anyone give me a idea where i need to start or even if this is the right section to be asking in. Having issues with Safes and Crates not accessing. I cannot put stuff in safes or they will not allow you to take stuff out. It mainly happens with Safes and wooden crates, but would say its elsewhere too. I am trying to find out how I can get some logs from exile that can show me the requests to the database.. maybe to help identify the issue. Or better still if anyone has found the problem, maybe the fix would be good. I can see from the database itself ,that it isn't updating some of the containers. As if something is blocking the requests. So seeing what is going to it would help fix it i think. Thanks in advance Zeus
  20. ok i have players that are spawning in the ground as rabbits and i have to delete their player out of the database so they can play, is there anyway to fix this?
  21. Dear Community, first, excuse me for my bad english iam from german ^^ Okay my Question/Problem I write a level script for anti-boost and some other features. Now i am stuck. The reason is that i can not load my new entrys from Database to game and and the other way to update the states. I try many things but nothing works. To update the stats and get the stats i used line like that: (can not check if updating works because it does not loading from database) There 2 extracts of 2 files i also trying to update the exile.ini but after all my trys it do not work. I have try it with MySQL help like https://dev.mysql.com/doc/refman/5.7/en/create-view.html and some other documents, woth new table but nothing will work. (maybe i do something wrong but i dont know) Thank you for everything Greets David1197
  22. First off here is the log from my server: extDB2: Version: 70 extDB2: https://github.com/Torndeco/extDB2 extDB2: Windows Version Message: All development for extDB2 is done on a Linux Dedicated Server Message: If you would like to Donate to extDB2 Development Message: https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=2SUEFTGABTAM2 Message: Also leave a message if there is any particular feature you would like to see added. Message: Thanks for all the people that have donated. Message: Torndeco: 20/02/15 extDB2: Found extdb-conf.ini extDB2: Detected 8 Cores, Setting up 6 Worker Threads [17:34:17:406039 --5:00] [Thread 29900] extDB2: Database Type: MySQL [17:34:17:408893 --5:00] [Thread 29900] extDB2: Database Session Pool Started [17:34:17:410040 --5:00] [Thread 29900] extDB2: SQL_CUSTOM_V2: Loading Template Filename: G:\Arma3 server\@ExileServer\extDB\sql_custom_v2\exile.ini [17:34:17:410187 --5:00] [Thread 29900] extDB2: SQL_CUSTOM_V2: Version 12 Detected, Latest Version 12 Available [17:34:17:465877 --5:00] [Thread 30292] extDB2: SQL_CUSTOM_V2: Error StatementException: MySQL: [MySQL]: [Comment]: mysql_stmt_prepare error [mysql_stmt_error]: Unknown column 'container.territory_id' in 'where clause' [mysql_stmt_errno]: 1054 [mysql_stmt_sqlstate]: 42S22 [statemnt]: UPDATE container SET abandoned = NOW(), pin_code = '0000' WHERE (SELECT flag_stolen_at from territory WHERE territory.id=container.territory_id AND territory.flag_stolen_at < DATE_SUB(NOW(), INTERVAL ? DAY)); [17:34:17:465917 --5:00] [Thread 30292] extDB2: SQL_CUSTOM_V2: Wiping Statements + Session [17:34:17:465876 --5:00] [Thread 26788] extDB2: SQL_CUSTOM_V2: Error StatementException: MySQL: [MySQL]: [Comment]: mysql_stmt_prepare error [mysql_stmt_error]: Unknown column 'last_updated_at' in 'where clause' [mysql_stmt_errno]: 1054 [mysql_stmt_sqlstate]: 42S22 [statemnt]: UPDATE construction SET deleted_at = NOW() WHERE last_updated_at < DATE_SUB(NOW(), INTERVAL ? DAY) AND territory_id IS NULL AND deleted_at IS NULL [17:34:17:465956 --5:00] [Thread 26788] extDB2: SQL_CUSTOM_V2: Wiping Statements + Session [17:34:17:466114 --5:00] [Thread 30292] extDB2: SQL_CUSTOM_V2: Error: UniqueID: 1 Input String: setAbandonedUnlocked:2 [17:34:17:466157 --5:00] [Thread 26788] extDB2: SQL_CUSTOM_V2: Error: UniqueID: 1 Input String: markDeleteOldConstructions:2 [17:34:17:466233 --5:00] [Thread 29640] extDB2: SQL_CUSTOM_V2: Error StatementException: MySQL: [MySQL]: [Comment]: mysql_stmt_prepare error [mysql_stmt_error]: Unknown column 'last_paid_at' in 'where clause' [mysql_stmt_errno]: 1054 [mysql_stmt_sqlstate]: 42S22 [statemnt]: UPDATE territory SET deleted_at = NOW() WHERE last_paid_at < DATE_SUB(NOW(), INTERVAL ? DAY) AND deleted_at IS NULL [17:34:17:466255 --5:00] [Thread 29640] extDB2: SQL_CUSTOM_V2: Wiping Statements + Session [17:34:17:466460 --5:00] [Thread 27544] extDB2: SQL_CUSTOM_V2: Error StatementException: MySQL: [MySQL]: [Comment]: mysql_stmt_prepare error [mysql_stmt_error]: Unknown column 'deleted_at' in 'where clause' [mysql_stmt_errno]: 1054 [mysql_stmt_sqlstate]: 42S22 [statemnt]: DELETE FROM territory WHERE deleted_at < DATE_SUB(NOW(), INTERVAL ? DAY) [17:34:17:466493 --5:00] [Thread 27544] extDB2: SQL_CUSTOM_V2: Wiping Statements + Session [17:34:17:466757 --5:00] [Thread 29640] extDB2: SQL_CUSTOM_V2: Error: UniqueID: 1 Input String: markDeleteUnpaidTerritories:7 [17:34:17:466760 --5:00] [Thread 27544] extDB2: SQL_CUSTOM_V2: Error: UniqueID: 1 Input String: deleteUnpaidTerritories:3 [17:34:17:466899 --5:00] [Thread 30620] extDB2: SQL_CUSTOM_V2: Error StatementException: MySQL: [MySQL]: [Comment]: mysql_stmt_prepare error [mysql_stmt_error]: Unknown column 'last_updated_at' in 'where clause' [mysql_stmt_errno]: 1054 [mysql_stmt_sqlstate]: 42S22 [statemnt]: UPDATE vehicle SET deleted_at = NOW() WHERE last_updated_at < DATE_SUB(NOW(), INTERVAL ? DAY) AND deleted_at IS NULL [17:34:17:466924 --5:00] [Thread 30620] extDB2: SQL_CUSTOM_V2: Wiping Statements + Session [17:34:17:467216 --5:00] [Thread 29916] extDB2: SQL_CUSTOM_V2: Error StatementException: MySQL: [MySQL]: [Comment]: mysql_stmt_prepare error [mysql_stmt_error]: Unknown column 'last_updated_at' in 'where clause' [mysql_stmt_errno]: 1054 [mysql_stmt_sqlstate]: 42S22 [statemnt]: UPDATE container SET deleted_at = NOW() WHERE last_updated_at < DATE_SUB(NOW(), INTERVAL ? DAY) AND territory_id IS NULL AND deleted_at IS NULL [17:34:17:467265 --5:00] [Thread 29916] extDB2: SQL_CUSTOM_V2: Wiping Statements + Session [17:34:17:467410 --5:00] [Thread 30620] extDB2: SQL_CUSTOM_V2: Error: UniqueID: 1 Input String: markDeleteOldVehicles:3 [17:34:17:467414 --5:00] [Thread 29916] extDB2: SQL_CUSTOM_V2: Error: UniqueID: 1 Input String: markDeleteOldContainers:10 [17:34:17:467550 --5:00] [Thread 30620] extDB2: SQL_CUSTOM_V2: Error StatementException: MySQL: [MySQL]: [Comment]: mysql_stmt_prepare error [mysql_stmt_error]: Unknown column 'last_updated_at' in 'where clause' [mysql_stmt_errno]: 1054 [mysql_stmt_sqlstate]: 42S22 [statemnt]: UPDATE container SET abandoned = NOW(), pin_code = '0000' WHERE last_updated_at < DATE_SUB(NOW(), INTERVAL ? DAY) AND class = "Exile_Container_Safe" AND territory_id IS NULL [17:34:17:467573 --5:00] [Thread 30620] extDB2: SQL_CUSTOM_V2: Wiping Statements + Session [17:34:17:467590 --5:00] [Thread 30620] extDB2: SQL_CUSTOM_V2: Error: UniqueID: 1 Input String: addAbandonedSafes:7 [17:34:17:467718 --5:00] [Thread 30292] extDB2: SQL_CUSTOM_V2: Error StatementException: MySQL: [MySQL]: [Comment]: mysql_stmt_prepare error [mysql_stmt_error]: Unknown column 'deleted_at' in 'where clause' [mysql_stmt_errno]: 1054 [mysql_stmt_sqlstate]: 42S22 [statemnt]: DELETE FROM container WHERE deleted_at < DATE_SUB(NOW(), INTERVAL ? DAY) AND territory_id IS NULL [17:34:17:467742 --5:00] [Thread 30292] extDB2: SQL_CUSTOM_V2: Wiping Statements + Session [17:34:17:467758 --5:00] [Thread 30292] extDB2: SQL_CUSTOM_V2: Error: UniqueID: 1 Input String: deleteOldContainers:3 [17:34:17:467781 --5:00] [Thread 26788] extDB2: SQL_CUSTOM_V2: Error StatementException: MySQL: [MySQL]: [Comment]: mysql_stmt_prepare error [mysql_stmt_error]: Unknown column 'deleted_at' in 'where clause' [mysql_stmt_errno]: 1054 [mysql_stmt_sqlstate]: 42S22 [statemnt]: DELETE FROM construction WHERE deleted_at < DATE_SUB(NOW(), INTERVAL ? DAY) AND territory_id IS NULL [17:34:17:467820 --5:00] [Thread 26788] extDB2: SQL_CUSTOM_V2: Wiping Statements + Session [17:34:17:467831 --5:00] [Thread 26788] extDB2: SQL_CUSTOM_V2: Error: UniqueID: 1 Input String: deleteOldConstructions:3 [17:34:17:468117 --5:00] [Thread 29640] extDB2: SQL_CUSTOM_V2: Error StatementException: MySQL: [MySQL]: [Comment]: mysql_stmt_prepare error [mysql_stmt_error]: Unknown column 'deleted_at' in 'where clause' [mysql_stmt_errno]: 1054 [mysql_stmt_sqlstate]: 42S22 [statemnt]: DELETE FROM vehicle WHERE deleted_at < DATE_SUB(NOW(), INTERVAL ? DAY) [17:34:17:468158 --5:00] [Thread 29640] extDB2: SQL_CUSTOM_V2: Wiping Statements + Session [17:34:17:468167 --5:00] [Thread 29640] extDB2: SQL_CUSTOM_V2: Error: UniqueID: 1 Input String: deleteOldVehicles:3 [17:34:17:468363 --5:00] [Thread 29900] extDB2: SQL_CUSTOM_V2: Error StatementException: MySQL: [MySQL]: [Comment]: mysql_stmt_prepare error [mysql_stmt_error]: Unknown column 'deleted_at' in 'where clause' [mysql_stmt_errno]: 1054 [mysql_stmt_sqlstate]: 42S22 [statemnt]: SELECT id FROM territory WHERE deleted_at IS NULL LIMIT ?,? [17:34:17:468382 --5:00] [Thread 29900] extDB2: SQL_CUSTOM_V2: Wiping Statements + Session [17:34:17:468391 --5:00] [Thread 29900] extDB2: SQL_CUSTOM_V2: Error: UniqueID: 1 Input String: loadTerriotryIdPage:0:100 [17:37:00:906164 --5:00] [Thread 26788] extDB2: SQL_CUSTOM_V2: Error StatementException: MySQL: [MySQL]: [Comment]: mysql_stmt_prepare error [mysql_stmt_error]: Unknown column 'hitpoints' in 'field list' [mysql_stmt_errno]: 1054 [mysql_stmt_sqlstate]: 42S22 [statemnt]: UPDATE player SET name = ?, damage = ?, hunger = ?, thirst = ?, alcohol = ?, oxygen_remaining = ?, bleeding_remaining = ?, hitpoints = ?, direction = ?, position_x = ?, position_y = ?, position_z = ?, assigned_items = ?, backpack = ?, backpack_items = ?, backpack_magazines = ?, backpack_weapons = ?, current_weapon = ?, goggles = ?, handgun_items = ?, handgun_weapon = ?, headgear = ?, binocular = ?, loaded_magazines = ?, primary_weapon = ?, primary_weapon_items = ?, secondary_weapon = ?, secondary_weapon_items = ?, uniform = ?, uniform_items = ?, uniform_magazines = ?, uniform_weapons = ?, vest = ?, vest_items = ?, vest_magazines = ?, vest_weapons = ?, temperature = ?, wetness = ? WHERE id = ? [17:37:00:906268 --5:00] [Thread 26788] extDB2: SQL_CUSTOM_V2: Wiping Statements + Session [17:37:00:906289 --5:00] [Thread 26788] extDB2: SQL_CUSTOM_V2: Error: UniqueID: 1 Input String: updatePlayer::0:100:100:0:1:0:[]:0:13237.161133:11705.337891:0.001297:["ItemMap","ItemCompass","ItemWatch","ItemRadio"]::[]:[]:[]:::["","","",""]::::[]::["","","",""]::["","","",""]::[]:[]:[]::[]:[]:[]:0:0:-1 [17:45:46:319106 --5:00] [Thread 26788] extDB2: SQL_CUSTOM_V2: Error StatementException: MySQL: [MySQL]: [Comment]: mysql_stmt_prepare error [mysql_stmt_error]: Unknown column 'hitpoints' in 'field list' [mysql_stmt_errno]: 1054 [mysql_stmt_sqlstate]: 42S22 [statemnt]: UPDATE player SET name = ?, damage = ?, hunger = ?, thirst = ?, alcohol = ?, oxygen_remaining = ?, bleeding_remaining = ?, hitpoints = ?, direction = ?, position_x = ?, position_y = ?, position_z = ?, assigned_items = ?, backpack = ?, backpack_items = ?, backpack_magazines = ?, backpack_weapons = ?, current_weapon = ?, goggles = ?, handgun_items = ?, handgun_weapon = ?, headgear = ?, binocular = ?, loaded_magazines = ?, primary_weapon = ?, primary_weapon_items = ?, secondary_weapon = ?, secondary_weapon_items = ?, uniform = ?, uniform_items = ?, uniform_magazines = ?, uniform_weapons = ?, vest = ?, vest_items = ?, vest_magazines = ?, vest_weapons = ?, temperature = ?, wetness = ? WHERE id = ? [17:45:46:319161 --5:00] [Thread 26788] extDB2: SQL_CUSTOM_V2: Wiping Statements + Session [17:45:46:319180 --5:00] [Thread 26788] extDB2: SQL_CUSTOM_V2: Error: UniqueID: 1 Input String: updatePlayer::0:100:100:0:1:0:[]:0:13237.161133:11705.337891:0.001297:["ItemMap","ItemCompass","ItemWatch","ItemRadio"]::[]:[]:[]:::["","","",""]::::[]::["","","",""]::["","","",""]::[]:[]:[]::[]:[]:[]:0:0:-1 [17:45:48:224331 --5:00] [Thread 26788] extDB2: SQL_CUSTOM_V2: Error StatementException: MySQL: [MySQL]: [Comment]: mysql_stmt_prepare error [mysql_stmt_error]: Unknown column 'hitpoints' in 'field list' [mysql_stmt_errno]: 1054 [mysql_stmt_sqlstate]: 42S22 [statemnt]: UPDATE player SET name = ?, damage = ?, hunger = ?, thirst = ?, alcohol = ?, oxygen_remaining = ?, bleeding_remaining = ?, hitpoints = ?, direction = ?, position_x = ?, position_y = ?, position_z = ?, assigned_items = ?, backpack = ?, backpack_items = ?, backpack_magazines = ?, backpack_weapons = ?, current_weapon = ?, goggles = ?, handgun_items = ?, handgun_weapon = ?, headgear = ?, binocular = ?, loaded_magazines = ?, primary_weapon = ?, primary_weapon_items = ?, secondary_weapon = ?, secondary_weapon_items = ?, uniform = ?, uniform_items = ?, uniform_magazines = ?, uniform_weapons = ?, vest = ?, vest_items = ?, vest_magazines = ?, vest_weapons = ?, temperature = ?, wetness = ? WHERE id = ? [17:45:48:224362 --5:00] [Thread 26788] extDB2: SQL_CUSTOM_V2: Wiping Statements + Session [17:45:48:224373 --5:00] [Thread 26788] extDB2: SQL_CUSTOM_V2: Error: UniqueID: 1 Input String: updatePlayer::0:100:100:0:1:0:[]:0:13234.717773:11705.455078:0.001297:["ItemMap","ItemCompass","ItemWatch","ItemRadio"]::[]:[]:[]:::["","","",""]::::[]::["","","",""]::["","","",""]::[]:[]:[]::[]:[]:[]:0:0:-1 [17:53:27:847014 --5:00] [Thread 26788] extDB2: SQL_CUSTOM_V2: Error StatementException: MySQL: [MySQL]: [Comment]: mysql_stmt_prepare error [mysql_stmt_error]: Unknown column 'hitpoints' in 'field list' [mysql_stmt_errno]: 1054 [mysql_stmt_sqlstate]: 42S22 [statemnt]: UPDATE player SET name = ?, damage = ?, hunger = ?, thirst = ?, alcohol = ?, oxygen_remaining = ?, bleeding_remaining = ?, hitpoints = ?, direction = ?, position_x = ?, position_y = ?, position_z = ?, assigned_items = ?, backpack = ?, backpack_items = ?, backpack_magazines = ?, backpack_weapons = ?, current_weapon = ?, goggles = ?, handgun_items = ?, handgun_weapon = ?, headgear = ?, binocular = ?, loaded_magazines = ?, primary_weapon = ?, primary_weapon_items = ?, secondary_weapon = ?, secondary_weapon_items = ?, uniform = ?, uniform_items = ?, uniform_magazines = ?, uniform_weapons = ?, vest = ?, vest_items = ?, vest_magazines = ?, vest_weapons = ?, temperature = ?, wetness = ? WHERE id = ? [17:53:27:847067 --5:00] [Thread 26788] extDB2: SQL_CUSTOM_V2: Wiping Statements + Session [17:53:27:847090 --5:00] [Thread 26788] extDB2: SQL_CUSTOM_V2: Error: UniqueID: 1 Input String: updatePlayer::0:100:100:0:1:0:[]:0:13237.161133:11705.337891:0.001297:["ItemMap","ItemCompass","ItemWatch","ItemRadio"]::[]:[]:[]:::["","","",""]::::[]::["","","",""]::["","","",""]::[]:[]:[]::[]:[]:[]:0:0:-1 Okay so what is happening is when me and my friends spawn into my server we all spawn in the ground "dead" is what people call it. in the database i have only accounts and no players. My mySQL is working because the database is there and server functions. Mods: Exile only. Any help is appreciated. Thanks!
  23. Hello i need some help i am trying to set up an arma 3 server on my dedicated server that is running TCAdmin2.0 but when i try to create the game server i get the following error. any help is much appreciated
  24. I suddenly have an issue where the last 30 minutes of gameplay before a restart are lost. Players will log in and their vehicles will be wherever they happened to be 30 min prior to restart. Mods that I've installed that modified the database are Virtual Garage (XM8) and AVS (Advanced Vehicle System). I don't know if either of those could be an issue. I talked to QGS who hosts my shared server and the support guy said it sounds like the db save period is set wrong but that he doesn't know where to set it. He's looking into it. Between that and my players getting glued to spawned vehicles (that's another topic ), my server has been a ghost town.
  25. I recommend for your database that you switch from using MySQL to using MariaDB. MariaDB is a binary drop-in replacement for MySQL. Here are 10 reasons according to seravo.fi why you should switch to MariaDB: MariaDB development is more open and vibrant Quicker and more transparent security releases More cutting edge features More storage engines Better performance Galera active-active master clustering Oracle stewardship is uncertain MariaDB has leapt in popularity Compatible and easy to migrate Migration might become difficult after 2015 (due to MySQL version compatibility) i have been using MariaDB on my servers for a couple years now and so far everything is blazing fast and very responsive. Migration is simple and easy. You download the installer, it checks for an existing MySQL install and replaces the necessary files. Done.