Sign in to follow this  
Followers 0
Patrix87

DB Error retreiving something

6 posts in this topic

Anyone ever seen that ?

Spoiler

22:28:19 Error in expression <8,0.00249315,0.0101977,0.999945,[[],[]],<null>,<null>,"9680"]]]>
22:28:19   Error position: <<null>,<null>,"9680"]]]>
22:28:19   Error Invalid number in expression
22:28:19 Error in expression <8,0.00249315,0.0101977,0.999945,[[],[]],<null>,<null>,"9680"]]]>
22:28:19   Error position: <<null>,<null>,"9680"]]]>
22:28:19   Error Invalid number in expression
22:28:19 Error in expression <"extDB2" callExtension _query);
switch (_result select 0) do
{
case 0:
{
(format>
22:28:19   Error position: <_result select 0) do
{
case 0:
{
(format>
22:28:19   Error Undefined variable in expression: _result
22:28:19 File exile_server\code\ExileServer_system_database_query_selectSingle.sqf, line 16
22:28:19 Error in expression <000)
];
_vehicleObject = createVehicle [_vehicleClassName, _temporaryPositionInO>
22:28:19   Error position: <_vehicleClassName, _temporaryPositionInO>
22:28:19   Error Undefined variable in expression: _vehicleclassname
22:28:19 File mpmissions\__cur_mp.Altis\custom\ExileServer_object_vehicle_carefulCreateVehicle.sqf, line 23
22:28:19 Error in expression <ode = _this select 4;
_vehicleObject = [_className, _position, _direction, _useP>
22:28:19   Error position: <_className, _position, _direction, _useP>
22:28:19   Error Undefined variable in expression: _classname
22:28:19 File exile_server\code\ExileServer_object_vehicle_createPersistentVehicle.sqf, line 18
22:28:19 Error in expression <
_items = _this select 1;
if ((typeName _items) isEqualTo "ARRAY") then 
{
if!(_>
22:28:19   Error position: <_items) isEqualTo "ARRAY") then 
{
if!(_>
22:28:19   Error Undefined variable in expression: _items
22:28:19 File exile_server\code\ExileServer_util_fill_fillItems.sqf, line 15
22:28:19 Error in expression <gazines = _this select 1;
if ((typeName _magazines) isEqualTo "ARRAY") then 
{	
>
22:28:19   Error position: <_magazines) isEqualTo "ARRAY") then 
{	
>
22:28:19   Error Undefined variable in expression: _magazines
22:28:19 File exile_server\code\ExileServer_util_fill_fillMagazines.sqf, line 15
22:28:19 Error in expression <weapons = _this select 1;
if ((typeName _weapons) isEqualTo "ARRAY") then 
{
if!>
22:28:19   Error position: <_weapons) isEqualTo "ARRAY") then 
{
if!>
22:28:19   Error Undefined variable in expression: _weapons
22:28:19 File exile_server\code\ExileServer_util_fill_fillWeapons.sqf, line 15
22:28:19 Error in expression <tabase_query_selectSingle;
_position = [_data select 8, _data select 9, _data se>
22:28:19   Error position: <_data select 8, _data select 9, _data se>
22:28:19   Error Undefined variable in expression: _data
22:28:19 File exile_server\code\ExileServer_object_vehicle_database_load.sqf, line 15

 

Thanks

Share this post


Link to post
Share on other sites

I am seeing a lot of this in my rpt file as well.

Share this post


Link to post
Share on other sites
Advertisement

@Patrix87@Omen

That means you guys have vehicles with bad information within their database row.

This is the most important line.

Open up your DB, goto vehicle, click filter and enter 0.999945 in the search box.

Click search and it will show you the one or more entries that have this number in it.

Right click the row and delete it out. You will not get that error anymore

 

8,0.00249315,0.0101977,0.999945,[[],[]],<null>,<null>,"9680"]

 

Or you can lookup the lock code of 9680 and find the vehicle that way. Either or it will work and solve that one issue

 

 

Share this post


Link to post
Share on other sites

The easiest way is to just copy and replace all fields with <null> from an ok entry above.

That way you don't have to delete any vehicles.

You can then restart or wait to a scheduled restart and the error will clear.

 

Edited by Renegade2k6

Share this post


Link to post
Share on other sites

I did not find any null in the db but I did found 

0.999945

I then deleted it as it was a bike.

and now the error is gone.

Share this post


Link to post
Share on other sites
On ‎11‎/‎01‎/‎2016 at 5:09 PM, Patrix87 said:

I did not find any null in the db but I did found 


0.999945

I then deleted it as it was a bike.

and now the error is gone.

I removed bikes from traders totally as the inventory doesn't set up correctly in the table when purchased (blank instead of <null> ), I then deleted any permanent ones.

Wont put them in unless/when a fix comes out for them

 

I did think of setting default of each of the cargos to <null> in the database (open vehicles in phpmyadmin click on structure) and then if anything wrote wrongly at least it wouldn't glitch the cargo, it just wouldn't have any

Edited by red_ned

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.