Karmafied

Using a 2nd A3XAI ?

4 posts in this topic

I am currently running a copy of A3XAI on my server. 

I tried using a SECOND version of it, simply changing the AI's side to WEST (to create some friendlies). I also changed EVERY instance of A3XAI to A3XAI2. Every filename, every line in the code, etc.

Yet, when the server starts, it only runs the first version. Does anyone have a clue as to why it wouldn't run this second version? I figured that by adding the 2 to every A3XAI, it would make the server think it was a completely new addon. What am I missing here?

Share this post


Link to post
Share on other sites

I believe that it is because the first instance of A3XAI defines a variable that tells the second instance that A3XAI is running causing it to abort.

 

See line 13 in A3XAI_initserver.sqf

1 person likes this

Share this post


Link to post
Share on other sites
Advertisement

Line 13: A3XAI_isActive = true;

But if I called the 2nd instance A3XAI2, why would this still be affected? Shouldn't it read as two separate programs/addons?

And if I disable this, should I disable it in A3XAI, A3XAI2, or both? Would that work?

Share this post


Link to post
Share on other sites

Update: Disabling line 13 in A3XAI2 DID cause the addon to show up in the server startup log, but A3XAI2 did not spawn any AI. Can't seem to figure out why it would start in the log but not continue further and actually spawn AI?

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.