Sign in to follow this  
Followers 0
Razor77

Debug Console

9 posts in this topic

Hi,  I have finally (after 3 evenings) managed to install a server on my pc, basically its for me only just to mess around and learn how to add missions etc

Is there a way to get the debug menu/console form editor and use it while im on the server as admin?  So i can tp, spawn in weapons, vehicles etc, i know there are programs you an buy to do this, but im only messing around at the moment.

 

Thanks

Share this post


Link to post
Share on other sites

Open your description.ext (found in mpmission/Exile.YOURMAP)

 

find 

// Allows access to the Debug Console outside of the editor during normal gameplay. 
// 0 = Default behavior, available only in editor
// 1 = Available in SP and for hosts / logged in admins
// 2 = Available for everyone
enableDebugConsole = 0; // 2 = dangerous in MP

and change it to 

enableDebugConsole = 1;

You'll need a PBO unwrapper if you don't have one already. 

 

you can find one here

http://www.armaholic.com/page.php?id=16369

Share this post


Link to post
Share on other sites
Advertisement

Sorry to revive an old post, but once enabled, how does one access said debug console?

Share this post


Link to post
Share on other sites
14 hours ago, ElShotte said:

Sorry to revive an old post, but once enabled, how does one access said debug console?

type in chat #login (then admin password that you set in config)  Then when you press ESC you will have debug console, if you use infistar you can access it through the menu

Edited by Razor77

Share this post


Link to post
Share on other sites
On 18/01/2017 at 8:13 AM, Razor77 said:

type in chat #login (then admin password that you set in config)  Then when you press ESC you will have debug console, if you use infistar you can access it through the menu

I can open Debug Console, but none command work. How to fix it, please?

I tryied:
player setDamage 0;
onmapsingleclick "vehicle player setpos _pos"
deleteVehicle cursorTarget

None works. I think I have to add some call function in CfgRemoteExec . Could you help me, please?

Thank you!

Edited by joew00

Share this post


Link to post
Share on other sites

Should not have to add anything else as far as I know, if debug console pops up then you should be good to go. 

 

Share this post


Link to post
Share on other sites
22 hours ago, Razor77 said:

Should not have to add anything else as far as I know, if debug console pops up then you should be good to go.

Sadly it isn't this way =(

The debug console pops up, but don't execute.
Its because Exile is using remotecfg and Debug Console uses call.

In Altis framework is easy deal with it, just have to add one function to remotecfg like as F(call, "ANYONE");
It will execute the calls, but i can't find a way to latest Exile version =(

Do you have any idea?

Thankz!

Share this post


Link to post
Share on other sites
1 hour ago, joew00 said:

Sadly it isn't this way =(

The debug console pops up, but don't execute.
Its because Exile is using remotecfg and Debug Console uses call.

In Altis framework is easy deal with it, just have to add one function to remotecfg like as F(call, "ANYONE");
It will execute the calls, but i can't find a way to latest Exile version =(

Do you have any idea?

Thankz!

No Im sorry I dont know much about how arma/scrpting works....you are already confusing me :D

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.