ProjectViper72

Battleye, infiSTAR & DMS?

7 posts in this topic

Ok I hope this is the right place to ask this. But I purchased  infiSTAR Exile to use on one of my servers mainly due to all the Battleye script issues. So my question is, do I still have to run Battleye to use  infiSTAR? Because the only way I could get the server to start, was to place the a3_infiSTAR_Exile.pbo in my @ExileServer folder like I had to do with the DMS mission pbo. But It kicks everyone instantly with a "Battleye: Public Variable Restriction #0". And if I do everything the install instructions say to do with adding the @a3_infiSTAR_Exile folder and putting the a3_infiSTAR_Exile.pbo init then adding it to the command line for startup, the server just stays on "creating" and never boots all they way up. I might be having more then one issue, but I'm still researching and trying to figure it out. My next step is to contact my server host and see if they can take a look at it. But if anyone knows if infiSTAR has to run with Battleye, please let me know.

Share this post


Link to post
Share on other sites

Hey
Your server host or infiSTAR has not directly anything to do with your BE filter issue.

If you run vanilla Exile with infiSTAR and my Filters you have no BE issues.
If you go ahead and mod your server like using DMS or any other addon, you need to adjust your BE filters

(google it or search here on the forum, countless posts on how to do it, everywhere.)

What you did with the a3_infiSTAR_Exile.pbo (dropping it to your exile_server pbo) is the best & easiest way to run it (I do it myself like that as well) but at the end of the day it makes no difference if you do it like that or as -serverMod=@Exile_infiSTAR
so just leave it like you have it :)

 

1 person likes this

Share this post


Link to post
Share on other sites
Advertisement
45 minutes ago, infiSTAR said:

If you go ahead and mod your server like using DMS or any other addon, you need to adjust your BE filters

What you did with the a3_infiSTAR_Exile.pbo (dropping it to your exile_server pbo) is the best & easiest way to run it (I do it myself like that as well) but at the end of the day it makes no difference if you do it like that or as -serverMod=@Exile_infiSTAR
so just leave it like you have it :)

 

1. Yea I believe my main issue is that I added "Armed Vehicles & Choppers" to the server. That seams to be the main reason for the script errors and player kicks. But I believe I now have that fixed, thanks to alot of folks here.

 

2. So did you put the a3_infiSTAR files in the exile_server.pbo it's self or just in the folder (@ExileServer) along side of the exile_server.pbo?

Share this post


Link to post
Share on other sites

Hey
I go here
"SERVER_ARMA3_FOLDER\@infiSTAR_Exile\addons" and then make a pbo out of "a3_infiSTAR_Exile"

14_01_2016__16-11-48.png

then I cut that pbo and paste it into
"C:\Program Files (x86)\Steam\steamapps\common\Arma3Server\@ExileServer\addons"

14_01_2016__16-12-05.png

Share this post


Link to post
Share on other sites

Ok just making sure, thanks. I have something set wrong because the admin menu will not come up but at least the server is up now lol. Thanks for all the intel.

Share this post


Link to post
Share on other sites

Well it is only that and the mpmission changes you have to do :)
ah and don't forget to add your UID in the config.hpp so you are an admin 

Share this post


Link to post
Share on other sites

Ok thanks a ton getting me in the right direction, you rock @infiSTAR. I got it all the way down the the original " Battleye: Public Variable Restriction #0 " issue, so I decided to just turn off Battleye and infiSTAR works perfect.  The original issue has to have something to do with something I must have done before adding infiSTAR. So what I wanted to do I ended up successful thanks to your guidance.

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.