Sign in to follow this  
Followers 0
TMHackSaW

CUSTOM BUILDINGS

21 posts in this topic

Hello Guys . 

I am editing new buildings for my map and when i save it to mine.sqf shows like this.

[
    ["Land_Pier_F",[11985.9,12723.9,-2.05908],19.1688,0,0,false],
    ["Land_Pier_F",[12025.3,12710.2,-2.09171],19.1688,0,0,false],
    ["Land_Pier_F",[12064.4,12696.6,-2.05716],19.1688,0,0,false],
    ["Land_Pier_F",[12103.8,12682.9,-2.08646],19.1688,0,0,false],
    ["Land_Pier_F",[12143.3,12669.3,-2.05716],19.1688,0,0,false],
    ["Land_Pier_F",[12182.6,12655.5,-2.05716],19.1688,0,0,false],
    ["Land_Pier_F",[11958.6,12743.8,-2.05908],54.7013,0,0,false],
    ["Land_Pier_F",[11955.5,12770.6,-2.05908],113.143,0,0,false],
    ["Land_Pier_F",[11977.2,12788.3,-2.05908],167.844,0,0,false],
    ["Land_Pier_F",[12008.7,12786,-2.05908],201.039,0,0,false],
    ["Land_Pier_F",[12047.6,12771,-2.05908],201.039,0,0,false],

]

 

then inside my init i call it like this 

 


if(!isDedicated) then{
    
    []execVM "minesqf";

    
};

 

But does not load . 

Any ideas why. 

 

Thanks, 

 

 

Share this post


Link to post
Share on other sites

Hello Guys . 

I am editing new buildings for my map and when i save it to mine.sqf shows like this.

[
    ["Land_Pier_F",[11985.9,12723.9,-2.05908],19.1688,0,0,false],
    ["Land_Pier_F",[12025.3,12710.2,-2.09171],19.1688,0,0,false],
    ["Land_Pier_F",[12064.4,12696.6,-2.05716],19.1688,0,0,false],
    ["Land_Pier_F",[12103.8,12682.9,-2.08646],19.1688,0,0,false],
    ["Land_Pier_F",[12143.3,12669.3,-2.05716],19.1688,0,0,false],
    ["Land_Pier_F",[12182.6,12655.5,-2.05716],19.1688,0,0,false],
    ["Land_Pier_F",[11958.6,12743.8,-2.05908],54.7013,0,0,false],
    ["Land_Pier_F",[11955.5,12770.6,-2.05908],113.143,0,0,false],
    ["Land_Pier_F",[11977.2,12788.3,-2.05908],167.844,0,0,false],
    ["Land_Pier_F",[12008.7,12786,-2.05908],201.039,0,0,false],
    ["Land_Pier_F",[12047.6,12771,-2.05908],201.039,0,0,false],

]

 

then inside my init i call it like this 

 


if(!isDedicated) then{
    
    []execVM "minesqf";

    
};

 

But does not load . 

Any ideas why. 

 

Thanks, 

 

 

EDIT :

 

if(!isDedicated) then{
    
    []execVM "mine.sqf";

    
};

Share this post


Link to post
Share on other sites
Advertisement

Try out this:

private ["_objs"];
_objs = [

		//your custom objects
];

{
	private ["_obj"];
	_obj = createVehicle [_x select 0, [0,0,0], [], 0, "CAN_COLLIDE"];
	if (_x select 4) then {
		_obj setDir (_x select 2);
		_obj setPos (_x select 1);
	} else {
		_obj setPosATL (_x select 1);
		_obj setVectorDirAndUp (_x select 3);
	};
} foreach _objs;

Make sure you dont have a comma at the end of the last object.

Share this post


Link to post
Share on other sites

Delete tje comma ath the last object. Like this.

[
    ["Land_Pier_F",[11985.9,12723.9,-2.05908],19.1688,0,0,false],
    ["Land_Pier_F",[12025.3,12710.2,-2.09171],19.1688,0,0,false],
    ["Land_Pier_F",[12064.4,12696.6,-2.05716],19.1688,0,0,false],
    ["Land_Pier_F",[12103.8,12682.9,-2.08646],19.1688,0,0,false],
    ["Land_Pier_F",[12143.3,12669.3,-2.05716],19.1688,0,0,false],
    ["Land_Pier_F",[12182.6,12655.5,-2.05716],19.1688,0,0,false],
    ["Land_Pier_F",[11958.6,12743.8,-2.05908],54.7013,0,0,false],
    ["Land_Pier_F",[11955.5,12770.6,-2.05908],113.143,0,0,false],
    ["Land_Pier_F",[11977.2,12788.3,-2.05908],167.844,0,0,false],
    ["Land_Pier_F",[12008.7,12786,-2.05908],201.039,0,0,false],
    ["Land_Pier_F",[12047.6,12771,-2.05908],201.039,0,0,false]  // <<

]

NOT THIS

[
    ["Land_Pier_F",[11985.9,12723.9,-2.05908],19.1688,0,0,false],
    ["Land_Pier_F",[12025.3,12710.2,-2.09171],19.1688,0,0,false],
    ["Land_Pier_F",[12064.4,12696.6,-2.05716],19.1688,0,0,false],
    ["Land_Pier_F",[12103.8,12682.9,-2.08646],19.1688,0,0,false],
    ["Land_Pier_F",[12143.3,12669.3,-2.05716],19.1688,0,0,false],
    ["Land_Pier_F",[12182.6,12655.5,-2.05716],19.1688,0,0,false],
    ["Land_Pier_F",[11958.6,12743.8,-2.05908],54.7013,0,0,false],
    ["Land_Pier_F",[11955.5,12770.6,-2.05908],113.143,0,0,false],
    ["Land_Pier_F",[11977.2,12788.3,-2.05908],167.844,0,0,false],
    ["Land_Pier_F",[12008.7,12786,-2.05908],201.039,0,0,false],
    ["Land_Pier_F",[12047.6,12771,-2.05908],201.039,0,0,false], // <<< with the comma thats why its not loading the script you placed in your server. its the same when you add weapons/attatch/food/water in a line code like this

]

Share this post


Link to post
Share on other sites

I am affraid is not loading for me i did 

addons.sqf

 private ["_objs"];


_objs = [

        //Addons
        ["Land_Cargo_Tower_V1_No1_F",[4694.64,2439.81,0],26.6494,0,0,false],
        ["Land_Cargo_Tower_V1_No2_F",[4579.34,2511.25,0],46.7533,0,0,false],
        ["Land_Cargo_Tower_V1_No3_F",[5178.98,2292.54,0],305.766,0,0,false],
        ["Land_Cargo_Tower_V1_F",[4472.24,9978.89,0],55.1688,0,0,false],
        ["Land_Cargo_Tower_V1_F",[4698.38,10357.7,0],61.7143,0,0,false],
        ["Land_Cargo_Tower_V1_F",[4890.78,10104.2,-0.206146],60.3118,0,0,false],
        ["Land_i_Barracks_V1_F",[4597.18,10379.8,0],150.545,0,0,false],
        ["Hhedgehog_concrete",[4589.19,10406.6,0],329.61,0,0,false],
        ["Hhedgehog_concrete",[4597.06,10411.2,0],329.61,0,0,false],
        ["Hhedgehog_concrete",[4604.92,10415.8,0],329.61,0,0,false],
        ["Hhedgehog_concrete",[4610.24,10413.3,0],60.7793,0,0,false],
        ["Hhedgehog_concrete",[4614.69,10405.4,0],60.7793,0,0,false],
        ["Hhedgehog_concrete",[4619.14,10397.4,0],60.7793,0,0,false],
        ["Hhedgehog_concrete",[4623.58,10389.5,0],60.7793,0,0,false],
        ["Hhedgehog_concrete",[4628.03,10381.5,0],60.7793,0,0,false],
        ["Hhedgehog_concrete",[4632.48,10373.5,0],60.7793,0,0,false],
        ["Hhedgehog_concrete",[4636.93,10365.6,0],60.7793,0,0,false],
        ["Hhedgehog_concrete",[4641.38,10357.6,0],60.7793,0,0,false],
        ["Hhedgehog_concrete",[4638.45,10352.4,0],153.351,0,0,false],
        ["Hhedgehog_concrete",[4630.31,10348.3,0],153.351,0,0,false],
        ["Hhedgehog_concrete",[4622.16,10344.2,0],153.351,0,0,false],
        ["Hhedgehog_concrete",[4614.01,10340.2,0],153.351,0,0,false],
        ["Hhedgehog_concrete",[4605.87,10336.1,0],153.351,0,0,false],
        ["Hhedgehog_concrete",[4597.72,10332,0],153.351,0,0,false],
        ["Hhedgehog_concrete",[4581.33,10402,0],329.61,0,0,false],
        ["Hhedgehog_concrete",[4573.47,10397.4,0],329.61,0,0,false],
        ["Hhedgehog_concrete",[4565.61,10392.8,0],329.61,0,0,false],
        ["Hhedgehog_concrete",[4557.75,10388.2,0],329.61,0,0,false],
        ["Hhedgehog_concrete",[4556.76,10381.9,0],239.844,0,0,false],
        ["Hhedgehog_concrete",[4561.34,10374,0],239.844,0,0,false],
        ["Hhedgehog_concrete",[4565.92,10366.1,0],239.844,0,0,false],
        ["Hhedgehog_concrete",[4570.5,10358.3,0],239.844,0,0,false],
        ["Hhedgehog_concrete",[4575.08,10350.4,0],239.844,0,0,false],
        ["Hhedgehog_concrete",[4579.66,10342.5,0],239.844,0,0,false],
        ["Hhedgehog_concrete",[4584.23,10334.6,0],239.844,0,0,false],
        ["Hhedgehog_concrete",[4592.35,10329.3,0],153.351,0,0,false],
        ["Hhedgehog_concrete",[4586.45,10330.6,0],239.844,0,0,false],
        ["Flag_AAF_F",[4586.56,10365.6,0],117.818,0,0,false],
        ["Land_PaperBox_open_full_F",[4620.68,10360,0],0,0,0,false],
        ["Land_PaperBox_open_full_F",[4620.59,10358.5,0],0,0,0,false],
        ["Land_PaperBox_open_full_F",[4618.57,10357,0],0,0,0,false],
        ["Land_PaperBox_open_full_F",[4617.16,10358.1,0],8.41559,0,0,false],
        ["Land_PaperBox_closed_F",[4618.82,10359.2,0],0,0,0,false],
        ["Land_PaperBox_closed_F",[4620.43,10356.8,0],0,0,0,false],
        ["Land_PaperBox_closed_F",[4621.7,10358.8,0],0,0,0,false],
        ["Land_Misc_Cargo1E_EP1",[4581.54,10344.6,0],158.026,0,0,false],
        ["Land_Misc_Cargo1B",[4585.02,10345.4,0],0,0,0,false],
        ["Misc_Cargo1Bo_military",[4582.74,10350.5,0],0,0,0,false],
        ["Land_Pallet_MilBoxes_F",[4591.3,10383.6,0],0,0,0,false],
        ["Land_Pallet_MilBoxes_F",[4589.66,10382.4,0],334.753,0,0,false],
        ["Land_Cargo_HQ_V1_F",[4566.53,10384.8,0],151.013,0,0,false],
        ["Land_Cargo_Patrol_V1_F",[4636.98,10356.5,0],331.948,0,0,false],
        ["Land_Cargo_Patrol_V1_F",[4590.88,10333.5,0],331.948,0,0,false],
        ["Land_Mil_Barracks_i",[4826.28,10251.5,0],63.1429,0,0,false],
        ["Land_i_Barracks_V1_F",[4136.54,10814.9,0],330.078,0,0,false],
        ["Land_Mil_Barracks_i",[4291.35,10908.4,0],59.4026,0,0,false],
        ["Land_Mil_Barracks_i",[4276.56,10899.7,0],59.4026,0,0,false],
        ["Land_Mil_Barracks_i",[4261.78,10891,0],59.4026,0,0,false],
        ["Land_Cargo_Patrol_V1_F",[4260.52,10874.3,0],58.9091,0,0,false],
        ["Land_Cargo_Tower_V1_No1_F",[4300.19,10911.5,0],61.2467,0,0,false]

];

{
    private ["_obj"];
    _obj = createVehicle [_x select 0, [0,0,0], [], 0, "CAN_COLLIDE"];
    if (_x select 4) then {
        _obj setDir (_x select 2);
        _obj setPos (_x select 1);
    } else {
        _obj setPosATL (_x select 1);
        _obj setVectorDirAndUp (_x select 3);
    };
} foreach _objs; 

and either on my init.sqf or initplayer.sqf 

 

i called


if (!hasInterface || isServer) exitWith {};


waitUntil {alive vehicle player};    
waitUntil {typeOF player != "Exile_Unit_GhostPlayer"};
uiSleep 2;

// Mission Briefing
call CompileFinal preprocessFileLineNumbers "custom\MissionBriefing.sqf";
systemchat("MissionBriefing activated...");    

if(!isDedicated) then{
    
    []execVM "addons.sqf";
    
};

 

but nothing, any help please.

 

Share this post


Link to post
Share on other sites

use initserver.sqf 

That what Exile Dev is using for custom building, i just add some at the end (add a coma and don't forget to remove at the last one)

1 person likes this

Share this post


Link to post
Share on other sites

use initserver.sqf 

That what Exile Dev is using for custom building, i just add some at the end (add a coma and don't forget to remove at the last one)

No luck, at the end does not load and my traders does not load any other clue?

Share this post


Link to post
Share on other sites

Here is how i would put your .sqf in my server.

Put this into your initServer.sqf in the mission.pbo

if (isServer) then {
  []execVM "mine.sqf";
};

 

Edited by =DH= Unremorseful

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.