Sign in to follow this  
Followers 0
olke

not spawn particle

1 post in this topic

USE_ANMZONE= TRUE;
SET_MARKER= TRUE;

_zonecoord =
[
    [[14544.271,16902.896,0],175, 'Anom1', true],// TraderZone Folia 
    [[14527.828,16922.42,0],175, 'Anom2', true], // Mafia Trader Zone
    [[14508.646,16902.037,0],175, 'Anom3', true] // TraderZone Silderas
];

if (isServer) exitWith 
{
    if (USE_ANMZONE) then
    {
        {
            _center = _x select 0;
            _radius = _x select 1;
            _name = _x select 2;    

            if (SET_MARKER) then { 
                _marker = createMarker [format["GreenZone:%1", _name], _center];
                _marker setMarkerType "selector_selectedMission";
                _marker setMarkerText "Anomaly detected";
                _marker setMarkerColor "ColorRed";

        _pickedLocReal = setPos _center
        _gravi1 = "#particlesource" createVehicleLocal getPosWorld  _pickedLocReal;
        _gravi2 = "#particlesource" createVehicleLocal getPosWorld  _pickedLocReal;
        _gravi3 = "#particlesource" createVehicleLocal getPosWorld  _pickedLocReal;
        _gravi1 setParticleCircle [3, [0, 0, 0]];
        _gravi1 setParticleRandom [0, [0.25, 0.25, 0], [0.175, 0.175, 0], 0, 0.25, [0, 0, 0, 0.1], 0, 0];
        _gravi1 setParticleParams [["\A3\data_f\cl_rock1", 1, 0, 1], "", "SpaceObject", 1, 7, [0, 0, 0], [0, 0, 0.75], 0, 10, 7.9, 0.075, [10, 2, 4], [[0.1, 0.1, 0.1, 1], [0.25, 0.25, 0.25, 0.5], [0.5, 0.5, 0.5, 0]], [0.08], 1, 0, "", "", ""];
        _gravi1 setDropInterval 0.05;
        _gravi2 setParticleCircle [0, [0, 0, 0]];
        _gravi2 setParticleRandom [0, [0.25, 0.25, 0], [0.175, 0.175, 0], 0, 0.25, [0, 0, 0, 0.1], 0, 0];
        _gravi2 setParticleParams [["\A3\data_f\cl_grass2", 1, 0, 1], "", "SpaceObject", 1, 12.5, [0, 0, 0], [0, 0, 0.75], 0, 10, 7.9, 0.075, [5, 2, 4], [[0.1, 0.1, 0.1, 1], [0.25, 0.25, 0.25, 0.5], [0.5, 0.5, 0.5, 0]], [0.08], 1, 0, "", "", ""];
        _gravi2 setDropInterval 0.05;
        _gravi3 setParticleCircle [1, [0, 0, 0]];
        _gravi3 setParticleRandom [0, [0, 0, 0], [0, 0, 0], 0, 0.2, [0, 0, 0, 0], 0, 0];
        _gravi3 setParticleParams [["\A3\data_f\ParticleEffects\Pstone\PStone.p3d", 8, 3, 1], "", "SpaceObject", 2, 7, [0, 0, 0], [0, 0, 3], 0.5, 4, 1, 0, [1, 1, 1], [[1, 1, 1, 1], [0.25, 0.25, 0.25, 0.5], [0.5, 0.5, 0.5, 0]], [0.08], 1, 0, "", "", ""];
        _gravi3 setDropInterval 0.1;

        };
     } forEach _zonecoord ; 
    };                                                                                       
};

 

 

what is the problem, where I'm wrong ... why havent spawn particles :(

Edited by olke

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.