Celmi

Linux Server Installation Guide

49 posts in this topic

Hi,

because I could not find a linux server installation tutorial, I decided to document my own steps I've done. 

I installed an exile server on an Ubuntu 14.04 LTS minimal version.
First of all if you use a minimal version of Ubuntu you have to install some useful tolls like: VIM, wget, unzip and so on.

  1. Install arma on your server. For this i used this tutorial: Tutorial
  2. After that you can test your server with a vanilla arma gameplay mode.

Now we download and unzip the Exile mod:

  1. Change your directory to the Arma root directory
    cd ~/steamcmd/arma3/
    
  2. Download the Exile Server and the Exile Mod

    wget http://www.exilemod.com/download/@ExileServer-0.9.20b.zip 
    wget http://swcdn.launcher.eu/a3launcher/@Exile-0.9.20.zip
    
  3. Unzip both of them

    unzip \@ExileServer-0.9.20b.zip -d tmpserver
    unzip \@Exile-0.9.20.zip -d tmpclient
    
  4. Change directory

    cd tmpserver
    
  5. Move the content to the arma root dorectory

    mv  MySQL/ ~/steamcmd/arma3/MySQL/
    cd Arma\ 3\ Server
    mv \@ExileServer/ ~/steamcmd/arma3/\@exileserver/
    mv battleye/* ~/steamcmd/arma3/battleye/
    mv keys/* ~/steamcmd/arma3/keys/
    mv mpmissions/* ~/steamcmd/arma3/mpmissions/
    mv tbb.dll ~/steamcmd/arma3/
    mv tbbmalloc.dll ~/steamcmd/arma3/
    cd ~/steamcmd/arma3/tmpclient
    mv \@Exile/ ~/steamcmd/arma3/\@exile/
    
  6. Now it's time to install MySQL
    I recommend use this tutorial: https://wiki.ubuntuusers.de/MYSQL
  7.  Start MySQL and create exile Database
    mysql -u root -p 
    create database if not exists exile;
    create user 'exile'@'localhost' identified by 'password';
    grant all privileges on exile.* to 'exile'@'localhost';
    flush privileges;
    source /home/steam/steamcmd/arma3/MySQL/exile.sql
    
  8. Now we configure the exile DB

    cd ~/steamcmd/arma3/\@exileserver/
    vim extdb-conf.ini
    
  9. At the bottom set the user name and passwords appropriately.

  10. now you have to download the extDB2.so
    extDB2-v65.rar

  11. I used filezilla to copy this file to the @ExileServer folder. You finde this file at /Linux/@extDB2/

  12. Then test this file. (Thanks to K3nG9LoL)

    cd ~/server/arma3/@exileserver
    ldd extDB2.so 

    It should look like this
     

    Linux-gate.so. 1 (0xf77b6000)
    libtbbmalloc.so. 2 => /usr/lib/libtbbmalloc.so.2 (0xf6cef000)
    libdl.so. 2 => /lib/i386-linux-gnu/i686/cmov/libdl.so.2 (0xf6cea000)
    libm.so.6. 6 => /lib/i386-linux-gnu/i686/cmov/libm.so.6 (0xf6ca6000)
    libpthread.so. 0 => /lib/i386-linux-gnu/i686/cmov/libpthread.so.0 (0xf6c8b000)
    libc.so.6. 6 => /lib/i386-linux-gnu/i686/cmov/libc.so.6 (0xf6ad9000)
    /lib/ld-linux.so.2 (0xf77b7000)
    LibRT.so.1. 1 => /lib/i386-linux-gnu/i686/cmov/librt.so.1 (0xf6ad0000)

    If its looks about as
     

    Linux-gate.so. 1 (0xf77b6000)
    libtbbmalloc.so. 2 => not found
    libdl.so. 2 => /lib/i386-linux-gnu/i686/cmov/libdl.so.2 (0xf6cea000)
    libm.so.6. 6 => /lib/i386-linux-gnu/i686/cmov/libm.so.6 (0xf6ca6000)
    libpthread.so. 0 => /lib/i386-linux-gnu/i686/cmov/libpthread.so.0 (0xf6c8b000)
    libc.so.6. 6 => not found
    /lib/ld-linux.so.2 (0xf77b7000)
    LibRT.so.1. 1 => /lib/i386-linux-gnu/i686/cmov/librt.so.1 (0xf6ad0000)

    you have to install some libraries

    dpkg --add-architecture i386
    apt-get update
    apt-get install libc6 tmux lib32gcc1 libtbb2 lib32gcc1 lib32stdc++6 libtbb2:i386
    
  13. Now you have to configure your server

    mv ~/steamcmd/arma3/\@exileserver/config.cfg ~/steamcmd/arma3/
    cd ~/steamcmd/arma3/
    vim config.cfg
    
  14. You have to change hostename, password, passwordAdmin, serverCommandPassword
    remember that passwordAdmin  and serverCommandPassword  should not be the same
     
  15. Now you can start the server with those parameters:
     
    ./arma3server -config=config.cfg -mod=@exile -servermod=@exileserver -autoinit > stdout.log 2> stderr.log &

    This will start the Server with the exile mod, load the config from config.cfg, automatically start the mission and send the console output to stdout.log and stderr.log files

 

If something not dosen't work or you have any problems or suggestions, how to do it better feel free to contact me or post it below :)
I hope this is helps you to setup your own Exile Server on Linux

Edited by Celmi
9 people like this

Share this post


Link to post
Share on other sites
Advertisement

At the moment our server performs well with linux, but we have to do further testing with more players online.

We currently running the server on a dedicatet V Server with 4x 2,26 GHz Xenon Prozessor and 8GB RAM.
Today we had about 50 Server FPS with 5 players online. 
I dont know how good this FPS are in compare with windows server.

Share this post


Link to post
Share on other sites

Great guide but I have seem to of run into a speed bump. I am running on Debian 7 and I was missing the "libtbbmalloc.so.2" so I followed the steps to installing that file and it seems to of not worked.

root@vps53196:~# apt-get install libc6 tmux lib32gcc1 libtbb2 lib32gcc1 lib32stdc++6 libtbb2:i386
Reading package lists... Done
Building dependency tree
Reading state information... Done
libtbb2 is already the newest version.
lib32gcc1 is already the newest version.
tmux is already the newest version.
lib32stdc++6 is already the newest version.
libc6 is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libtbb2 : Conflicts: libtbb2:i386 but 4.0+r233-1 is to be installed
 libtbb2:i386 : Depends: libc6:i386 (>= 2.4) but it is not going to be installed
                Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
                Depends: libstdc++6:i386 (>= 4.1.1) but it is not going to be installed
                Conflicts: libtbb2 but 4.0+r233-1 is to be installed
E: Unable to correct problems, you have held broken packages.

 

This is what I get when I run

apt-get install libc6 tmux lib32gcc1 libtbb2 lib32gcc1 lib32stdc++6 libtbb2:i386

It seems to get caught up on "libtbb2:i386" as when I remove that part it installs fine.

Thanks in advanced.

Share this post


Link to post
Share on other sites

What is your console output if you do a ledd on extDB2.so

And can you run the server without problems? Then you can skipp this part.

If you use the extDB2.so you have dependencies to other external libraries. 
So you have to install these libraries. 
These are the libraries that I had to install on a Ubuntu 14.04:

apt-get install libc6 tmux lib32gcc1 libtbb2 lib32gcc1 lib32stdc++6 libtbb2:i386

So you have read the console output of ledd extDB2.so to figure out which dependencies you have to install on your Debian 7

Share this post


Link to post
Share on other sites

Im using Debian 7, linux is a bit more of a faf to get it running but I am happy with the results.

Share this post


Link to post
Share on other sites

What is your console output if you do a ledd on extDB2.so

And can you run the server without problems? Then you can skipp this part.

If you use the extDB2.so you have dependencies to other external libraries. 
So you have to install these libraries. 
These are the libraries that I had to install on a Ubuntu 14.04:

apt-get install libc6 tmux lib32gcc1 libtbb2 lib32gcc1 lib32stdc++6 libtbb2:i386

So you have read the console output of ledd extDB2.so to figure out which dependencies you have to install on your Debian 7

The server seems to start fine, but when I try to join it stops at a loading screen that says "Virtual Reality". Do you think is related to the missing lib?

Share this post


Link to post
Share on other sites

Can you post your console output of the running server below? 
I need more information to indentify your problem.

Share this post


Link to post
Share on other sites

The server seems to start fine, but when I try to join it stops at a loading screen that says "Virtual Reality". Do you think is related to the missing lib?

Quit out of arma, delete the mods you use from your arma mods list then re-import them, relaunch and it should work. Had this error before, when/if I get it again ill post what it says on the console, something about character deleted I forgot.

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.