Sign in to follow this  
Followers 0
DattoSSS

extDB2: No Config Option Found: exile

7 posts in this topic

Hello everyone

I have rented a server from Wombat and have added the latest Exile files.  I am new to modding servers so I have used the forums extensively to solve the incoming issues.  My goal is to start with exile.altis as a learning curve, add AI and other addons, then find another custom map thats a bit different to use once I have my head around the script.

Anyway I am to the point where the server hangs on 'receiving server version'.

Wombat have been very helpful.  Management (Javed) actually sat up past 2.30am emailing me and loading the latest C++ redistributable on my database to assist and making sure strict mode was turned off.

I have set up the database using exile sql and updated to the latest version.  I have also checked the scripts as has Wombat and no connectivity errors could be found with the [exile] section.  I have basically tried every fix I could find in the forums.

Wombat have suggested there may be an error in the script above [exile] affecting connection.

Could you please have a look at the logs and files and see if you could find the error?  Any assistance is greatly appreciated.

Server is Windows and the DB is Linux if that makes a difference.

Thanks

Command Line:

-ip=43.245.163.200 -port=2382 -noPause -noSound -cpuCount=4 -maxMem=2048 -exThreads=7 -cfg=A3DS\basic.cfg -config=A3DS\server.cfg -profiles=A3DS\Profiles -world=empty -mod=@Exile -servermod=@ExileServer

Log:

extDB2: Version: 70
extDB2: https://github.com/Torndeco/extDB2
extDB2: Windows Version
Message: All development for extDB2 is done on a Linux Dedicated Server
Message: If you would like to Donate to extDB2 Development
Message: https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=2SUEFTGABTAM2
Message: Also leave a message if there is any particular feature you would like to see added.
Message: Thanks for all the people that have donated.
Message: Torndeco: 20/02/15


extDB2: Found extdb-conf.ini
extDB2: Detected 8 Cores, Setting up 6 Worker Threads


[01:18:29:256675 +00:-1] [Thread 65268] extDB2: No Config Option Found: exile
[01:18:29:256675 +00:-1] [Thread 65268] extDB2: Sending Shutdown to Armaserver

@ExileServer\extdb-conf.ini:

[Main]
Version = 5
;Threads = 0  
; Default Value is the number of CPU Cores Detected (max value is 6, min value is 2)
Randomize Config File = false
;This is a legacy option to randomize config file for Arma2 Servers. Only for Windows Builds


[Rcon]
;; This is functional, should be working fine. Just needs abit of testing on a $
;; Allow for changing Address for those running server in a VM environment.
IP = 103.231.91.30
Port = 3306

;; Rcon Password i.e Battleye/beserver.cfg
Password = ***

;; Bad Player Name Checks
;;        This will only work if your mission / mod has started extDB2 Rcon. i.e 9:START_RCON:RCON
Bad Playername Enable = true
Bad Playername Kick Message = Bad Player Name

;; By default : is a bad character (used as seperator for extDB2 Calls (this is hardcoded in)
Bad Playername Strings = (:):{:}
;;Bad Playername Regex_1 = [:alnum:]
;;Bad Playername Regex_2 = [:alnum:]
;;Bad Playername Regex_3 = [:alnum:]

;; Whitelisting / Reserve Slots
;;        This will only work if your mission / mod has started extDB2 Rcon. i.e 9:START_RCON:RCON
Whitelist Enable = false
Whitelist Kick Message = Only Reserved Slots Left
Whitelist Public Slots = 999

;; Database settings to use (Optional)
Whitelist Database = exile
Whitelist SQL Prepared Statement = SELECT CASE WHEN EXISTS(SELECT UID FROM PlayerInfo WHERE BattlEyeGUID=? AND Whitelisted=1) THEN 1 ELSE 0 END
Whitelist Kick on SQL Query Failed = false

;; Hardcoded BEGuids for whitelisted players
;Whitelist BEGuids = xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx : yyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyy

[Steam]
;; This is for VAC Protocol for VAC Bans + Steam Friends.
;; https://steamcommunity.com/dev/apikey
API Key = xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

[VAC]
;; This feature requires Steam + Rcon to be enabled.
;; Also this feature is called via SQF Code atm, i.e it doesn't auto detect players joining server yet....
Auto Ban = false

;; For Player to get banned ( their total VAC Bans => NumberOfVACBans)  AND ( Days Since their Last Ban was <= DaysSinceLastBan)
;; This is also used extDB Protocol VAC:VACBanned returned results

NumberOfVACBans = 1
DaysSinceLastBan = 999999999
BanDuration = 1
;; 0 = Forever, otherwise its x Minutes
BanMessage = Steam VAC Banned

[Log]
;; Flush Logs after each write, more work on Harddrive
Flush = true

[exile]
Type = MySQL
Name = BradH1_1
Username = BradH1
Password = ***
IP = 103.231.91.30
Port = 3306
minSessions = 2
idleTime = 60
; Really should only use this if MySQL server is external. Also only for MySQL
compress = false
; Recommend you turn this on http://dev.mysql.com/doc/refman/5.6/en/mysql-command-options.html#option_mysql_secure-auth
Secure Auth = true

[SQLite_Example]
Type = SQLite
Name = sqlite.db

minSessions = 1
; minSession Default Value = 1

;maxSessions = 4
; maxSession Default Value = number of Main->Threads
;     You really should leave this value alone
idleTime = 60
; idleTime no Default Value yet, needs to be defined.
;     idleTime is the time before a database session is stopped if not used. 
;    If Database Sessions are greater than minSessions

Edited by DattoSSS

Share this post


Link to post
Share on other sites

BOOM

I wound back the tbmalloc.dll to an older version  and the server works!

Hope this helps others with the same issue.

Now for some AI.....

Share this post


Link to post
Share on other sites
Advertisement

If you wind back tbbmalloc you may get random crashes
It also has absolutely nothing todo  with no config option found error
 

Edited by Torndeco

Share this post


Link to post
Share on other sites
16 hours ago, Torndeco said:

If you wind back tbbmalloc you may get random crashes
It also has absolutely nothing todo  with no config option found error
 

Thanks Torndeco, it was the only change I made though and it worked?  

Share this post


Link to post
Share on other sites

Am the author for extDB2 i can tell you winding back the tbbmalloc is a really bad idea / solution.
TBBMalloc also has zero todo with the error message cant find config option (chances are you have a file with mixed file endings or encoding issue)

Share this post


Link to post
Share on other sites

Hi Torndeco

I replaced tbbmalloc with the latest version, only change I made, and my server stuck in 'Waiting for server version"

I rolled back to tbbmalloc version 60, and connected easily.

I have no idea why.

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.