Snakeyes

Another question about DMS static user missions

10 posts in this topic

Greetings,

Since I have added about 6 user created missions I never see them spawn anymore. Ai Island was the last user made mission that I saw spawning on the server. The stock missions still run, but that is all that I see. Any ideas why? DMS is not broken because it is still spawning stock missions. I would like to try some of the new user made missions.

Share this post


Link to post
Share on other sites
1 hour ago, Snakeyes1 said:

Greetings,

Since I have added about 6 user created missions I never see them spawn anymore. Ai Island was the last user made mission that I saw spawning on the server. The stock missions still run, but that is all that I see. Any ideas why? DMS is not broken because it is still spawning stock missions. I would like to try some of the new user made missions.

if you were missing files it would usually complain but check the missions/static and objects/static folders in the PBO still contain the files.

The next thing to do is check the map_configs/altis_config.sqf file and see what's listed

mine looks like this

DMS_StaticMissionTypes append [["opbackfire",3],["castle_183",5],["kastro_castle",5],["kore_factory",5],["opslaughterhouse",3],["bomos",4],["saltflats",4],["slums",1],["ai_island",3],["a_village",6],["terrorist_island",2]];

the numbers help weight which missions are likely to spawn more/less than others then check your main config.sqf file for number of missions, mine is

 DMS_MaxStaticMissions    = 2;      // Maximum number of Static Missions running at the same time. It's recommended you set this to the same amount of static missions

So I have up to 2 static missions spawn at once (although all the map objects spawn in on server start ready for missions)

Also due to recent post check this is default:

 DMS_StaticMissionTypes =   [       // List of STATIC missions with spawn chances.
           
          ];

We found that trying to use this section can stop things working, finally if everything still isn't working check about the location/player distance isn't set to something silly as this will now spawn a mission within X distance of a current player:

 DMS_StaticMinPlayerDistance   = 1500;      // If a player is this close to a mission location, then it won't spawn the mission and will wait 60 seconds before attempting to spawn it.

 

Hope that helps

Edited by red_ned
1 person likes this

Share this post


Link to post
Share on other sites
Advertisement

This is what my altis_config.sqf looks like:

// Add the "saltflats" and "slums" mission to the existing mission types.
DMS_StaticMissionTypes append [["saltflats",4],["slums",1],["ai_island",3],["opslaughterhouse",3],["donmd",2],["opbackfire",2]],["bomos",4],["kastro_castle",4],["castle_183",3]];

The array looks okay. I'll check the other parameters later today. Thanks!

Share this post


Link to post
Share on other sites

@Snakeyes1

array isn't ok:

 [["saltflats",4],["slums",1],["ai_island",3],["opslaughterhouse",3],["donmd",2],["opbackfire",2]],["bomos",4],["kastro_castle",4],["castle_183",3]];

double ]] after opbackfire

Edited by red_ned

Share this post


Link to post
Share on other sites

Yes, you 're correct. My bad. I'll fix that and maybe the user missions will start spawning again.

Share this post


Link to post
Share on other sites

red_ned,

I fixed the array and looked at the other things that you mentioned. DMS seems to work fine. It was spawning missions like clockwork when I was playing today. However, I did not notice any of the addon user missions spawn in. Only the stock DMS missions were spawning. I may just reinstall DMS and add in a user made mission one at time to verify that they are working. This is my altis_config:

Spoiler

/*
    Custom configs for Altis.
    Sample by eraser1

    All of these configs exist in the main config. The configs below will simply override any config from the main config (although the majority of them are the same).
    Explanations to all of these configs also exist in the main config.
*/

DMS_findSafePosBlacklist =
[
    [[22500,19420],[24870,16725]]        // Salt flats are blacklisted for Altis by default.
];

// These configs are the default values from the main config. Just included here as an example.
DMS_PlayerNearBlacklist                = 2000;
DMS_SpawnZoneNearBlacklist            = 2500;
DMS_TraderZoneNearBlacklist            = 2500;
DMS_MissionNearBlacklist            = 2500;
DMS_WaterNearBlacklist                = 500;

// Altis is pretty flat, so we can make the min surfaceNormal ... stricter? more strict? Who cares, you get the idea.
DMS_MinSurfaceNormal                = 0.95;


// Making these configs below as strict as possible will help in reducing the number of attempts taken to find a valid position, and as a result, improve performance.

DMS_MinDistFromWestBorder            = 2000;    // There's at least 2km of ocean from the west edge to the first bit of land.
DMS_MinDistFromEastBorder            = 2250;    // There's over 2km of ocean from the east edge to the first bit of land.
DMS_MinDistFromSouthBorder            = 5000;    // There's about 5km of ocean from the south edge to the first bit of land.
DMS_MinDistFromNorthBorder            = 5200;    // There's around 5km of ocean from the north edge to the first bit of land (including the island).


// Add the "saltflats" and "slums" mission to the existing mission types.
DMS_StaticMissionTypes append [["saltflats",4],["slums",1],["ai_island",4],["opslaughterhouse",3],["donmd",2],["opbackfire",2],["bomos",4],["kastro_castle",4],["castle_183",3]];

// Add the "salt flats base" and "slums" to the "bases" to spawn on server startup. NOTE: "append" and "pushback" are NOT the same.
DMS_BasesToImportOnServerStart append ["saltflatsbase","slums_objects","ai_island_buildings","opslaughterhouse","donmd","opbackfire","bomos_buildings","kastro_castle_buildings","castle_183_buildings"];

 

Share this post


Link to post
Share on other sites

here's mine, looks pretty similar

Spoiler

/*
 Custom configs for Altis.
 Sample by eraser1

 All of these configs exist in the main config. The configs below will simply override any config from the main config (although the majority of them are the same).
 Explanations to all of these configs also exist in the main config.
*/

DMS_findSafePosBlacklist =
[
 [[22500,19420],[24870,16725]]  // Salt flats are blacklisted for Altis by default.
];

// These configs are the default values from the main config. Just included here as an example.
DMS_PlayerNearBlacklist    = 2000;
DMS_SpawnZoneNearBlacklist   = 2500;
DMS_TraderZoneNearBlacklist   = 2500;
DMS_MissionNearBlacklist   = 2500;
DMS_WaterNearBlacklist    = 500;

// Altis is pretty flat, so we can make the min surfaceNormal ... stricter? more strict? Who cares, you get the idea.
DMS_MinSurfaceNormal    = 0.95;


// Making these configs below as strict as possible will help in reducing the number of attempts taken to find a valid position, and as a result, improve performance.

DMS_MinDistFromWestBorder   = 2000; // There's at least 2km of ocean from the west edge to the first bit of land.
DMS_MinDistFromEastBorder   = 2250; // There's over 2km of ocean from the east edge to the first bit of land.
DMS_MinDistFromSouthBorder   = 5000; // There's about 5km of ocean from the south edge to the first bit of land.
DMS_MinDistFromNorthBorder   = 5200; // There's around 5km of ocean from the north edge to the first bit of land (including the island).


// Add the "saltflats" and "slums" mission to the existing mission types.
DMS_StaticMissionTypes append [["castle_183",5],["kastro_castle",5],["kore_factory",5],["opslaughterhouse",3],["bomos",4],["saltflats",4],["slums",1],["ai_island",3],["a_village",6],["terrorist_island",2]];

// Add the "salt flats base" and "slums" to the "bases" to spawn on server startup. NOTE: "append" and "pushback" are NOT the same.
DMS_BasesToImportOnServerStart append ["saltflatsbase","slums_objects","ai_island_buildings","bomos_buildings","kore_factory_buildings","a_village_buildings","ai_island_bridge","opslaughterhouse_buildings","kastro_castle_buildings","terrorist_island_buildings","castle_183_buildings"];

have you checked your RPT for any errors?

Plus check your main config.sqf for your static mission settings and make sure the other stuff we discussed looks right

Share this post


Link to post
Share on other sites

I don't have any RPT errors related to DMS. I decided to reinstall the DMS addon dev branch. I like some of the new features . I added 4 user made missions and started the server. Right off the bat Ai Island started. I did not see another user made mission run after that and I played for a few hours. All the missions are weighted at "1" for priority.

Share this post


Link to post
Share on other sites
4 hours ago, Snakeyes1 said:

Castle 183 just spawned. wooHoo! :rock:

congrats on sorting it

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.