Deazl

Zombies & Demons: BattlEye kicks me

9 posts in this topic

Hey guys,

I'm not really experienced with Arma 3 servers so I need your help.
A few friends and me want to play on a private server. I've installed it on my root and everything works.

Now we want to play with zombies. I found out, that it's possible to use the Zombies & Demons mod with a Script on GitHub to spawn them.
But for serious: I don't know how to install them. The readme tells me something of a ZOM folder I can't find. Second we want to use the Zombies & Demons from the Steam Workshop and not the one from Arma Holic.

I tried to install it with the content of the MODLESS_ZOMBIE folder. It made sense to me. Then I found out that theres a updated version in the Spawner_v3.2_Serverside.zip wich is located in the NEW_CODE folder. The main thing I failed are the BattlEye scripts. I can't figure out where to place the snippets. The readme tells me to put one snippet at the end of a execVM line in the scripts.txt wich isn't there. The other both snippets should be placed at the very first line in the createVehicle.txt and setpos.txt file. Thats what I did. Tried to starting: Got kicked by a Script restriction #25 error.
After googling a bit, the only thing I found was an unanswered thread on this forum with the exact same problem.

Did I done anything wrong? Or is there any easier installation instruction?
 

Edited by Deazl

Share this post


Link to post
Share on other sites

check in your scripts.log file and post the entire kick message without removing any spaces or new lines and then quote line 27 of your scripts.txt

No expert this mod, never played or seen it tbh but sounds like a simple BE kick if you post the info

Share this post


Link to post
Share on other sites
Advertisement

Hey @red_ned
thanks for your quick reply.

I tried installing it again (I removed it temporarily from the server so we can play) but now I get this error on every startup:

 0:07:32 Warning Message: You cannot play/edit this mission; it is dependent on downloadable content that has been deleted.Ryanzombies
 0:07:32 Mission Exile.Altis read from bank.
 0:07:32 Missing addons detected:
 0:07:32   Ryanzombies

But I have this addon even in my startscript. It doesn't change anything when I place it after "@Exile\;"

./libs/lib/i386-linux-gnu/ld-2.21.so --library-path ./:./libs/lib/i386-linux-gnu ./arma3server -pid=2322 -cfg=@ExileServer/basic.cfg -config=@ExileServer/config.cfg -port=2302 -autoInit -mod=@Ryanzombies\;@Exile\; -servermod=@ExileServer\;

 

It spams my whole terminal:
1454454774-ee488a9a-5c1e-421b-ba8f-f450d

Edited by Deazl

Share this post


Link to post
Share on other sites

its not a problem one, in your mission.sqm you need to add any of the items it reports as missing

so missing is: Ryanzombies

should look like this but I use Altis so you just add it into your own list and repack the mission PBO

addOns[]=
 {
  "exile_client",
  "a3_map_altis",
  "Ryanzombies"
 };

Share this post


Link to post
Share on other sites

Hey @red_ned

thanks, but I already have this in my mission.sqm. I even load it and the folder exists.
 

Share this post


Link to post
Share on other sites

Hey @red_ned

So there we go. I installed it again but I still get the same error. But now the mod gets loaded:
1454606883-261e9940-9ca3-44b8-95f8-34b4c

 

But I still get the same error as before. Now I'm using the workshop version (wich we want to use). It seems that it doesnt matter if the name is upper case or lowercase or if I even change it to Ryanzombies (like you see on the screenshot) in the mod.cpp and meta.cpp.

Share this post


Link to post
Share on other sites

Deazl

I had this same error message in the RPT, turns out I  forget to adjust the call in the exile server config.ccp, which should look like this: class CfgPatches
{
    class exile_server_config
    {
        requiredVersion = 0.1;
        requiredAddons[] = {"ryanzombies"};
        units[] = {};
        weapons[] = {};
        magazines[] = {};
        ammo[] = {};
    };
};

///////////////hope this helps.///////////////

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.