biabock

tool bAdmin - In-Game Admin Menu from A3W

187 posts in this topic

bAdmin

eCErbll.jpg

Other Images: http://imgur.com/pQQBXwZ,WqSrwTf

Admin Panel from A3Wasteland ported and customized for exile :D

Features:

  • Player Management (Infos, Spectate, Kill)
  • Player Markers
  • Shop Menu (No working yet)
  • Add Poptabs
  • Add Score
  • Teleport Menu (Map Pos, To Player, Player to)
  • Show Server FPS
  • Toggle God-mode

Admin Levels:

  • Owner(All Options)
  • High Admin(Player Management, Player Markers, Shop Menu, Add Money and Score)
  • Low Admin(Player Management, Player Markers, Shop Menu)

Installation

Step 1: Download all files from github (link below).)

Step 2: Copy all content of mission-files folder to your mission

Step 3: Add it to your description.ext (not add it inside a class)

//bAdmin dialog includes

#include "badmin\client\gui_base.hpp"
#include "badmin\client\systems\common.hpp"
#include "badmin\client\systems\adminPanel\dialog\adminMenu.hpp"
#include "badmin\client\systems\adminPanel\dialog\modMenu.hpp"
#include "badmin\client\systems\adminPanel\dialog\serverAdminMenu.hpp"
#include "badmin\client\systems\adminPanel\dialog\debugMenu.hpp"
#include "badmin\client\systems\adminPanel\dialog\shopMenu.hpp"
#include "badmin\client\systems\adminPanel\dialog\playerMenu.hpp"

Step 4: Your mission.pbo is already ready, you can pack it.

Step 5: Now copy the bAdmin_settings folder to your server directory(same location as the arma3server.exe).

Step 6: Add your UID at the admins.sqf into bAdmin_settings folder and save it(instructions inside file).

Step 7: BE FILTERS

 Open your scripts.txt and add it:

Add to Line 16(showCommandingMenu)

!="5, [["expression", "pselect5 = 'exit';"]], "1", "1"]];\nshowCommandingMenu "#USER:_pmenu";\n};\n_j = 0; _max = 10; if (_max>9) then"

Add to Line 22(onEachFrame)     

!="_start_loop = {\n\ncamera_loop_active =  true;\n["A3W_camera_oneachFrame", "onEachFrame", camera_loop] call BIS_fnc_addStackedEvent"

Add to Line 26(compile)

!="call compile preprocessFileLineNumbers "badmin\globalCompile.sqf";"

Add to Line 28(onMapSingleClick)

!="onMapSingleClick "vehicle player setPos _pos;""

Add to Line 36(setDamage)

!="State) then\n{\nthirstLevel = 100;\nhungerLevel = 100;\nplayer setDamage 0;\nplayer allowDamage false;\nvehicle player setDamage 0;\npl" !=" \n{\n\n\n\nsystemChat "Option Disabled";\n};\ncase 2: \n{\n_target setDamage 1;\n};\ncase 3: \n{\n\n\nsystemChat "Option Disabled";\n};\ncase 4:"

Add to Line 39(playableUnits)

!="then {   _target = nil; };;\n\nprivate["_units"];\n_units = playableUnits;\n_target = if ((isNil {_target} || ({(false ||{   not(isN"

Add to Line 41(isPlayer)

!="l _object) exitWith {nil};\n\nif (_object isKindOf "Man" && {!isPlayer _object}) exitWith {nil};\nif (_object isKindOf "LandVehicle"

Add to Line 43(execVM)

!="execVM "badmin\client\init.sqf";"

Add to Line 44(camCreate)

!=""_camera"];\n_pos = (getPosATL _player);\n_camera = "camera" camCreate [(_pos select 0),(_pos select 1),((_pos select 2) + 3)];\n_c"

Add to Line 46(eventHandler)

!="displayAddEventHandler ["KeyDown","_this select 1 call OPEN_bADMIN_FNC;false;"];"

or you can replace your scritps.txt for it: http://pastebin.com/raw.php?i=drCkNH74

Probably you will get kicked by "setvariable restrciton #0"

I am trying to solve this problem, but the only solution so far is delete the setvariable.txt file from batteye folder

Step 8: Open your server config file .cfg and search for allowedLoadFileExtensions(if you not found it, skip this step), you must enable the sqf file type, the line should be: (very important to load the admins UIDs)

allowedLoadFileExtensions[] 		= {"sqf"};

Step 9(After 1.52 Patch): Add the line below to you server config file .cfg after it you have to add the -filePatching parameter to you start server.

allowedFilePatching = 1;

Step 10: start your server and enjoy!(Press U in-game to open the menu:D:D - Sometimes there is a delay for the script load for client, if you press U and nothing happens, go back to the lobby and sign in again.

Spectate Camera Keybinds:

Camera hotkeys (U.S. keyboard with default Arma 3 keybinds):

  • Shift + > (moves to next player on list)
  • Shift + < (moves to prev player on list)
  • Ctrl + E (exit the camera mode)
  • Control + / (Attaches to target, or detaches from target)
  • Control + H (toggle target HUD)
  • N (cycles through NV, Thermal, and normal camera modes)
  • W,A,S,D (Move the camera in specified direction)
  • Q (Move the camera up, like helicopter)
  • Z (Move the camera down, like helicopter)
  • Mouse Move (Rotate camera naturally)
  • Scroll Wheel Up (Increase camera moving speed by 0.1 m/s, max 1 m/s)
  • Scroll Wheel Down (Decrease camera moving speed by 0.1 m/s, min 0 m/s)
  • Shift + W,A,S,D (Move the camera, but faster, extra 3 m/s)
  • M - Open/Close map (click on map, to move camera to clicked location)

Known Issues:

 -Add Poptabs and Score are not working;

-Player Menu dont show infos.

Download:

  Github repositories: https://github.com/biabock/bAdmin

Licensing

AgentRev commented 5 hours ago

I hereby grant you the right to use the A3Wasteland admin menu system, and its referenced functions, under the GNU Lesser GPL v3. Since bAdmin is a derivative work of A3W, you must therefore release it under this same license. I have included in this pull request all the changes needed to make your project compliant.

This will allow server owners to implement your addon in Exile Mod without conflict to its CC BY-NC-ND 4.0 license, and without requiring further action on their part.

If you accept these terms, please merge this pull request.

Regards,
AgentRev

Edited by biabock
21 people like this

Share this post


Link to post
Share on other sites
Advertisement

Okay I've followed your installation instructions, server boot is fine.

When pressing "U" nothing is happening :-/ I'm not using befilters, could that be causing it not to work? 

Share this post


Link to post
Share on other sites

Okay I've followed your installation instructions, server boot is fine.

When pressing "U" nothing is happening :-/ I'm not using befilters, could that be causing it not to work? 

your rpt logs says :

bAdmin - Innitizaling and Server Compile Finish?

you put your UID in admins.sqf inside badmin_settings folder?

Share this post


Link to post
Share on other sites

Same. Followed..But nothing... I do not even see anything in the logs that it loads. 

Alsol when you say 

Now copy the bAdmin_settings folder to your server directory.

You mean the same location as the Arma3server.exe correct? 

Share this post


Link to post
Share on other sites

 

Same. Followed..But nothing... I do not even see anything in the logs that it loads. 

Alsol when you say 

Now copy the bAdmin_settings folder to your server directory.

You mean the same location as the Arma3server.exe correct? 

your rpt file didnt show: 

"bAdmin - Initializing"

"bAdmin - Server Compile Finished" ?

Edited by biabock

Share this post


Link to post
Share on other sites

@Falcon911

your rpt file dont show: 

"bAdmin - Initializing"

"bAdmin - Server Compile Finished" ?

CTRL+f for the win..

yeap see it...

Sorry about  that... 

Share this post


Link to post
Share on other sites

bAdmin_setting folder should be in the same directory of Arma3server.exe.

you put your UID in admins.sqf file that is inside that folder?

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.