Sign in to follow this  
Followers 0
cGs! mIKE

Loot Spawn not in self-placed buildings?

9 posts in this topic

Ok...

So I've been running a CUP TERRAINS - Chernarus Map.

I've fixed the loot spawn location as shown on the forums to accommodate A2 building spawn locations which works perfectly.

However,  Loot will not spawn on A2 or A3 Buildings that are placed via Editor.   This is my question, why, for example does loot spawn in a hanger which is part of the CUP TERRAINS permanent hanger work.  However the NEW hanger I placed next to it, same model, same building name, does NOT spawn loot?

It is blowing my mind,  any insight or help would be appreciated.

I thought it was based on the building's "class" and locations correct?  or do we have to also apply the buildings physically location somewhere as well? 

Share this post


Link to post
Share on other sites

Have a look at the building names you are placing in the editor. I bet because you are using CUP, they are prefixed with CUP???? Then look at your loot tables, the entries are more than likely not prefixed with CUP, hence why they don't work.

1 person likes this

Share this post


Link to post
Share on other sites
Advertisement

the actual building location doesn't need to be added anywhere though?  like the location on the map?

As I understand, its purely based on the location "around" the building?

Share this post


Link to post
Share on other sites

And,  yes some are "cup",  but some are just the regular A2 Barack's which does spawn loot if it was ported over with the map, however when using the same building in a "custom" location, it wont spawn there, which is what blows my mind.

Share this post


Link to post
Share on other sites

All defined in the cfgbuildings in your exile_server_config.pbo.

class Land_Cargo_Tower_V1_No5_F *****BUILDING CLASS NAME*****
{
  table = "Military"; *****TYPE OF LOOT TO SPAWN TAKEN FROM LOOT TABLE*****
  positions[] = {{-2.25781, -2.77344, -0.120119}, {-2.375, -4.45508, 5.00472}, {-2.41602, 5.18164, 5.00472}, {-2.94922, 2.4082, -4.2958}, {-3.89648, -2.7832, 2.47988}, {-4.03906, 1.43945, -0.120119}, {0.0410156, -0.8125, 5.07988}, {1.62305, 2.55664, -8.24332}, {2.97461, -0.335938, 5.00472}, {3.90039, 3.68555, 2.47988}, {4.80859, 3.57422, -0.120117}}; *****POSITION TO SPAWN AT*****
};

You just need to make sure that the class names in your cfgbuildings match the class names you are using in the editor, if not create a new class.

 

 

 

Share this post


Link to post
Share on other sites

Gotcha thanks!   I'll double check existing/working buildings.  and I'll try to get a CUP Terrain Buildings loot class going for the forums if I can figure it out and post here.    Thanks again for reassuring I'm understanding this properly.  

 

+Rep to you sir. 

Edited by Sjolie

Share this post


Link to post
Share on other sites

Just clone the entries from the cfg I sent you, and add the CUP prefix for the buildings you have added, that use CUP.

 

Share this post


Link to post
Share on other sites

Ok,  I am looking at the config you PM'd me,  however this is where my issue is.

I loaded up M3Editor with my custom town i'm building.  the military barracks, which is part of your config already "Land_MilOffices_V1_F",  however it will not spawn loot in it, or near it at all.  in fact,  zero loot will spawn in this self-made town. 

 

any ideas?

sample.jpg

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.