• 0
Breau

Database Error

Question

So I had my server setup last night was working fine. I updated arma 3 server today and since then I get stuck on Bambi Creation Timeout ...

My Extdb Logs give the error below.

I went back and set sqlmode again when I do SELECT @@global.sql_mode I get 'NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION'.

Re installed VC 2015 as well rebooted the box it self.

 

Any ideas ?

 

[20:52:17:614210 --3:00] [Thread 3796] extDB2: SQL_CUSTOM_V2: Error StatementException: MySQL: [MySQL]: [Comment]: mysql_stmt_execute error    [mysql_stmt_error]: Cannot add or update a child row: a foreign key constraint fails (`exile`.`player`, CONSTRAINT `player_ibfk_1` FOREIGN KEY (`account_uid`) REFERENCES `account` (`uid`) ON DELETE CASCADE)    [mysql_stmt_errno]: 1452    [mysql_stmt_sqlstate]: 23000    [statemnt]: INSERT INTO player SET account_uid = ?, name = ?
[20:52:17:614461 --3:00] [Thread 3796] extDB2: SQL_CUSTOM_V2: Wiping Statements + Session
[20:52:17:614500 --3:00] [Thread 3796] extDB2: SQL_CUSTOM_V2: Error: UniqueID: 1 Input String: createPlayer:myplayid:mmyplayernamehere

Share this post


Link to post
Share on other sites

8 answers to this question

Advertisement
  • 0

did you find a fix for this? i am currently trying to fix this problem myself.

Share this post


Link to post
Share on other sites
  • 0

No it still happens once in a while, when a new person wants to join the server if the server has been or for a while it will error out at bambi creation. I restart and it's fine it adds the record to the database.

Share this post


Link to post
Share on other sites
  • 0

Double check your "my.ini".

If you are using WAMP (Windows) look in C:\Wamp\bin\mysql\ OR C:\wamp64\bin\mysql

Look for strict in that, before you change it make sure to turn off mysql service.
That is the only way to make it permanent.

If you are not using WAMP, look in your ProgramData or Program Files folder for MySQL Configs.
Changing the parameter in MySQL Workbench or PhpMyAdmin doesn't make it permanent and only temporary.

Share this post


Link to post
Share on other sites
  • 0

I am using MySQL on linux Debian. When I check the  my.cnf I dont have strict mode on

sql-mode=NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION
 

Share this post


Link to post
Share on other sites
  • 0

Same, i don't have strict mode on and this is still happening.

Share this post


Link to post
Share on other sites
  • 0

Error: UniqueID: 1 Input String: createPlayer:

sql-mode="NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION"

Removing Strict doesn't fix the issue.  Removing Strict doesn't fix the issue. Maybe i do not right? ^^ :)

Error in the structure of tables, or write permissions is not set?

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.