ProjectViper72

[SOLVED] In need of server help I'm at a loss...

7 posts in this topic

Ok sorry for begging for help this way but since the latest ARMA 3 update I have not be able to get my server back up. I first thought it was my host but after a fresh reinstall the server came up and showed in the server list as well as game tracker but no one could get all the way in game. They was stopped with a black screen and no one ever showed as being on the server.

 

So I thought I screwed something up on my new fresh database, so I reinstalled that and still the same thing. So I contacted my server provider and they passed the following to me. 

Looks like the latest version of Arma3 has broken the Exile mod. Getting 30 or so lines of error code every second, resulting in giant RPT files. The one I just found was 7GBs of Log File.

Following error is being listed; 

{
(format>
13:08:48 Error position: <_result select 0) do
{
case 0:
{
(format>
13:08:48 Error Undefined variable in expression: _result
13:08:48 File exile_server\code\ExileServer_system_database_query_selectFull.sqf, line 16
13:08:48 Error in expression <electFull;
_numberOfTerritories = count _territoryIDs;
if (_numberOfTerritories >
13:08:48 Error position: <_territoryIDs;
if (_numberOfTerritories >
13:08:48 Error Undefined variable in expression: _territoryids
13:08:48 File exile_server\code\ExileServer_world_loadAllTerritories.sqf, line 21
13:08:48 Error in expression <"extDB2" callExtension _query);
switch (_result select 0) do

Now I do install Exile from my server providers one click option, I don't do it manually. Could it be their install causing the issue or even their mysql setup? Any help or a point in the right direction would be very much appreciated.

Edited by ProjectViper72

Share this post


Link to post
Share on other sites

Ask your GSP to disable Strict Mode on the MySQL/MariaDB

Share this post


Link to post
Share on other sites
Advertisement
59 minutes ago, Torndeco said:

Ask your GSP to disable Strict Mode on the MySQL/MariaDB

Thanks for your response. I ask them to do this and this was their response.

Strict mode is disabled by default on our MySQL Servers. I've double checked your installation, it's definitely set correctly; 

sql-mode="NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION"

Anything else I can try that might be the issue or something to check?

Share this post


Link to post
Share on other sites

Definitely looks like an MYSQL error.
I would have them double check it again and make sure that the database is setup correctly.

Share this post


Link to post
Share on other sites
On 2/22/2016 at 8:44 AM, Storm18 said:

Definitely looks like an MYSQL error.
I would have them double check it again and make sure that the database is setup correctly.

Yes I agree but my provider didn't so I canceled their service and switched to another lol. Now I'm getting more slots at a cheaper price plus no issue getting a server up lol. Thanks for all the help.

Share this post


Link to post
Share on other sites

Well, in the end, I would just suggest getting a server from OVH and setting it up that way.

 

Share this post


Link to post
Share on other sites
Advertisement
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.