Sign in to follow this  
Followers 0
Ninja_Dog81

M3Editor / MCC Editor / Map Customisation

9 posts in this topic

Hello all,

I have been scouring the forum and YouTube for info on how to properly set up M3Editor and then create sqf bases and to change the layout of the default Altis map.

My intention is to port to another map and create missions, bases, new trader layout etc but I simply can't get around this map editor. I am quite used to doing it old school but apparently this is a better method, keeping the size of the mission.sqm down.

If someone could please point me in the direction of a tut or thread that explains all this, including how to install M3editor I would be most appreciative (Most importantly, the dll's and how to unlock them).

Once I have the map working with loot spawns and basic setup I will share it here.

Appreciate the help, in advance, thanks!

Share this post


Link to post
Share on other sites

You can use the Eden Editor aswell is simple better too place any objects,

Load Arma 3 with This Map or mods you want. Like CUP Terrain pack or AllInArmaTerrainPack.

And M3editor.

i have build many things with the M3editor but i say the Eden Editor are much better to place objects.

Step 1: So try too Build something with the Eden editor.

Step 2: Place a Unit on the Map too Call the M3Editor. If you see inside off this mod you see nothing but with the nest step all buildings copied inside this m3editor

Step 3: Use follow code in the Command Box

{  _dir = getdir _x;  
_object setVariable ['M3E_dir', _dir, true];  
_object setVariable ['M3E_pitch', 0, true];  
_object setVariable ['M3E_bank', 0, true];  
_object setVariable ['M3E_followterrain', false, true];  
_object setVariable ['M3E_position', position _x, true];  
M3E_insertedObjects pushBack _x;  }  forEach allMissionObjects "All";  call M3E_fnc_loadSpawnedList;

So all things your build with the eden editor are now inside off the M3editor

Step 4: Save it now with the M3editor with a simple better format.

 

If you mean that this is my way too build something for our server. And it works fine.

 

 

I dont know what you mean with this:

4 hours ago, Ninja_Dog81 said:

(Most importantly, the dll's and how to unlock them).

Share this post


Link to post
Share on other sites
Advertisement

@Sgt. ScrapMetal

Thanks for the response/tip. I'll definitely give it a try today.

The dll's are supplied with m3editor and from the info I have found one has to "unlock" them? Without doing so it crashes Arma every time. In fact I believe it was a warning message that came up the first time I used the m3editor.

Share this post


Link to post
Share on other sites

Hey Im using this and I have built a lot of things on the map but when I load them in the server nothing is placed correctly.. and nothing is lined up how it was in the editor. 

 

In the editor things were neat but in game they are all messed up, any ideas on how to fix it so things stay lined up?

Share this post


Link to post
Share on other sites

If you build with the Eden editor?

Then check the building below the cordinates are some rotation values the First to a not safing set it to 0

 

And use this its the better way now

 

Share this post


Link to post
Share on other sites

I used M3Editor - 3Den... Objects have shifted after putting them in the server, nothing has stayed where I put them..

 

What does this even mean...?

" Then check the building below the cordinates are some rotation values the First to a not safing set it to 0 "

Share this post


Link to post
Share on other sites

Doppel click on each object and check the Rotation, i have building yesterday and have the same issiue because the script where im using have this data not include. Check the Picture I mean The Rotation data

http://images.akamai.steamusercontent.com/ugc/509278725907235690/64706D260AB65E4E065DAD9DBBB7DD7528EA6A8C/

Share this post


Link to post
Share on other sites

I had this issue on Panthera... Then one day it magically fixed itself. No idea what changed.

 

Share this post


Link to post
Share on other sites

Posted (edited)

Hmm still having this issue, I don't think its rotation though as its not been rotated in the server and its rotation is correct its just not staying in the spot I placed it. If I'm standing there looking at the building it has moved backwards like 2 feet I need to somehow make it stay where its supposed to. I remember having this issue on Arma 2 and there was a section of code I could place on the object to force it to stay where I placed it but for the life of me I can not remember the code line for it :(

 

EDIT: [More Information here]

 

Edited by [DZW] ☠Real-Killer☠

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.