FalconX77

Update 0.9.6 and Traders Problems

40 posts in this topic

Posted (edited)

So i have updated to 0.9.6, everything works great on our server except 1 issue. All traders except the vehicle traders are empty, i have looked through allmost everything with no luck....

Anyone else have this issue and/or figure out whats happening?

Falcon,

Khaos-Gaming

Edited by FalconX77

Share this post


Link to post
Share on other sites

_trader = [
    "Exile_Trader_Hardware",
    "GreekHead_A3_01",
    ["HubStandingUA_idle1"],
    [12111.6,19110.8,0.56221],
    140
]
call ExileClient_object_trader_create;
_trader setVariable ["ExileTraderType", "Exile_Trader_Hardware"];

 

This is a working trader just remake everyone like this.

2 people like this

Share this post


Link to post
Share on other sites
Advertisement
1 hour ago, Zeppo | Kickback.com said:

_trader = [
    "Exile_Trader_Hardware",
    "GreekHead_A3_01",
    ["HubStandingUA_idle1"],
    [12111.6,19110.8,0.56221],
    140
]
call ExileClient_object_trader_create;
_trader setVariable ["ExileTraderType", "Exile_Trader_Hardware"];

 

This is a working trader just remake everyone like this.

Thanks, did not have the :

_trader setVariable ["ExileTraderType", "Exile_Trader_Hardware"];

Once added worked perfectly, thanks man!

Share this post


Link to post
Share on other sites

Thanks this worked for me as well, now I am trying to create a custom vehicle traders, do I need to do anything special, since it tries to buy a vehicle to my backpack :)

Share this post


Link to post
Share on other sites

So this line:
_trader setVariable ["ExileTraderType", "Exile_Trader_Hardware"];
just needs to be added to the hardware traders or all the traders?

Share this post


Link to post
Share on other sites

All traders but change the type to match the trader!

So

_trader = [
        "Exile_Trader_AircraftCustoms",
        "GreekHead_A3_07",
        ["HubBriefing_scratch", "HubBriefing_stretch", "HubBriefing_think", "HubBriefing_lookAround1", "HubBriefing_lookAround2"],
        [10456.3,5889.75,0.00323486],82]
        call ExileClient_object_trader_create;
       _trader setVariable ["ExileTraderType", "Exile_Trader_AircraftCustoms"];

Share this post


Link to post
Share on other sites

This is interesting. I was using the new exile.altis PBO to reference changes. It appears only some traders have the "_trader setVariable ["ExileTraderType", "Exile_Trader_Equipment"];" line, and other don't. Can I get some feedback from someone who has updated? Does this need to definitively be added to every trader, or just select traders?  It sounds like you mentioned this above, but I'd like to verify.

Share this post


Link to post
Share on other sites

Well it is running on my test server like this and the traders all work fine!

1 person likes this

Share this post


Link to post
Share on other sites

Thank you for the feedback :) I think this is the smoothest, most well informed, well documented update so far!

1 person likes this

Share this post


Link to post
Share on other sites
22 minutes ago, da1geek said:

This is interesting. I was using the new exile.altis PBO to reference changes. It appears only some traders have the "_trader setVariable ["ExileTraderType", "Exile_Trader_Equipment"];" line, and other don't. Can I get some feedback from someone who has updated? Does this need to definitively be added to every trader, or just select traders?  It sounds like you mentioned this above, but I'd like to verify.

I added and modified it for each line and have no issues now :D

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.