Kuro Raijin

0.9.6 Loot Not Working :(

13 posts in this topic

Posted (edited)

Hello,

I've updated the database etc and the server starts and works O.K.

However, I can't get the loot to work... I've tried new tables, old ones, everything, but no luck, any ideas please ? I must be missing something in files outside of the exile_server_config maybe for loot to work?

Traders are empty too but I think I know how to fix them? not a big deal if I can't run the server due to loot not working !

Thanks,

Kuro

Edited by Kuro Raijin
This topic is about LOOT not traders!

Share this post


Link to post
Share on other sites
Advertisement

I have MAS Weapons installed too - but that's something I couldn't care less about. Even normal loot, even with the exact loot table from the files that came with 0.9.6 - it doesn't spawn anything :( (tested with 1 player, so no load on server to be slow, waited for 10 minutes in different places).

I have ESSEKER and TAVIANA running, both of which have the same problem :(

Share this post


Link to post
Share on other sites

Same issue,  nothing spawns, and I've looked at the loot table coding, and nothing has changed as far as format goes.   Is there a new area where we need to configure for loot?

Share this post


Link to post
Share on other sites

I just got told by one of the Exile VIP's "JamieKG" on Teamspeak, that the loot config has been moved from the Server config to the CLIENT config, so loot through the Altis Mission PBO's config.cpp and find the loot part and add it bro!

Trying this now, will update on findings.

1 person likes this

Share this post


Link to post
Share on other sites

I have had no issues with loot spawning.  As with any update I don't ever copy over my config.cpp or any of my files.  I utilize the new files and basically re-add all of my stuff to the new files distributed by the Exile team.  Loot spawn is handled totally different now, which renders your files from old versions completely useless.  For instance there is no more configs in your exile_server_config.pbo that handle the percentage of how loot spawns.  No more 100% loot spawn.  Its handled totally different now.  Hope this helps.

-Goonie

1 person likes this

Share this post


Link to post
Share on other sites
3 minutes ago, agentGoonie said:

I have had no issues with loot spawning.  As with any update I don't ever copy over my config.cpp or any of my files.  I utilize the new files and basically re-add all of my stuff to the new files distributed by the Exile team.  Loot spawn is handled totally different now, which renders your files from old versions completely useless.  For instance there is no more configs in your exile_server_config.pbo that handle the percentage of how loot spawns.  No more 100% loot spawn.  Its handled totally different now.  Hope this helps.

-Goonie

Yes agentGoonie, first time for me :) Sorry for the trouble and thanks for the reply :)

Share this post


Link to post
Share on other sites

Posted (edited)

why does the default server config still have loot tables in it?

This is a couple lines taking from a FRESH DOWNLOADED @exileserver  config.pbo 

Spoiler

    class CivillianLowerClass
    {
        count = 124;
        half = 7143.29532481418;
        halfIndex = 62;
        sum = 10000;
        items[] = 
        {
            {441.988950276243, "Exile_Item_Can_Empty"}, // 4.42%
            {883.977900552486, "Exile_Item_ToiletPaper"}, // 4.42%
            {1325.96685082873, "Exile_Item_PlasticBottleEmpty"}, // 4.42%

 

it still has loot,  same format, and still shows percentages.    how is this not a "percentage" setting?  just curious 

Edited by Sjolie

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.