• 0
Sign in to follow this  
Followers 0
da1geek

Weather settings nul since update

Question

Not sure if anyone else has notice this (as their focus is likely elsewhere since the update), but has anyone notice their weather settings not being taken into account? In terms of overcast/sunny/thunderstorm it works fine, but the definitions of each type of weather. My settings are below (and haven't changed since the update). As you can see, the wind is 0 as it was killing parachuters. Now it just blows as it pleases (insert dirty joke here).

 

Quote

class Weather
{
    /*
        You can define multiple "keyframes" for the weather to change. The server will pick
        a keyframe randomly to simulate the weather. It will change the weather-keyframes
        based on the following interval
    */
    interval = 20;

    /*
        Add the keyframes here. The server will pick one random, so if you want one 
        weather type of be more dominant compared to others, add it multiple times
    */
    keyframes[] = {"Sunny", "Sunny", "Cloudy", "Thunderstorm", "Sunny", "Sunny"}; 

    /*
        This is a keyframe. Look up the BIKI to get more details about the parameters

        Be sure to design the fog settings at a view distance of 1,600m as this is the
        limit in multiplayer by default

       https://community.bistudio.com/wiki/fogParams
       https://community.bistudio.com/wiki/overcast
       https://community.bistudio.com/wiki/setWaves
       https://community.bistudio.com/wiki/setWindStr
       https://community.bistudio.com/wiki/setGusts
       https://community.bistudio.com/wiki/setRain
       https://community.bistudio.com/wiki/setLightnings
       https://community.bistudio.com/wiki/setRainbow
    */
    class Sunny
    {
        fogValue = 0.0;
        fogDecay = 0.0;
        fogBase = 5;
        overcast = 0.0;
        waves = 0.0;
        wind = 0.0;
        gusts = 0.0;
        rain = 0;
        lightnings = 1.0;
        rainbows = 1.0;
    };

    class Cloudy
    {
        fogValue = 0.2;
        fogDecay = 0.1;
        fogBase = 5;
        overcast = 0.3;
        waves = 0.4;
        wind = 0.0;
        gusts = 0.0;
        rain = 0.1;
        lightnings = 0.8;
        rainbows = 0.8;
    };

    class Thunderstorm
    {
        fogValue = 0.7;
        fogDecay = 0.2;
        fogBase = 5;
        overcast = 1;
        waves = 1;
        wind = 0.0;
        gusts = 0.0;
        rain = 1;
        lightnings = 1;
        rainbows = 0.5;
    };
};
 

 

Share this post


Link to post
Share on other sites

1 answer to this question

  • 0

It also appears that having multiple of the same keyframe prevents time from working. 

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.