Sign in to follow this  
Followers 0
Haz

[SOLVED] BE Filters

10 posts in this topic

Posted (edited)

Hello! First off, sorry if this is the wrong place to post this but I seem to limited where i can post (maybe because I am new here). I am having issues with my BE Filters therefore getting kicked when I load in. I have tried reading through the "How To: BattlEye filters - DO IT YOURSELF!" thread but it honestly isn't making much sense to me.

init.sqf:

0 = [] spawn {
    waitUntil {!isNull (findDisplay 46)};
    (findDisplay 46) displayAddEventHandler ["KeyDown", Haz_fnc_Key_Handler];
};

0 = [] spawn Haz_fnc_Player_Markers_Init;

I have tried the following and a few other things too but nothing work so far.

scripts.txt:

1 Haz_fnc_Key_Handler !=""Haz_fnc_Key_Handler"
1 Haz_fnc_Player_Markers_Init !=""Haz_fnc_Player_Markers_Init"
1 Haz_fnc_Player_Markers !=""Haz_fnc_Player_Markers"
1 !=""0 = [] spawn {\n
    waitUntil {!isNull (findDisplay 46)};\n
    (findDisplay 46) displayAddEventHandler ["KeyDown", Haz_fnc_Key_Handler];\n
};
1 !=""0 = [] spawn Haz_fnc_Player_Markers_Init;"
1 !=""Haz_fnc_Key_Handler"
1 !=""Haz_fnc_Player_Markers_Init"
1 !=""Haz_fnc_Player_Markers"
1 !=""0 = [] spawn {\n
    waitUntil {!isNull (findDisplay 46)};\n
    (findDisplay 46) displayAddEventHandler ["KeyDown", Haz_fnc_Key_Handler];\n
};
1 !=""0 = [] spawn Haz_fnc_Player_Markers_Init;"
1 !="Haz_fnc_Key_Handler"
1 !=""Haz_fnc_Player_Markers_Init"
1 !="Haz_fnc_Player_Markers"
1 !="0 = [] spawn {\n
    waitUntil {!isNull (findDisplay 46)};\n
    (findDisplay 46) displayAddEventHandler ["KeyDown", Haz_fnc_Key_Handler];\n
};
1 !="0 = [] spawn Haz_fnc_Player_Markers_Init;"

Any help is much appreciated!

Edited by Haz

Share this post


Link to post
Share on other sites

Posted (edited)

You're pose to paste the be filter fixes into be # + 2

So let's say you got
 

#22 "yMapMarkers;
ExileClientPartyMapMarkers = [];

Then instead of pasting the be fix into line 22 you paste it into line 24. Use: http://gp.gamersinc.net/BEF.php

7 loadFile 
7 createMarker !="yMapMarkers;\nExileClientPartyMapMarkers = ["
7 createVehicleCrew

Use notepad++ to find the correct line to paste it into.

Edited by Zippy

Share this post


Link to post
Share on other sites
Advertisement
#22 "yMapMarkers;

Where are you getting this from?

Share this post


Link to post
Share on other sites

We had that BE error at 22:00:27 on our server, so I used it as an example. Your BE errors should be created in a .log file in your battleye folder. Then you just copy the error after #YourErrorNumber and paste it into that url i posted and it'll generate the fix and then you paste it into the .txt file where you obtained the be from.

Share this post


Link to post
Share on other sites

Posted (edited)

0 = [] spawn Haz_fn"
08.03.2016 02:02:56: Haz (IP Removed) GUID Removed - #0 "il {!isNull (findDisplay 46)};
(findDisplay 46) displayAddEventHandler ["KeyDown", Haz_fnc_Key_Handler];
};

0 = [] spawn Haz_fn"

This is what I have in my scripts.log file and above is what I have in my init.sqf file. Can we use this as an example so I can follow and hopefully understand better?

Edited by Haz

Share this post


Link to post
Share on other sites

That would become:
 

!="il {!isNull (findDisplay 46)};\n(findDisplay 46) displayAddEventHandler [\"KeyDown\", Haz_fnc_Key_Handler];\n};\n\n0 = [] spawn Haz_fn"

and that would be posted into line 2 which would be like this:
 

//new2
7 eventHandler !="il {!isNull (findDisplay 46)};\n(findDisplay 46) displayAddEventHandler [\"KeyDown\", Haz_fnc_Key_Handler];\n};\n\n0 = [] spawn Haz_fn"

 

1 person likes this

Share this post


Link to post
Share on other sites

Posted (edited)

Why does it have il after the != symbols?

Edited by Haz

Share this post


Link to post
Share on other sites

It's how BE filters work,

Here's a rough guide where to post each be error after you've turned it into the the correct format for filters:
 

//new2
7 eventHandler <- BE error 0
7 "setVariable <- BE error 1
7 ctrlCreate <- BE error 2
7 createUnit <- BE error 3
7 createTeam <- BE error 4
7 createAgent <- BE error 5
7 createVehicle <- BE error 6
7 callExtension <- BE error 7
7 showCommandingMenu <- BE error 8
7 setUnitRecoilCoefficient <- BE error 9
7 setWeaponReloadingTime <- BE error 10
7 addAction <- BE error 11
7 remoteexec <- BE error 12
7 drawline3d <- BE error 13
7 onEachFrame <- BE error 14
7 removeAllItems <- BE error 15
7 removeAllActions <- BE error 16
7 addbackpack <- BE error 17
7 compile <- BE error 18
7 compileFinal <- BE error 19
7 onMapSingleClick <- BE error 20
7 loadFile <- BE error 21
7 createMarker <- BE error 22
7 createVehicleCrew <- BE error 23
7 deleteVehicleCrew <- BE error 24
7 allMissionObjects <- BE error 25
7 setAmmo <- BE error 26
7 setDammage <- BE error 27
7 setDamage <- BE error 28
7 allVariables <- BE error 29
7 allPlayers <- BE error 30
7 playableUnits <- BE error 31
7 allUnits <- BE error 32
7 entities <- BE error 33
7 isPlayer <- BE error 34
7 Exile_unit_player <- BE error 35
7 allGroups <- BE error 36
7 units <- BE error 37
7 exec <- BE error 38
7 camCreate <- BE error 39
7 selectCamera <- BE error 40
7 ExileClient_gui_safezone_safeESP <- BE error 41
7 removeMPEventHandler <- BE error 42
7 removeAllMPEventHandlers <- BE error 43

 

1 person likes this

Share this post


Link to post
Share on other sites

Stuck again... :(

_posV = getPos _v;
_smoke1 = "#particlesource" createVehicleLocal getpos _v;
_smoke1 attachTo [_v,[0,0,0],"engine_effe"
7 "" !="Exile_Unit_GhostPlayer" !="Steerable_Parachute_F" !"CMflare" !"I_UAV" !"LaserTarget" !"SLAM" !"SatchelCharge_Remote_Ammo" !"DemoCharge" !"ClaymoreDirectionalMine" !"IEDUrban" !"G_40mm_" !"F_40mm_" !="Exile_Ammo_Swing" !"F_Signal" !="I_IRStrobe" !="O_IRStrobe" !="NVG_TargetG" !"WeaponHolder" !"Supply" !"B_" !"SmokeShell" !"IEDLand" !"APERS" !="O_HMG_01_weapon_F" !="O_HMG_01_F" !="O_HMG_01_support_F" !"Chemlight" !="GrenadeHand" !="mini_Grenade" !="SmokeLauncherAmmo" !="Sign_Arrow_F" !="_v)} do {\n_posV = getPos _v;\n_smoke1 = \"#particlesource\" createVehicleLocal getpos _v;\n_smoke1 attachTo [_v,[0,0,0],\"engine_effe"

 

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.