C][G GhostTown™

contaminated zones and Gas Mask.

42 posts in this topic

Hello there!

I am running Napf and got most of my stuff finally fixed but have a few questions.

FIrst off is the Contaminated Zones, I want to have a zone here at my marker - http://imgur.com/ENBzgDg

I added the marker location in my config as 

Spoiler

class Radiation 
        {
            // 1 = enabled, 0 = disabled
            enable = 1;

            /*
                Defines contaminated zones in a specific map. 
                You can define multiple zones per map. The format
                of the zones is:

                [Position ASL(!), Full Radiation Radius, Maximum Radius]

                The radius works as follows:

                |-------------------------------------------------------|
                                    Maximum Radius
                
                |------------------------|
                  Full Radiation Radius   

                Within the full radiation radius, radiation factor is
                always at a maximum. Outside of this, it lowers down
                to no radiation smoothly.

                Radiation:

                |------------------------|------------------------------|
                1        1      1        1     0.75    0.5     0.25    0
            */
            contaminatedZones[] = {16403.842,18412.756,0.00143814, 450, 900};
        };

But yet once ingame, Nothing happens? Has no affect in the area at all. Did I imput the cords wrong?

 

Also on another server we was playing in the meantime when wearing the gas mask it had a cool overlay and made it appear you was wearing the mask in first person, but yet on my server it has no affect on vision? is there a config for that or did I do something wrong? or was that a custom feature?

 

Also I noticed that our body temps and Climate never change. Is this due to it being a custom map? is that also why the zones don't work?

Share this post


Link to post
Share on other sites

By the looks of it you haven't got the right co ords.

The clue is in the config.

    [Position ASL(!),

Goto where you want to setup the zone.

if you have infistar open adminconsole

paste this into it

_pos = getPosASL player;
_dir = getDir player;
_str = format ["{ { %1, %2, %3 }, %4 }", (_pos select 0), (_pos select 1), (_pos select 2), _dir];
copyToClipboard _str;
hint _str;

Run it, will show you the co ords at the top of the screen.

You only need the 1st 3 numbers. The 4th is direction which isn't needed,

Share this post


Link to post
Share on other sites
Advertisement

I just tried it on Chernarus with ASL coords nothing happens. Someone already got this to work?

class Radiation 
        {
            // 1 = enabled, 0 = disabled
            enable = 1;

            /*
                Defines contaminated zones in a specific map. 
                You can define multiple zones per map. The format
                of the zones is:

                [Position ASL(!), Full Radiation Radius, Maximum Radius]

                The radius works as follows:

                |-------------------------------------------------------|
                                    Maximum Radius
                
                |------------------------|
                  Full Radiation Radius   

                Within the full radiation radius, radiation factor is
                always at a maximum. Outside of this, it lowers down
                to no radiation smoothly.

                Radiation:

                |------------------------|------------------------------|
                1        1      1        1     0.75    0.5     0.25    0
            */
            contaminatedZones[] = {1449,23,14116.9,411.207,80,140};
        };

Share this post


Link to post
Share on other sites

Posted (edited)

You guys just using the wrong "formating" it needs to look like this :

		class Radiation 
		{
			// 1 = enabled, 0 = disabled
			enable = 1;


			contaminatedZones[] = {
				{{8464.13,  25060.8,   110.8}, 130, 330}
			};
		};

 

Edited by Bluea
1 person likes this

Share this post


Link to post
Share on other sites

Lol, just wanted to post now, got it working. Was indeed the formatting :)

Share this post


Link to post
Share on other sites

So am I doing something wrong here? I followed the instructions and still not working.

 

Spoiler

class Radiation 
        {
            // 1 = enabled, 0 = disabled
            enable = 1;

            /*
                Defines contaminated zones in a specific map. 
                You can define multiple zones per map. The format
                of the zones is:

                [Position ASL(!), Full Radiation Radius, Maximum Radius]

                The radius works as follows:

                |-------------------------------------------------------|
                                    Maximum Radius
                
                |------------------------|
                  Full Radiation Radius   

                Within the full radiation radius, radiation factor is
                always at a maximum. Outside of this, it lowers down
                to no radiation smoothly.

                Radiation:

                |------------------------|------------------------------|
                1        1      1        1     0.75    0.5     0.25    0
            */
            contaminatedZones[] = {
                {{16375.8, 18431.7, 40.0847}, 450, 900}
        };
    };

 

Share this post


Link to post
Share on other sites
On 9.3.2016 at 10:53 AM, Bluea said:

You guys just using the wrong "formating" it needs to look like this :


		class Radiation 
		{
			// 1 = enabled, 0 = disabled
			enable = 1;


			contaminatedZones[] = {
				{{8464.13,  25060.8,   110.8}, 130, 330}
			};
		};

 

@C][G GhostTown™ : got the same problem, no radiation is working

mine looks like this :

Spoiler

class Radiation 
        {
            // 1 = enabled, 0 = disabled
            enable = 1;


            contaminatedZones[] = {
                {{3616.48,  13077.3,   10.414}, 250, 500},
                {{9655.69,  12497.4,   14.5557}, 250, 500},
                {{14067,  18636.4,   27.4435}, 250, 500},
                {{16832.1,  12673.2,   24.0014}, 250, 500},
                {{25696.4,  21321.4,   20.1764}, 250, 500}
            };
        };

Share this post


Link to post
Share on other sites
26 minutes ago, hieve said:

@C][G GhostTown™ : got the same problem, no radiation is working

mine looks like this :

  Reveal hidden contents

class Radiation 
        {
            // 1 = enabled, 0 = disabled
            enable = 1;


            contaminatedZones[] = {
                {{3616.48,  13077.3,   10.414}, 250, 500},
                {{9655.69,  12497.4,   14.5557}, 250, 500},
                {{14067,  18636.4,   27.4435}, 250, 500},
                {{16832.1,  12673.2,   24.0014}, 250, 500},
                {{25696.4,  21321.4,   20.1764}, 250, 500}
            };
        };

Do these only work on Altis or custom maps as well?

Share this post


Link to post
Share on other sites
21 minutes ago, C][G GhostTown™ said:

Do these only work on Altis or custom maps as well?

these are my altis ones, kavala,zaros,pyrgos,athira and sofia, but like i said they do not work :/ it worked once, then i restarted 2-3 times and nothing, but i changed nothing of this part ..

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.