S.

solved Adding vehicles to Traders

36 posts in this topic

Thanks goes out to Paul for highlighting the error of my ways

Instructions:

Edit config.cpp in your mpmissions>exile.altis.pbo
Add required vehicle under the following subsections:


class CfgExileArsenal

///////////////////////////////////////////////////////////////////////////////
// HEMMT
///////////////////////////////////////////////////////////////////////////////
    class Exile_Car_HEMMT                                   { quality = 1; price = 3000; };
    class B_Truck_01_transport_F                          { quality = 1; price = 3000; };
    class B_Truck_01_covered_F                           { quality = 1; price = 3100; };
    class B_Truck_01_box_F                                 { quality = 1; price = 3200; };

class CfgTraderCategorie

  class Trucks
    {
        name = "Trucks";
        icon = "a3\ui_f\data\gui\Rsc\RscDisplayArsenal\itemacc_ca.paa";
        items[] = 
        {
            "Exile_Car_Van_Black",
            "Exile_Car_Van_Box_Black",
            "Exile_Car_Van_Fuel_Black",
            "Exile_Car_Zamak",
            "Exile_Car_Tempest",
            "Exile_Car_HEMMT",
            "B_Truck_01_transport_F",
            "B_Truck_01_covered_F",
            "B_Truck_01_box_F"

        };
    };

Repack mission pbo file.

DONE 

Edited by S.
1 person likes this

Share this post


Link to post
Share on other sites

it's easy, but how to add vehicles to community trader (or how to choose type of dialog (items/vehicles) to show)

Edited by N3V3RD134L0N3

Share this post


Link to post
Share on other sites
Advertisement

Thanks for the info. Do you not have to setup the values for inventory capacity, armor, etc? Or does Exile use some predefined ArmA 3 values?

Share this post


Link to post
Share on other sites

How can i add a Pawnee ah-99 this way, have tried but server doesnt load :)

Snap.. I've tried all ways from posts on the forum.. Server status just shows waiting.. Soon as i remove them it goes back to playing.. 

Share this post


Link to post
Share on other sites

OH sorry, i done it now.  works fine,

Are you adding them in both places.  Config.cpp

///////////////////////////////////////////////////////////////////////////////
    // Armed Choppers
    ///////////////////////////////////////////////////////////////////////////////
    class B_Heli_Light_01_armed_F                { quality = 1; price = 12500; };


 and same file but further down

class Choppers
    {
        name = "Helicopters";
        icon = "a3\ui_f\data\gui\Rsc\RscDisplayArsenal\itemacc_ca.paa";
        items[] = 
        {
            "Exile_Chopper_Hummingbird_Green",
            "Exile_Chopper_Hummingbird_Civillian_Wasp",
            "Exile_Chopper_Taru_Black",
            "Exile_Chopper_Taru_Covered_Black",
            "Exile_Chopper_Taru_Transport_Black",
            "Exile_Chopper_Orca_BlackCustom",
            "Exile_Chopper_Mohawk_FIA",
            "Exile_Chopper_Huron_Black",
            "Exile_Chopper_Hellcat_Green",
            "B_Heli_Light_01_armed_F"

 

 

Share this post


Link to post
Share on other sites

OH sorry, i done it now.  works fine,

Are you adding them in both places.  Config.cpp

Hidden Content


 and same file but further down

Hidden Content

 

Yeah ive added in both places.. I wanted to add jets, but it didn't work and server just stayed at waiting on the status.. I then removed the bits i added and just tried the truck way and just had the same out come :( 

Share this post


Link to post
Share on other sites

Yeah ive added in both places.. I wanted to add jets, but it didn't work and server just stayed at waiting on the status.. I then removed the bits i added and just tried the truck way and just had the same out come :( 

same problem server stays stuck on waiting.

 

Share this post


Link to post
Share on other sites

Yeah ive added in both places.. I wanted to add jets, but it didn't work and server just stayed at waiting on the status.. I then removed the bits i added and just tried the truck way and just had the same out come :( 

Like this look:

	///////////////////////////////////////////////////////////////////////////////
	// Planes
	///////////////////////////////////////////////////////////////////////////////
	class Exile_Plane_Cessna									{ quality = 1; price = 4000; };
	class B_Plane_CAS_01_F										{ quality = 9000; price = 150000; };
	class O_Plane_CAS_02_F										{ quality = 9000; price = 150000; };
	class I_Plane_Fighter_03_CAS_F								{ quality = 9000; price = 150000; };
	class I_Plane_Fighter_03_AA_F								{ quality = 9000; price = 150000; };

That sets the price, and then:

	class Planes
	{
		name = "Planes";
		icon = "a3\ui_f\data\gui\Rsc\RscDisplayArsenal\itemacc_ca.paa";
		items[] = 
		{
			"Exile_Plane_Cessna",
			"B_Plane_CAS_01_F",
			"O_Plane_CAS_02_F",
			"I_Plane_Fighter_03_CAS_F",
			"I_Plane_Fighter_03_AA_F"
		};
	};

That adds them to the trader itself.

You dont have to have them in both places. We currently have a price set in the top section for rockets, but dont have them in the trader. And if they are in the bottom section but not the top, they show in the trader with a 0 price.

How can i add a Pawnee ah-99 this way, have tried but server doesnt load :)

The pawnee would be (i've added mine to a new custom section for the price so they're easy to find):

	///////////////////////////////////////////////////////////////////////////////
	// Custom Added Vehicles
	///////////////////////////////////////////////////////////////////////////////
	class B_Heli_Transport_01_F							{ quality = 9000; price = 50000; };
	class B_Heli_Transport_01_camo_F					{ quality = 9000; price = 50000; };
	class B_Truck_01_Repair_F							{ quality = 1; price = 5000; };
	class B_Truck_01_ammo_F								{ quality = 1; price = 5000; };
	class B_Truck_01_fuel_F								{ quality = 1; price = 5000; };
	class B_Truck_01_medical_F							{ quality = 1; price = 5000; };
	class B_Heli_Light_01_armed_F						{ quality = 1; price = 10000; };
	class Choppers
	{
		name = "Helicopters";
		icon = "a3\ui_f\data\gui\Rsc\RscDisplayArsenal\itemacc_ca.paa";
		items[] = 
		{
			"Exile_Chopper_Hummingbird_Green",
			"Exile_Chopper_Hummingbird_Civillian_Wasp",
			"Exile_Chopper_Taru_Black",
			"Exile_Chopper_Taru_Covered_Black",
			"Exile_Chopper_Taru_Transport_Black",
			"Exile_Chopper_Orca_BlackCustom",
			"Exile_Chopper_Mohawk_FIA",
			"Exile_Chopper_Huron_Black",
			"Exile_Chopper_Hellcat_Green",
			"B_Heli_Transport_01_F",
			"B_Heli_Transport_01_camo_F",
			"B_Heli_Light_01_armed_F"

		};
	};

Just added this to our server (we had a request for it anyway), and it starts fine.

You can get all of the vehicle names from: https://community.bistudio.com/wiki/Arma_3_CfgVehicles_WEST

Also, for some of the vehicles you need to add a custom control to lock them: Go to Menu > Configure > Controls > Select custom controls from the list (2nd one up) > Use Action 1 > "U" (U is unassigned by default)

1 person likes this

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.