• 0
Pixmaip

Unable to connect with RCON

Question

Posted (edited)

Hi everyone.

I know there are a lot of existing threads about that subject: I read and tried all of them. But I still can't get my RCON to work.

First of all, I am running a Linux server (Ubuntu 15.04) so: NOT Windows. The RCON password is set in the BEServer.cfg in /serverroot/battleye/. The same password is set in the repacked exile_server_config.pbo and in the config.cfg. My startup script contains the option "-bepath=[path-to-battleye]" (this path is also correct). I double-checked everything I just said.

The server is perfectly running, I can join and play on it. Battleye is running (the console is showing it, and I can get kicked for using non-authorized scripts). I tried to connect with a ton of different RCON tools like EPM, DaRT, MsRcon... even locally from a python script (as all of the RCON tools are Windows-only) and it didn't work. Here's some of the errors:

Connection failed for server : [servername]
Couldn't connect to server!
2016-03-13 13:11:50,344 INFO Connecting to 127.0.0.1:2302 #1
2016-03-13 13:11:50,344 DEBUG Sending login information
2016-03-13 13:12:00,355 ERROR Socket timeout: timed out
[2016-03-13 | 12:53:55] Failed to connect. Please make sure that you properly set a password in beserver.cfg and the server is running.

I know these errors are not really helping but this is the only thing I have.

I spent the last 3 hours (and the entire last night) searching the internet for clues, but after all this time, still nothing.

Can you help me find a solution?

 

Thanks to you all,

Pixmaip.

Edited by Pixmaip

Share this post


Link to post
Share on other sites

16 answers to this question

  • 0

You don't need the -bepath, if you are using -profiles=.... then your battleye path should be inside of the folder named ...., inside of that battleye folder, make sure you create a BEServer.cfg:

RConPassword CHANGEME
MaxPing 600

This should resolve your issue.

1 person likes this

Share this post


Link to post
Share on other sites
  • 0

So I tried the -profiles=XXX option. It created a folder named XXX in my server root but not a battleye folder. So I created a battleye folder in which I added my BEServer.cfg, with the proper RCON password. But still nothing, impossible to connect with any of the RCON tools.

Share this post


Link to post
Share on other sites
Advertisement
  • 0

Posted (edited)

add to your launch peramaters -name=XXX, make sure you also remove -bepath

Edited by †RiH† StokesMagee

Share this post


Link to post
Share on other sites
  • 0

I already removed -bepath and I tried the -name=XXX option, still nothing.

I'm starting to think that I'm not using the right tool to connect to the RCON. What tool are you using (or you know would work) ?

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.