BetterDeadThanZed

Adding new objects to Esseker

21 posts in this topic

I have been adding custom buildings and objects to my Exile servers since I started working on them. I use this method to add them: 

I've begun working on Esseker. I'm setting up a small trader post, which I've done many times before. For some reason, when I place objects in the area of the map that has that gas station with the walls, wrecks, etc, surrounding it, the objects I'm placing aren't showing up on the server. To be sure I wasn't doing something wrong, I placed a random building on the airfield and it appeared. Here's a screenshot of the items placed in the editor:

20160320101109_1.thumb.jpg.85d9914b7e62c

Here's what I see in-game.

20160320101343_1.thumb.jpg.83aa69fb6d164

Strange that items placed elsewhere show up but when placed at this location, they vanish. I even added a debug line in the fn_init.sqf of the a3_custom.pbo to ensure the sqf was being loaded and it is. There are no errors on client or server side. 

Anyone have any suggestions on this?

Share this post


Link to post
Share on other sites

I'm pretty sure these items are sinking into the ground, as the vehicles are sinking into the ground too, per my topic in the "Maps" sub forum. I added them via the Initserver.sqf and they show up fine.

Share this post


Link to post
Share on other sites
Advertisement

How long are you waiting? Depending on your server, objects can take a while to load in.

Also, I would check your initServer.sqf for mistakes, I have missed a comma more times than I care to remember -

["land_seb_residental",[4972.45,8044.18,-0.192459],350.455,[[-0.165829,0.986154,0],[0,0,1]],false],
    ["Land_Misc_GContainer_Big",[5007.45,8060.39,0],310.909,[[-0.755749,0.654861,0],[0,0,1]],false],
    ["Land_cargo_addon01_V1_F",[4988,8007.71,0.482025],0,[[0,1,0],[0,0,1]],false],
    ["Land_cargo_addon01_V2_F",[4992.02,8007.71,0.64748],0,[[0,1,0],[0,0,1]],false],
    ["Land_PaperBox_open_empty_F",[4972.69,8041.18,4.70987],346.818,[[-0.228045,0.973651,0],[0,0,1]],false],
    ["Exile_Cosmetic_MG",[4966.37,8039.5,4.84768],173.182,[[0.118716,-0.992928,0],[0,-0,1]],false],
    ["Exile_Cosmetic_UAV",[4968.37,8039.81,4.71871],36.8182,[[0.599278,0.800541,0],[0,0,1]],false],
    ["Land_TableDesk_F",[5013.31,8011.31,4.12627],271.818,[[-0.999497,0.0317282,0],[0,0,1]],false],
    ["Land_WaterCooler_01_old_F",[4968.42,8047.3,4.72985],167.727,[[0.212565,-0.977147,0],[0,-0,1]],false],
    ["Land_ShelvesWooden_F",[5010.98,8010.87,4.12627],0,[[0,1,0],[0,0,1]],false],
    ["Land_Metal_rack_F",[4969.41,8047.53,4.72985],168.182,[[0.204806,-0.978803,0],[0,-0,1]],false],
    ["Land_Box_AmmoOld_F",[4971.42,8046.43,4.68838],310.455,[[-0.760916,0.648851,0],[0,0,1]],false],
    ["Land_CratesShabby_F",[4971.71,8050.85,4.6806],350.455,[[-0.16583,0.986154,0],[0,0,1]],false],
    ["Land_LuggageHeap_03_F",[4966.07,8040.06,0.479908],15,[[0.258819,0.965926,0],[0,0,1]],false],
    ["Land_LuggageHeap_02_F",[4965.52,8042.85,0.55238],354.091,[[-0.102951,0.994686,0],[0,0,1]],false],
    ["Land_LuggageHeap_01_F",[4965.5,8045.31,0.641945],0,[[0,1,0],[0,0,1]],false],
    ["land_mol_cr",[4367.94,4733.66,-2.67057],170,[[0.173647,-0.984808,0],[0,-0,1]],false],
    ["land_lodenice",[4353.54,4726.54,-0.00206777],186.364,[[-0.110839,-0.993838,0],[-0.101666,0.0113383,0.994754]],false],
    ["Land_PowerPoleWooden_L_off_F",[4367.56,4745.61,0],0,[[0,1,0],[0,0,1]],false],
    ["Land_RowBoat_V1_F",[4377.78,4732.28,0],32.7273,[[0.540641,0.841254,0],[0,0,1]],false] //Here... for example
    ["Land_RowBoat_V2_F",[4328.54,4732.59,0],288.182,[[-0.950071,0.312034,0],[0,0,1]],false],
    ["Land_RowBoat_V3_F",[4364.75,4745.36,0],13.6364,[[0.235759,0.971811,0],[0,0,1]],false],
    ["Land_RowBoat_V2_F",[4351.05,4744.07,0],113.182,[[0.91926,-0.39365,0],[0,-0,1]],false],
    ["Land_RowBoat_V1_F",[9127.52,10100,0],0,[[0,1,0],[0,0,1]],false],
    ["Land_RowBoat_V2_F",[9116.47,10094.3,-0.349067],278.636,[[-0.988661,0.150163,0],[-0.0252604,-0.166312,0.98575]],false],
    ["Land_RowBoat_V3_F",[9105.59,10070.7,0],286.818,[[-0.957228,0.289336,0],[0,0,1]],false]

 

Share this post


Link to post
Share on other sites

Posted (edited)

1 hour ago, John said:

How long are you waiting? Depending on your server, objects can take a while to load in.

Also, I would check your initServer.sqf for mistakes, I have missed a comma more times than I care to remember -

 

I think you misunderstand. The objects aren't appearing when putting them into a server side pbo. I use that method on my other two servers without a problem. I had to put them in initServer.sqf in order for them to appear. I don't like this method because I prefer all custom buildings/objects to be server side.

Since I also have a problem on Esseker where vehicles are spawning in under the ground, I'm guessing the same is happening to my added trader city objects in the server side pbo. Apparently when spawned client side, the same problem doesn't exist. As far as how long I'm waiting, it's a brand new test server with only me in the database, nothing built and no other added buildings/objects so slow server loading shouldn't be a factor.

Edited by BetterDeadThanZed

Share this post


Link to post
Share on other sites

Hi,
what Editor do you use? I had these issues with EDEN put some objects on a Table and in Game the Items are under the Ground. In Eden disable the simulation, in M3 i can´t remember but i think that was Physics?! Esseker has some trouble with the sea level Positions!

Greetz

Share this post


Link to post
Share on other sites

not having any issue using the same method, just switched over to the new Eden compatible m3editor and works fine.

Share this post


Link to post
Share on other sites
1 hour ago, Hoschi said:

Hi,
what Editor do you use? I had these issues with EDEN put some objects on a Table and in Game the Items are under the Ground. In Eden disable the simulation, in M3 i can´t remember but i think that was Physics?! Esseker has some trouble with the sea level Positions!

Greetz

I use m3editor. Works fine on my Lingor and Namalsk server. Esseker is different some how.

36 minutes ago, second_coming said:

not having any issue using the same method, just switched over to the new Eden compatible m3editor and works fine.

You put your custom buildings and objects in a server side pbo on Esseker and haven't experienced the same problem? As a test I put a building on the air strip on Esseker and it was sunk halfway into the ground with the server side pbo.

Share this post


Link to post
Share on other sites

Posted (edited)

not on Esseker, but I do the same for Altis, Chernarus and Namalsk all of which work no problem. Is the sea level different on Esseker?

 

Edited by second_coming

Share this post


Link to post
Share on other sites
5 minutes ago, second_coming said:

not on Esseker, but I do the same for Altis, Chernarus and Namalsk all of which work no problem. Is the sea level different on Esseker?

 

That's my whole point. I've never had problems like this on Lingor or Namalsk. There's no sea on Esseker but something is definitely different. Cars sink into the map too. I don't believe I haven't read about this before. It's a real shame because it's keeping me from putting up an Esseker server.

Share this post


Link to post
Share on other sites

Posted (edited)

Ok not a sea, but the River ist the deepest Point on that Map! Try to use the Eden Editor export the Buildings with 3DEN from Steam and put it in your Serverinit or a pbo! That Works! Dont forget to disable the simulation for static objects!!

Edited by Hoschi

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.