Higgins909

Server will not find extDB2

1 post in this topic

Posted (edited)

Every time I start my newish exile server, I get this.

Spoiler

23:09:36 "ExileServer - Server is loading..."
23:09:36 "ExileServer - ServerPassword MATCH! server locked for init"
23:09:36 Client: Nonnetwork object e40bac00.
23:09:36 "ExileServer - MySQL connection error!"
23:09:36 "ExileServer - Please have a look at @ExileServer/extDB/logs/ to find out what went wrong."
23:09:36 "ExileServer - MySQL Error: Unable to locate extDB2 extension!"
23:09:36 "ExileServer - Server will shutdown now :("

 

The server is linux, I installed libstdc++6 (32 went somewhere in it) got steam to update the arma files, changed the name of server, then changed the mysql as it will use a different database.  Allowed the mysql port through its firewall, it is now connecting through a LAN network, with the other computer also allowed port through.  I pretty much copied my working server to another computer, to config a bit differently and I can't figure out why it's not working.  The extDB2.so is in the folder, I even tried replacing it and the .dll.

I'm wondering if I'm missing some sort of package, like libstdc++6.  I know in my other server I was like screw it and installed about 6+ packages that were... dependency packages? as libxtdc++6 was one of them in the list.  Oh yeah, and the log file that it says it leaves behind... well it either does or doesn't and its got useless info. (It seems rather broken as I delete all the logs and then logs from other days, 30 days ago are there)

I've also restarted the computer and even added a new user with access to connect from anywhere, for mysql, and it still won't work.

Edit... installed libtbb2:i386  and some package that I thought was glibc...  I know get this issue after libtbb2:i386.  I've tried different shares and different users for the exdb2 config, and still get this.  Still no real logs in that folder.  One said it was connecting and then it was shutting down and nothing really inbetween.

Spoiler

 


 0:20:02 "ExileServer - Server is loading..."
 0:20:02 "ExileServer - ServerPassword MATCH! server locked for init"
 0:20:02 Client: Nonnetwork object e40c8c00.
 0:20:02 "ExileServer - Installed extDB2 version: 70"
 0:20:02 "ExileServer - MySQL connection error!"
 0:20:02 "ExileServer - Please have a look at @ExileServer/extDB/logs/ to find out what went wrong."
 0:20:02 "ExileServer - MySQL Error: Could not add database: [0,"Database Exception Error"]"
 0:20:02 "ExileServer - Server will shutdown now :("

 

Thanks,
Higgins909

Edited by Higgins909

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.