ertatu

PROBLEM: CPU to the fullest

40 posts in this topic

Hello guys, i have a problem with my server and I which is not the problem.

When the server restarts the cpu performance is 10%-15% but en 1 hours the cpu performance reaches 50%-60% only with 8-10 players
 
---------------------------------------------------------------------------------------------------------------------------------

I have the next mods: @DragonFire - @masvehicles 1.2 - @masweapons 1.9 - @Exile

---------------------------------------------------------------------------------------------------------------------------------

Map: Altis

---------------------------------------------------------------------------------------------------------------------------------

Scripts: Status Bar - loot table - DZE Missions - Invasion Mission - logo - traders

start parameters .bat: 

@echo off
REM Server
set serverkill="C:\Servidores\A3Exile"
cd /d %serverkill%
taskkill /im A3Exile.exe


REM Arrancar Server
timeout 5
start "arma3" /min /high "A3Exile.exe" -port=2302 "-config=xconfig\cfg\Config.cfg" "-profiles=xconfig\log" "-cfg=xconfig\cfg\basic.cfg" -name=Exile "-servermod=@ExileServer;@infiSTAR_servermod;@CBA_A3;@marma" "-mod=@Exile;@mas;@vehicles;@DragonFyre;" -world=empty -nosplash -noSound -noPause -autoinit -maxmem=14336 & -exThreads=4 -loadMissionToMemory -malloc=tbb4malloc_bi -enableHT

 

REM Arrancar BEC
timeout 30
set becpath="C:\Servidores\A3Exile\BEC"
cd /d %becpath%
start "batBEC" "bec.exe" -f Config.cfg --dsc

timeout 10
exit

---------------------------------------------------------------------------------------------------------------------------------

i adjunted images, cheak please.

I would appreciate any help .

 

If anyone needs more information just tell me.

 

 

 

 

Config PC.png

Rendimiento CPU.jpg

Share this post


Link to post
Share on other sites
Advertisement

First of all... Windows Server 2012.... WHY?!?!?!?!?! It's just Windows 10, with added server features ¬¬

2. CPU is underpowered
3. There is a lot of performance issues with A3 1.50, we're all waiting for 1.52, which hopefully will take care of the majority of performance issues, and fixes the headless clients. 

Benchmark your server, take off all the mods, get some players to join and collect the data, see if it makes any difference, that's always the first step in self-troubleshooting... Remove all mods, run it vanilla, collect data.

Edit: Why do you run Dragonfire / Dragonfyre on server end, it's a client mod.... 

Edited by ka0s

Share this post


Link to post
Share on other sites

-exThreads=4 or -enableHT not twice ... i think ^^

You can look here to know wich CPU was good for arma

https://www.cpubenchmark.net/singleThread.html

SingleThread was the way !

For me it's -exThreads=7 and -enableHT, I'm running a Octo-Core CPU, works very well with both parameters, if I remove -enableHT it'll utilize too much and gets frequent lag spikes without it, kinda strange, but that's just Arma being wierd again I guess -_-

Share this post


Link to post
Share on other sites

i use -exThreads=7

No enableHT

ertatu write: -exThreads=4 :o

omg ... just realise i'm wrong ...

-exThreads =/= cpucount xD
 

Enables the use of hyper-threading CPU cores which might slightly improve performance in certain scenarios. Note that this option may be overriden by -cpuCount so if you want to use maximum number of CPU cores use -enableHT without -cpuCount.


 

Share this post


Link to post
Share on other sites

-exThreads=1 -enableHT

i7 3770

exthreads =1 is enough for server...

So you run a quad core and deliberately gimp it, impressive.

Share this post


Link to post
Share on other sites

So you run a quad core and deliberately gimp it, impressive.

ARMA doesn't utilize the cores that well, it however rather wants higher single CPU speeds.

Share this post


Link to post
Share on other sites

ARMA doesn't utilize the cores that well, it however rather wants higher single CPU speeds.

Seems to be utilizing this quad core pretty well:

wC6Jwq4.jpg

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.