The Unknown

CUP Issues - Halp!

8 posts in this topic

Good day fine sir's.

I've been working on this new server and I'm beginning to get my head around it all, however I'm still very much a n00b at this stuff.

I'm currently running an Exile Namalsk and infiSTAR, on a server with some roaming Ai and missions, etc. and I was hoping to add CUP_Weapons, Vehicles and Units.

I've altered my loot tables to my liking and compiled them, added them into the exile_server_config, config file and I'm in the process of adding them to my trader too. I have however encountered an issue, which is that I can't get CUP_Weapons (the only one I'm currently trying out) to load onto the server. I've got @CBA_A3 and @CUP_Weapons in my server mods command line but neither of them are even acknowledged by the server on start up. I can connect to the server and play on it with no issues, but, no CUP_Weapons either :(

I feel I've overlooked something simple, but I'm a little stumped at the moment. :$

Any help would be most grateful and very appreciated :D

Share this post


Link to post
Share on other sites

Please pastebin your .RPT for review. In mine i can see when it loads by seeing this: 

Spoiler

22:37:16 Initializing Steam server - Game Port: 2302, Steam Query Port: 2303
22:37:16 Version: 2
22:37:16 GlobalFlags: 0
22:37:16 DLCFlags: 7
22:37:16 DLCHashes:
22:37:16 1460896055
22:37:16 -1310242515
22:37:16 228986908
22:37:16 Mods(5):
22:37:16 Hash: 1879839183
22:37:16 PublishedId: 497660133
22:37:16 Name: CUP Weapons 1.6
22:37:16 Hash: -307081782
22:37:16 PublishedId: 0
22:37:16 Name: CUP Terrains - Maps 1.0.1
22:37:16 Hash: -1346052004
22:37:16 PublishedId: 0
22:37:16 Name: CUP Terrains - Core 1.0.1
22:37:16 Hash: -1156253712
22:37:16 PublishedId: 0
22:37:16 Name: Community Base Addons v2.3.1
22:37:16 Hash: -97040573
22:37:16 PublishedId: 0
22:37:16 Name: Exile Mod
22:37:16 Difficulty: 0
22:37:16 AILevel: 0
22:37:16 FlightModel: 0
22:37:16 ThirdPersonCamera: 0
22:37:16 WeaponCrosshair: 0
22:37:16 Signatures:
22:37:16 a3
22:37:16 cba_2.3.1.160220-0b33c3c4
22:37:16 cup_terrains_core-1.0.1
22:37:16 cup_terrains_maps-1.0.1
22:37:16 cup_weapons-1.6.0
22:37:16 exile

 

Share this post


Link to post
Share on other sites
Advertisement

Thanks for the reply Mr.Karp.

I've luckily managed to get it sorted through sheer ignorance and determination. It turned out that despite "requiring" CBA_A3 to work.....it actually wouldn't work. Instead, I added ASDG_JR to the server and removed CBA_A3 and it worked instantly.

I am still having little issues in general (as I be n00b) but I'm beginning to get there. The server has taken massive strides forward in the last two weeks :D

 

Thanks again Mr.Karp :)

Share this post


Link to post
Share on other sites

Hey no problem! I have been pulling my hair out getting a Chernarus server up, but think i got most of it under control. What other issues are you having?

Share this post


Link to post
Share on other sites

Currently I'm running into some issues with the traders. For some weird reason my adding CUP weapons to the traders (along with it's ammo and attachements etc.) has caused the server to stop working. I've re-upped a working mission file till i figure out what exactly is wrong with it for now. I had found a few dupe's that I removed and hoped would solve the trick and also a missed comma....but...so far, no luck.

I think I will go back to a pre-edited mission file and re-add my weapons list. I'm sure it's something simple like a missed comma or a forgotten speech mark xD

 

Also, I'm not sure if anyone knows if it's possible to have 2 traders with the same items but different prices? My first guess would be a resounding, no. (As it would mean having the entry for an item twice in the price list and it has no way of telling which to use other than the class name...which...would of course be the same.

Share this post


Link to post
Share on other sites

Oh man, if you get that working with CUP weapons and addons please let me know, i haven't done that yet as i dont want to go bald quick.

But yea i would recommend starting from scratch and watching that syntax. Wish there was a formatter / checker online to check sqfs / arrays and what not for missing commas / semi-colons. But yea i would say missing comma :( 

Share this post


Link to post
Share on other sites

It's not been too bad really. If I get the shop working I'll happily post up the relevant segments for you to cut and paste :D

Should avoid all those nasty comma probs xD

Share this post


Link to post
Share on other sites
On 4/18/2016 at 1:30 PM, The Unknown said:

Currently I'm running into some issues with the traders. For some weird reason my adding CUP weapons to the traders (along with it's ammo and attachements etc.) has caused the server to stop working. I've re-upped a working mission file till i figure out what exactly is wrong with it for now. I had found a few dupe's that I removed and hoped would solve the trick and also a missed comma....but...so far, no luck.

I think I will go back to a pre-edited mission file and re-add my weapons list. I'm sure it's something simple like a missed comma or a forgotten speech mark xD

 

Also, I'm not sure if anyone knows if it's possible to have 2 traders with the same items but different prices? My first guess would be a resounding, no. (As it would mean having the entry for an item twice in the price list and it has no way of telling which to use other than the class name...which...would of course be the same.

For traders use this:

 

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.