• 0
Sign in to follow this  
Followers 0
Special Ed

Disabling Strict Mode SQL

Question

Hi,

I'm getting a Bambi Character Creation Timeout message and i'm trying to disable the strict mode in my sql as is mentioned in other posts.

My problem is that I cannot locate the file i need to do this. Other directories given with other posts aren't on my server at all and i'm sorta confused.

Could anyone help? Or tell me what sort of information they need to help?

Share this post


Link to post
Share on other sites

2 answers to this question

  • 0

If by "aren't on my server" you mean, your arma server. You're looking in the wrong place. MySQL server runs on it's own instance. If you are running your server from home or a dedi, 

Use keyboard shortcut (WinKey + R). 

 Enter “services.msc” and click “Ok”. 

Search for “MySQL57”, right click and stop service (Keep window open).

Enable hidden files in Explorer and navigate to “C:\ProgramData\MySQL\MySQL Server 5.7”.

Right click “my.ini” and select “Edit with Notepad++” .

Scroll down to and change the following text:  FROM  # Set the SQL mode to strict  sql-mode=

"STRICT_TRANS_TABLES,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION"    

TO  # Set the SQL mode to strict  sql-mode="".

Save and overwrite  “my.ini”.

Go back to “services.msc”. Right click “MySQL” and Start service. 

Share this post


Link to post
Share on other sites
  • 0

I'm now seeing this was a double post. xD Disregard

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.