Ronnie_McLovin

Sehr niedrige Server FPS

5 posts in this topic

Posted (edited)

Ich hoffe einer von euch kann mir helfen. Wir haben einen Exile Server auf Altis laufen.

Folgende Mods sind installiert mit dazugehöriger Konfiguration:

-Exile

-MAS Vehicles & Weapons

-DMS (3 Missionen, Slums und Mercenary sind deaktiviert)

A3XAI (12 Fahrzeug Patrols, alles andere deaktiviert)

Extended Base Mod

Ryan Zombies (gespawnt mit ExileZ 2 / 8 Zombies max. pro Spieler, Horde max. 20 Zombies. Rest ist aus)

 

So folgendes Problem:  Vorher hatten wie den Server auf nem vServer laufen. Da die Leistung da sehr schlecht war, sind wir nun auf einen dedicated Root gewechselt mit folgenden Leistungsdaten:

i7-4790K mit 4 x 4,0 GHz

32GB Ram

2 x 120GB SSD

 

Nun dachten wir, dass wir die Performance mit dem Server steigern könne, Fehlanzeige. Bei 50 Spielern liegen die Server FPS bei ca. 3FPS ....

Hat jemand Rat was man da tun könnte?

Hier noch die Startparameter:   -enableHT -maxMem=8192 -cpuCount=4

 

Ich weiss nicht mehr weiter. Ich höre von anderen mit ähnlicher oder sogar etwas schlechterer Hardware dass ihre Server mit noch mehr NPS's viel besser laufen -.-'

 

MfG Ronnie

 

Edit: Hab nun den Energie Modus der CPU auf volle Leistung gestellt. Ergebnis: 4 FPS mehr. Also liegen wir nun so bei 7 Server FPS. Also immer noch nicht was Wahre.

Edited by Ronnie_McLovin

Share this post


Link to post
Share on other sites

Posted (edited)

fehler im rpt log?

anzahl der objekte auf der map?

wieviele ai werden so im durchschnitt simuliert + peak?

max 8 zombies pro spieler bedeutet bei 50 leuten immerhin schon 400 aktive Zombies die simuliert werden müssen

headless client aktiv?

Edited by hieve

Share this post


Link to post
Share on other sites
Advertisement

Keine Fehler im RPT / 6000 gebaute Teile ca. / mission AI's ca. 60 nd halt die Zombies. Wollte schon mal die KI von den Missions und die Zombies per HC auslagern, steige da aber nicht wirklich durch. Da ich auch niemanden gefunden habe der mir auf dem Gebiet was erklären kann, hab ichs aufgegeben.

Share this post


Link to post
Share on other sites

Klingt ja nicht gerade System-schonend.^^

Wenn du mit knapp 500 Ki's + den 6000 Buildings + der 50 Spieler arbeitest, dann zieht das natürlich ordentlich. 

Habe selbst auch noch kein HC, aber mit dem FumS-Addon scheint es ganz plausibel zu sein. (ohne Hc 20 Spieler, 50 DMS-, 40 AXAI-Bots & 800 Buildings = 47fps) 

Werde heute früh es mal mit HC versuchen und kann dir dann berichten obs so einfach wie in der Anleitung ist^^.

Share this post


Link to post
Share on other sites

Das wäre auf jeden Fall ganz nett wenn du mir ein paar mehr Infos zum HC geben könntest.

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.