• 0
Harper9690

CUP/RHS

Question

Hello all,

    Im trying to get CUP/RHS to work on server. The problem im running into is the mods dont seem to be initializing on server startup. I dont believe that they are in the startup parameters. However I use VertHosting and I havent a clue how to add these. Ive found a custom command line area and made efforts but still no dice. The server plays just fine but the effects of not having this done right is that in all of the vendors the items just come up as blank unclickable boxes with prices next to them. Additionally the items arent spawning. Ive narrowed this down to this point and would love some help. Thanks!

Share this post


Link to post
Share on other sites

7 answers to this question

  • 0
8 hours ago, Harper9690 said:

 The problem im running into is the mods dont seem to be initializing on server startup.

I dont believe that they are in the startup parameters.

that is indeed why. I too use vert. Adding a custom startup is easy. Just add the mods in the first mods box. in the second one place this: -servermod=@ExileServer;

for an example, mine is:

-mod=@Exile;@Namalsk;
-servermod=@ExileServer;@infiSTAR_Exile;@A3XAI;@marma;
Be sure to add a ; after each mod, so also the last mod. If you need any more help hit me up.

Share this post


Link to post
Share on other sites
  • 0

Should post this in the right section. GD isn't made for support topics

Share this post


Link to post
Share on other sites
Advertisement
  • 0

Posted (edited)

Well how ive attempted to do this hasnt worked. It isnt initializing the mods still. Below is an example of the two lines im using based on what you said InsertCoins.

 

-mod=-mod=@Exile;@Namalsk; -config=C:\TCAFiles\Users\BenH\2284\ServerConfig\config.cfg -ip=216.244.79.109 -port=2302 -profiles=ServerConfig -cfg=C:\TCAFiles\Users\BenH\2284\ServerConfig\basic.cfg

-name=ServerConfig -autoInit -servermod=@ExileServer;@CBA_A3;@CUP_Units;@CUP_Vehicles;@CUP_Weapons;

 

Im just trying to add CUP Weapons, Vehicles, and Units to my server. Not sure what part im doing incorrectly.

 

 

 

 

 

 

 

Edited by Harper9690

Share this post


Link to post
Share on other sites
  • 0

So as it stands I have only RHS in the config file. Ive literally tried every combination of launch parameters and cannot get the mod to initialize so that RHS is in the vendors properly. Any suggestion or help with this? I use Vert Hosting.

Share this post


Link to post
Share on other sites
  • 0

Posted (edited)

you have the mods in the wrong parameters. they need to be as follows:

-mod=@Exile;@Namalsk;@CBA_A3;@CUP_Units;@CUP_Vehicles;@CUP_Weapons; -config=C:\TCAFiles\Users\BenH\2284\ServerConfig\config.cfg -ip=216.244.79.109 -port=2302 -profiles=ServerConfig -cfg=C:\TCAFiles\Users\BenH\2284\ServerConfig\basic.cfg

-name=ServerConfig -autoInit -servermod=@ExileServer;

Also pretty sure CBA requires a fix (google is your friend) to be compatible with this Exile patch.

 

Note: -servermod=  is only used for server mods (things player aren't required to download) like mARMA, or A3XAI....  -mod= are parameters for client/server mods that are downloaded by the players as well.

As far as the vendors, that requires more than just installing the mods. The best thing for this is THIS.

Edited by oSoDirty

Share this post


Link to post
Share on other sites
  • 0

This here is what I have input currently and it still isnt working. Going to play around with it more, but the UI im dealing with is not new user friendly, at all.

mod=@Exile;@RHSUSAF;@RHSAFRF; -config=C:\TCAFiles\Users\BenH\2284\ServerConfig\config.cfg -ip=216.244.79.109 -port=2302 -profiles=ServerConfig -cfg=C:\TCAFiles\Users\BenH\2284\ServerConfig\basic.cfg -name=ServerConfig -autoInit

 

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.