Flosstradamus

[SOLVED] 1.58 Bug Fixes/Discussion

426 posts in this topic

Discussion of bug fixes in here until the devs can implement some kind of patch.

Known Issues:

Safezone not working

CFG difficulties

Update 1

1.58.135673 profiling & performance v0 server and client, windows/linux
* sync with stable branch, some stuff ahead of main stable branch
https://www.dropbox.com/sh/582opsto4mmr8d8/3BSy9PdRGm

David Foltyn posted a new perf build.

Update 2

1.58.135689 profiling & performance v1 server and client, windows/linux
* more fixes of crashes,  joining mp game and VON
https://www.dropbox.com/sh/582opsto4mmr8d8/3BSy9PdRGm

Update 3

1.58.135712 profiling & performance v2 server and client, windows/linux
* fixed system allocator related crashes / issues
* fixed Difficulty tab no longer disabled after first mission on dedicated server
https://www.dropbox.com/sh/582opsto4mmr8d8/3BSy9PdRGm
https://drive.google.com/folderview?id=0B03-H4YIbhkFMUt5RzNqZjFlNGs

7 people like this

Share this post


Link to post
Share on other sites

SAFEZONE FIX

Create a file in your mission file at the same location as description.ext called init.sqf.
Then in that file paste this:

call ExileClient_system_map_initialize
13 people like this

Share this post


Link to post
Share on other sites
Advertisement

Posted (edited)

Beserver.cfg

Add RConIP and RConPort to this file
this is assuming you have a server IP of 192.192.192.192 and your game is running on 2302

RConPassword passwordhere
MaxPing 500
RConIP 192.192.192.192(reported only external IP works)
RConPort 2306

Don't forget to change your BEC config to reflect the ip/port change

I am using my server IP for RConIP and a dedicated port for RConPort and it works perfect for BEC and Dart and reported to also work for other Rcon utilities

 

Profile.arma3profile

difficulty="Custom";
class DifficultyPresets
{
	class CustomDifficulty
	{
		class Options
		{
			groupIndicators=2;
			friendlyTags=0;
			enemyTags=0;
			detectedMines=0;
			commands=0;
			waypoints=2;
			weaponInfo=2;
			stanceIndicator=0;
			reducedDamage=0;
			staminaBar=0;
			weaponCrosshair=1;
			visionAid=0;
			thirdPersonView=1;
			cameraShake=1;
			scoreTable=1;
			deathMessages=0;
			vonID=1;
			mapContent=0;
			autoReport=0;
			multipleSaves=0;
		};
		aiLevelPreset=2;
	};
	class CustomAILevel
	{
		skillAI=1;
		precisionAI=0;
	};
};

Use difficulty "Custom" in your servers config under the mission.

class Missions
{
	class Exile {
		template = Exile.napf; 
		difficulty = "Custom";    
	};
};

The above difficulty is the way ExileRegular is setup

Edited by DirtySanchez
18 people like this

Share this post


Link to post
Share on other sites

Having some weird bugs on our server as well. If I scope out a player or AI it displays their name, and then it will also display them on the map for a short period of time.

Also every player v player kill says (Friendly fire).

1 person likes this

Share this post


Link to post
Share on other sites
hey guys,
 
 
My Exile  was fine until the update now my server  cfgdifficulties are now not working correctly.
 
It was originally set to veteran and tweaked so curser and death message was deactivated.
After the update/ restart I was unable to use 3rd person mode which was previously working before the update.
And have reverted back to regular where players names show when pointed at and appear on the map.
 
This sucks =[
Kappa
 
 
 

Share this post


Link to post
Share on other sites
16 minutes ago, Mikeeeyy said:

SAFEZONE FIX

Create a file in your mission file at the same location as description.ext called init.sqf.
Then in that file paste this:


call ExileClient_system_map_initialize

Confirmed adding this line of code to the mission file Init.sqf will yield Proper Safezones :) Thx @Mikeeeyy

1 person likes this

Share this post


Link to post
Share on other sites
26 minutes ago, Mikeeeyy said:

SAFEZONE FIX

Create a file in your mission file at the same location as description.ext called init.sqf.
Then in that file paste this:


call ExileClient_system_map_initialize

But that would mean the preInit of Arma mods is now seriously fucked? o___O

Share this post


Link to post
Share on other sites

looks like you need alot of pizza and beer :D

2 people like this

Share this post


Link to post
Share on other sites
5 minutes ago, Eichi said:

But that would mean the preInit of Arma mods is now seriously fucked? o___O

I think allMapMarkers is firing too early, but idk why that would have changed. I remember trying to use it on preInit on server side and it returned an empty array.

Share this post


Link to post
Share on other sites

But the preInit is called after the mission was loaded. Did they change that? Didn't see anything in the changelogs that requires action from our side.

Share this post


Link to post
Share on other sites
Advertisement
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.