CameraChick

Importing SQL from Pre-0.96

10 posts in this topic

I saved an .SQL of the DB prior to 0.96. 

Now that we have updated, I am trying to import the SQL and for some reason, it won't load. Using HeidiSQL to do so. I have even tried importing ONLY the constructions, territories, and storages but to no avail.

Has anyone had luck with this or be willing to take a donation to connect via FTPzilla and work the magic? =) Paying here!

Share this post


Link to post
Share on other sites

Create a DB version equal to that of the DB, then upgrade? Rather than importing it into an already updated DB.

1 person likes this

Share this post


Link to post
Share on other sites
Advertisement
21 hours ago, kuplion said:

Create a DB version equal to that of the DB, then upgrade? Rather than importing it into an already updated DB.

Seems feasible. Doing some research to figure out how to do this.

Edited by CameraChick

Share this post


Link to post
Share on other sites

Update: This is the error from the report log:

15:47:52 "ExileServer - Done loading constructions!"
15:47:52 "ExileServer - Loading vehicles from database..."
15:47:52 "ExileServer - Done loading vehicles!"
15:47:52 "ExileServer - Loading containers from database..."
15:47:52 "ExileServer - Database Error: Error Statement Exception"
15:47:52 Error in expression <ase_handleBig;
};
};
(_result select 1) select 0>
15:47:52   Error position: <select 0>
15:47:52   Error Generic error in expression
15:47:52 File exile_server\code\ExileServer_system_database_query_selectSingle.sqf, line 27

Could this mean that there is only an issue within the container section that could be easily resolved?

Share this post


Link to post
Share on other sites

that error means you didnt update your /@exile_server/ext2db/custom/exile.ini

Share this post


Link to post
Share on other sites

After too long of trying this, I am paying someone to import this stuff into the DB. The server is ready to go, just need the .sql imported. Will pay via PayPal.

Share this post


Link to post
Share on other sites
20 minutes ago, DirtySanchez said:

@CameraChick

add some diag_log lines to the createcontainer.sqf in the server, boot up the test server and voila you will see the culprit that it is erroring on and IMHO just delete it out and throw the player some poptabs and a kiss!

This actually seems like a BRILLIANT idea! ... until I tried it. I couldn't find the createcontainer.sqf, and then realized I didn't even know how to put diag_log lines into it IF i found it!  AAAHHHH!!!!!

 

Share this post


Link to post
Share on other sites
7 hours ago, DirtySanchez said:

let me turn on my rdp while at work and I'll get you a file name, then I'll write a diag_log line here

Sanchez, did you have any luck? :) 

Share this post


Link to post
Share on other sites

RPT log shows a spam of:

Error in expression <tabase_query_selectSingle;
_position = [_data select 4, _data select 5, _data se>
Error position: <_data select 4, _data select 5, _data se>
Error Undefined variable in expression: _data
File exile_server\code\ExileServer_object_construction_database_load.sqf, line 15

 

That file, ExileServer_object_construction_database_load.sqf, line 15 shows:

_position = [_data select 4, _data select 5, _data select 6];

========================================================

Also:

"ExileServer - Database Error: Error Statement Exception"
Error in expression <ase_handleBig;
};
};
(_result select 1) select 0>
Error position: <select 0>
Error Generic error in expression
File exile_server\code\ExileServer_system_database_query_selectSingle.sqf, line 27

 

And Line 27 (the last line below) looks like this within that named file:

_result = call compile ("extDB2" callExtension _query);
switch (_result select 0) do
{
    case 0:
    {
        (format["Database Error: %1", (_result select 1)]) call ExileServer_util_log;
    };
    case 2:
    {
        _result = (_result select 1) call ExileServer_system_database_handleBig;
    };
};
(_result select 1) select 0

 

Something's really off here. There has to be a way to import this silly thing.

 

Edited by CameraChick

Share this post


Link to post
Share on other sites
4 minutes ago, DirtySanchez said:

 

Ok so now I have reread the whole post. So which is it are you having issues with containers or constructions?

You have given me two rpts with two different errors now. This is why people hesitate helping people....

I think I have given you enough info so that you can attempt to track this down and fix it on your own.

You need to add diag_log lines to all the create* files that exile has since you cant seem to lock down what your error is....

ExileServer_world_loadAllDatabaseConstructions

ExileServer_world_loadAllDatabaseContainers

ExileServer_world_loadAllDatabaseVehicles

ExileServer_world_loadAllTerritories

these are the loading files that exile uses, just add a diag_log to them and find your issue, I'm out of this one from here.....

Hi Sanchez-

I was in the process of replying to you and telling you that you were correct- it was me and it was line 18 that initially popped the error. I am sorry that it has come across the way that it apparently has; I know exactly what you mean when people hesitate helping others and why. For that, I am sorry.

I do have enough information to continue combing through all of this and trying to figure things out. I am not good with this, as you can tell, which is why I initially just offered to pay someone. I would much rather make a donation to someone via PayPal for their time and have it done right than expect someone to waste their time trying to poke through things via me as the mediator. As you can see, I know just enough to create more problems.

I will continue to work this out and will post my results when successful so that anyone else who may encounter this issue can use it to their advantage. I honestly agree with you wholeheartedly and apologize if this came across as an absolute disaster on my end. Thank you for the help you provided. 

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.