Zeito

[Solved] I must have something wrong

12 posts in this topic

I followed the guide put up by @S. to put together a server for my friends and I to play on and mess around on. It runs like a dream and I managed to get it set up, add a few mods like DMS and Occupation. But i must have either massively missed something with BattleEye, or there's something weird going on.

None of us have ever been kicked for a restriction, or anything like that. Yet I've not touched any filters. BattleEye = 1; is in my @ExileServer\config.cfg but i'm assuming there's more to it than that?

I currently don't have infistar, so what hoping BE would somewhat prevent some cheating (server is public-facing).

Am i some kind of crazy genius who has managed to avoid running into filters, or have i missed the mark big time and battleeye isn't doing squat?

My money is on the latter.

Share this post


Link to post
Share on other sites

I think you may find battleye is not loading the filters from were you want it to whats your start up prams and were are your filters located ?

Edit. Saying that if its just  DMS and Occupation and you do not have it offloading ai to client or your ai don't fire rpg's you might be ok

Share this post


Link to post
Share on other sites
Advertisement

Occupation doesn't require BE filters editing and I don't think DMS does either.

Share this post


Link to post
Share on other sites

@JamieKG @second_coming I'm not sure - i've not changed anything related to BE. I do have a server\battleye\scripts.txt with all sorts of entries in it.

I am just using DMS and Occupation, AI have launchers, use them, and i can pick them up and use them too. I even added them to traders (though buying the launcher just takes the money but not a big deal) and they work fine.

I have just stuck ZCP on for a a laugh so i suppose i'll see if theres any BE weirdness going on when i next join.

Share this post


Link to post
Share on other sites

If your server is using the -profiles= launch peramater, then your battleye folder should be located inside of the name of -profiles. if you don't use -profiles= then you should :P and just put the filters inside the battleye folder generated inside of the profile name.

Share this post


Link to post
Share on other sites
40 minutes ago, second_coming said:

Occupation doesn't require BE filters editing and I don't think DMS does either.

if a AI fires a rpg that is offloaded to a client ?

Share this post


Link to post
Share on other sites
10 minutes ago, †RiH† StokesMagee said:

If your server is using the -profiles= launch peramater, then your battleye folder should be located inside of the name of -profiles. if you don't use -profiles= then you should :P and just put the filters inside the battleye folder generated inside of the profile name.

Aha, I am using that param, but i dont think the folder is under the profile, it's just in the server root.

Share this post


Link to post
Share on other sites
4 minutes ago, Zeito said:

Aha, I am using that param, but i dont think the folder is under the profile, it's just in the server root.

it should be

Share this post


Link to post
Share on other sites
12 minutes ago, JamieKG said:

if a AI fires a rpg that is offloaded to a client ?

I've not known it cause problems but who knows :D

Share this post


Link to post
Share on other sites
17 minutes ago, †RiH† StokesMagee said:

it should be

I'll move it over and see how it goes, i imagine i'll start getting kicked for all sorts!

11 minutes ago, second_coming said:

I've not known it cause problems but who knows :D

I have the offloadtoClient enabled in DMS and i dont think it's caused any issues so far!

Share this post


Link to post
Share on other sites
Advertisement
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.