Question

hello everyone,

so far for those 2 days i have been having issue with my virtual rented server crashing on its own after approx 2.30h of start time, server cycle we use is 4h, and i have checked the RPT log the last 20 lines were showing this:

Quote

 

Virtual memory total 4095 MB (4294836224 B)
14:39:11 Virtual memory free 135 MB (141942784 B)
14:39:11 Physical memory free 17547 MB (18400161792 B)
14:39:11 Page file free 40290 MB (42247921664 B)
14:39:11 Process working set 3265 MB (3424342016 B)
14:39:11 Process page file used 3649 MB (3826626560 B)
14:39:11 Longest free VM region: 4063232 B
14:39:11 VM busy 4170436608 B (reserved 204926976 B, committed 3965509632 B, mapped 43053056 B), free 124399616 B
14:39:11 Small mapped regions: 17, size 77824 B
ErrorMessage: Out of memory (requested 189 KB).
footprint 3328245760 KB.
pages 81920 KB.

14:45:08 NetServer::finishDestroyPlayer(875047921): DESTROY immediately after CREATE, both cancelled

 


 

i tried to search and make my own resolution out of it for 2 days so far and i still not able to get it fixed, 

server run 4 mods now only ( Exile,CBA,CUPunits,CUPweapons,CUPvehicles) before we had Ryanzombies + infection also on it that i removed after reading alot of post saying that this might have been the issue crashing the server. anw for those interested this is my RPT logs:

http://pastebin.com/u191SbbY

any help is much appreciated

thx 

Share this post


Link to post
Share on other sites

8 answers to this question

  • 0
37 minutes ago, Vurama said:

hello everyone,

so far for those 2 days i have been having issue with my virtual rented server crashing on its own after approx 2.30h of start time, server cycle we use is 4h, and i have checked the RPT log the last 20 lines were showing this:

i tried to search and make my own resolution out of it for 2 days so far and i still not able to get it fixed, 

server run 4 mods now only ( Exile,CBA,CUPunits,CUPweapons,CUPvehicles) before we had Ryanzombies + infection also on it that i removed after reading alot of post saying that this might have been the issue crashing the server. anw for those interested this is my RPT logs:

http://pastebin.com/u191SbbY

any help is much appreciated

thx 

not pointing fingers here.... so anyone reading this, PLEASE don't interject "ITS NOT THE MOD" -- this is only a test....

Root cause on this is very clearly 1 of 2 things. A MySQL read write violation (which is right in the error) or a memory leak from a mod that's running.

I would do 2 things to test this.

1) Increase your tiny page file to the same size as your ram (requires a VM restart). THEN test the solution for at least 2 server cycles (8 hours) before trusting the change.

This can fix the issue simply by adding more available memory, but the fix would be a bandaid. IF this resolves the issue, then I would set the page file back to where it was and continue to step 2.

2)  I would then try to disable the mod that was the last entry in the RPT with an error "OCCUPATION". Test for 2 server cycles and see if the memory leak is gone.

 If the server does not crash, you have determined the memory leak is within the MOD with "occupation" in it (MOST LIKELY - again not blaming a MOD for this).

Here is a breakdown of what you are seeing in the RPT for the memory error and how to determine a leak (Sort of).

  1. 15:45:06 Virtual memory total 4095 MB (4294836224 B) <--- this is the amount that you allocated to the VM.
  2. 15:45:06 Virtual memory free 108 MB (113504256 B) <--- this is the amount of page file memory that you had free at the crash time (Note the 108 for later).
  3. 15:45:06 Physical memory free 17400 MB (18245316608 B) <------- This is the total VMware Host SERVER RAM available, at the time of crash.
  4. 15:45:06 Page file free 40171 MB (42122932224 B)  <-- this does not match item 1 so we will ignore it, and move past like it never happened).
  5. 15:45:06 Process working set 3256 MB (3414732800 B) <---- this is what Arma 3 was using at time of crash (yes that is WAY more than it should).
  6. 15:45:06 Process page file used 3682 MB (3861270528 B) <---- this is what all processes were using when the server crashed.
  7. 15:45:06 Longest free VM region: 4128768 B <---- This looks like something related to a thin provisioned VMware disk.
  8. 15:45:06 VM busy 4198912000 B (reserved 199155712 B, committed 3999756288 B, mapped 42655744 B), free 95924224 B <------ Ignore for now.
  9. 15:45:06 Small mapped regions: 17, size 77824 B <---- ignore again since I have no idea what this is. Its either game related or DB related.
  10. ErrorMessage: Out of memory (requested 213 KB). <--- this is WHY the server crashed, it was trying to write data to the page file, since the RAM was full. The page file only had 108MB available and you cant fit 213 into 108 = crash
  11.   footprint 3339517952 KB. <--- this is how much RAM is used at server crash time this means the actual gaming server had 911 MB of free ram out of 4GB  = WHAT ?! that's WAY to much usage. If the memory was commited (and arma did not crash releasing the RAM) the server would have blue screened.
  12.   pages 81920 KB. < ---- This is your page file windows has allocated. It is also almost double the RAM. If this was Windows XP, then it would have been ok. This is SERVER and it should Never ever be more than your total RAM.
Hope this helps

Share this post


Link to post
Share on other sites
  • 0

Posted (edited)

we had a lot of "out of memory" crashes aswell lately. our guess:

its caused by some idiots who dupe at the traders. all the clients have suddenly 4-5 fps only then... so stupid... we catched some idiots while doing it... :(

Edited by yesyesjo
1 person likes this

Share this post


Link to post
Share on other sites
Advertisement
  • 0
7 minutes ago, yesyesjo said:

we had a lot of "out of memory" crashes aswell lately. our guess:

its caused by some idiots who dupe at the traders. all the clients have suddenly 4-5 fps only then... so stupid... we catched some idiots while doing it... :(

Don't allow the selling of ANY attachments on your server. Sell them, have them in loot, missions and as other rewards, but stop the ability to sell. Duping stops.

As an example.

They get over it fast.

class rhsusf_acc_SF3P556      { quality = 2; price = 140; sellPrice = 0; };
 class rhsusf_acc_SFMB556      { quality = 2; price = 140; sellPrice = 0; };
 class rhsusf_acc_nt4_black      { quality = 3; price = 180; sellPrice = 0; };
 class rhsusf_acc_nt4_tan      { quality = 3; price = 180; sellPrice = 0; };
 class rhsusf_acc_rotex5_grey     { quality = 3; price = 180; sellPrice = 0; };
 class rhsusf_acc_rotex5_tan      { quality = 3; price = 180; sellPrice = 0; };
 class rhsusf_acc_SR25S       { quality = 3; price = 190; sellPrice = 0; };
 class rhsusf_acc_M2010S       { quality = 3; price = 200; sellPrice = 0; };
 

Share this post


Link to post
Share on other sites
  • 0
5 minutes ago, GamersRoost said:

Don't allow the selling of ANY attachments on your server. Sell them, have them in loot, missions and as other rewards, but stop the ability to sell. Duping stops.

As an example.

They get over it fast.

class rhsusf_acc_SF3P556      { quality = 2; price = 140; sellPrice = 0; };
 class rhsusf_acc_SFMB556      { quality = 2; price = 140; sellPrice = 0; };
 class rhsusf_acc_nt4_black      { quality = 3; price = 180; sellPrice = 0; };
 class rhsusf_acc_nt4_tan      { quality = 3; price = 180; sellPrice = 0; };
 class rhsusf_acc_rotex5_grey     { quality = 3; price = 180; sellPrice = 0; };
 class rhsusf_acc_rotex5_tan      { quality = 3; price = 180; sellPrice = 0; };
 class rhsusf_acc_SR25S       { quality = 3; price = 190; sellPrice = 0; };
 class rhsusf_acc_M2010S       { quality = 3; price = 200; sellPrice = 0; };
 

fckin great idea!!! why didnt we found this? oh boy... :) sometimes the solution is so simple... thx man!!!! 

Share this post


Link to post
Share on other sites
  • 0
5 minutes ago, yesyesjo said:

fckin great idea!!! why didnt we found this? oh boy... :) sometimes the solution is so simple... thx man!!!! 

I also provided "Fire extinguishers" in mission loot as RARE loot, to offset the inability to seel the attachments.

class Exile_Item_FireExtinguisher    { quality = 1; price = 0; sellPrice = 50000; };

1 person likes this

Share this post


Link to post
Share on other sites
  • 0

Posted (edited)

first thing to do is update Arma server with todays hotfix.

Secondly, you need to change the helicopter class you are using (CUP_B_CH47F_DB) for the Occupation Sky as the vehicles are not spawning (either you have the classname wrong or there is a problem with CUP vehicles)

15:41:06 "[OCCUPATION:Sky] Started"
15:41:07 Cannot create non-ai vehicle CUP_B_CH47F_DB,
15:41:08 Cannot create non-ai vehicle CUP_B_CH47F_DB,
15:41:09 CUP_B_UH60L_FFV_US: pylons_hide - unknown animation source pylons_hide
15:41:11 UH1H_m240_skeleton: Invalid parent bone 'otochlaven_3' for 'gatling_3'
15:41:11 UH1H_m240_skeleton: Invalid parent bone 'damagehide' for 'glass1'
15:41:11 UH1H_m240_skeleton: Invalid parent bone 'damagehide' for 'glass4'
15:41:11 UH1H_m240_skeleton: Invalid parent bone 'damagehide' for 'glass5'
15:41:11 Warning: Convex component representing Skids not found
15:41:11 Array mat in bin\config.bin/CfgVehicles/UH1HL_base/Damage/ not multiply of 3
15:41:11 Exile_Chopper_Huey_Armed_Green: Glass7_destruct - unknown animation source HitGlass7
15:41:11 Error: bin\config.bin/CfgVehicles/UH1H_M240/Turrets/RightDoorGun/: Turret body Turret2 not found while initializing the model exile_psycho_uh1h\uh1h_m240.p3d
15:41:11 Error: bin\config.bin/CfgVehicles/UH1H_M240/Turrets/CoPilotObs/: Turret body ObsTurret not found while initializing the model exile_psycho_uh1h\uh1h_m240.p3d
15:41:11 Error: bin\config.bin/CfgVehicles/UH1H_M240/Turrets/CoPilotObs/: Turret gun ObsGun not found while initializing the model exile_psycho_uh1h\uh1h_m240.p3d
15:41:12 "[OCCUPATION:Sky] Running"

edit: try "CUP_B_CH47F_USA" or  "CUP_B_CH47F_GB"

Edited by second_coming
1 person likes this

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, GamersRoost said:

not pointing fingers here.... so anyone reading this, PLEASE don't interject "ITS NOT THE MOD" -- this is only a test....

Root cause on this is very clearly 1 of 2 things. A MySQL read write violation (which is right in the error) or a memory leak from a mod that's running.

I would do 2 things to test this.

1) Increase your tiny page file to the same size as your ram (requires a VM restart). THEN test the solution for at least 2 server cycles (8 hours) before trusting the change.

This can fix the issue simply by adding more available memory, but the fix would be a bandaid. IF this resolves the issue, then I would set the page file back to where it was and continue to step 2.

2)  I would then try to disable the mod that was the last entry in the RPT with an error "OCCUPATION". Test for 2 server cycles and see if the memory leak is gone.

 If the server does not crash, you have determined the memory leak is within the MOD with "occupation" in it (MOST LIKELY - again not blaming a MOD for this).

Here is a breakdown of what you are seeing in the RPT for the memory error and how to determine a leak (Sort of).

  1. 15:45:06 Virtual memory total 4095 MB (4294836224 B) <--- this is the amount that you allocated to the VM.
  2. 15:45:06 Virtual memory free 108 MB (113504256 B) <--- this is the amount of page file memory that you had free at the crash time (Note the 108 for later).
  3. 15:45:06 Physical memory free 17400 MB (18245316608 B) <------- This is the total VMware Host SERVER RAM available, at the time of crash.
  4. 15:45:06 Page file free 40171 MB (42122932224 B)  <-- this does not match item 1 so we will ignore it, and move past like it never happened).
  5. 15:45:06 Process working set 3256 MB (3414732800 B) <---- this is what Arma 3 was using at time of crash (yes that is WAY more than it should).
  6. 15:45:06 Process page file used 3682 MB (3861270528 B) <---- this is what all processes were using when the server crashed.
  7. 15:45:06 Longest free VM region: 4128768 B <---- This looks like something related to a thin provisioned VMware disk.
  8. 15:45:06 VM busy 4198912000 B (reserved 199155712 B, committed 3999756288 B, mapped 42655744 B), free 95924224 B <------ Ignore for now.
  9. 15:45:06 Small mapped regions: 17, size 77824 B <---- ignore again since I have no idea what this is. Its either game related or DB related.
  10. ErrorMessage: Out of memory (requested 213 KB). <--- this is WHY the server crashed, it was trying to write data to the page file, since the RAM was full. The page file only had 108MB available and you cant fit 213 into 108 = crash
  11.   footprint 3339517952 KB. <--- this is how much RAM is used at server crash time this means the actual gaming server had 911 MB of free ram out of 4GB  = WHAT ?! that's WAY to much usage. If the memory was commited (and arma did not crash releasing the RAM) the server would have blue screened.
  12.   pages 81920 KB. < ---- This is your page file windows has allocated. It is also almost double the RAM. If this was Windows XP, then it would have been ok. This is SERVER and it should Never ever be more than your total RAM.
Hope this helps

hey i was out and just got back, thanks for the read out and taking ur time explaining this, i have actually struggled for 2 days trying to figure out the issues and had been forced to remove all mods almost to justify the problem, i removed the occupation just for testing now with ryanzombies and infection, seems the server holding strong so far with no failure signs, checked the paging and the Sql connection all seems fine on Log side and data. i will reply to you once i  get more info and tests thx again

Share this post


Link to post
Share on other sites
  • 0

Posted (edited)

1 hour ago, second_coming said:

first thing to do is update Arma server with todays hotfix.

Secondly, you need to change the helicopter class you are using (CUP_B_CH47F_DB) for the Occupation Sky as the vehicles are not spawning (either you have the classname wrong or there is a problem with CUP vehicles)


15:41:06 "[OCCUPATION:Sky] Started"
15:41:07 Cannot create non-ai vehicle CUP_B_CH47F_DB,
15:41:08 Cannot create non-ai vehicle CUP_B_CH47F_DB,
15:41:09 CUP_B_UH60L_FFV_US: pylons_hide - unknown animation source pylons_hide
15:41:11 UH1H_m240_skeleton: Invalid parent bone 'otochlaven_3' for 'gatling_3'
15:41:11 UH1H_m240_skeleton: Invalid parent bone 'damagehide' for 'glass1'
15:41:11 UH1H_m240_skeleton: Invalid parent bone 'damagehide' for 'glass4'
15:41:11 UH1H_m240_skeleton: Invalid parent bone 'damagehide' for 'glass5'
15:41:11 Warning: Convex component representing Skids not found
15:41:11 Array mat in bin\config.bin/CfgVehicles/UH1HL_base/Damage/ not multiply of 3
15:41:11 Exile_Chopper_Huey_Armed_Green: Glass7_destruct - unknown animation source HitGlass7
15:41:11 Error: bin\config.bin/CfgVehicles/UH1H_M240/Turrets/RightDoorGun/: Turret body Turret2 not found while initializing the model exile_psycho_uh1h\uh1h_m240.p3d
15:41:11 Error: bin\config.bin/CfgVehicles/UH1H_M240/Turrets/CoPilotObs/: Turret body ObsTurret not found while initializing the model exile_psycho_uh1h\uh1h_m240.p3d
15:41:11 Error: bin\config.bin/CfgVehicles/UH1H_M240/Turrets/CoPilotObs/: Turret gun ObsGun not found while initializing the model exile_psycho_uh1h\uh1h_m240.p3d
15:41:12 "[OCCUPATION:Sky] Running"

edit: try "CUP_B_CH47F_USA" or  "CUP_B_CH47F_GB"

hello and thx for ur reply second_coming i will look thorough this and check for the rest u mentioned, i was using your occupation mod and was forced to remove it for testing sake not saying that the problem was it at all, i can see that i had some minor issues myself and host side. thx 

Edited by Vurama

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.