Janski

ExAd - Package of Virtual Garage|XM8|StatsBar|Halo & Parachute|Admin Events|Hacking|Grinding|Vehicle Upgrade

1824 posts in this topic

Having a problem with the VG. Where it won't store vehicles. Option is there but nothing happens.

This is a new installation. I've installed core and statbar and they are working fine.

I ran the sql query. I installed VG and it's not throwing any errors in game, I don't see anything really in the logs.

This is from my remoteexec.log

06.01.2017 18:38:09: Shreeden (47.147.137.10:2304) 99ebfcc49f56810d46ffe2cbee8539b4 - #0 "exadserver_fnc_clientrequest ["VGStore",["2:3289","2:3340","2:3225"]]"

Not sure where else to look to uncover what is happening. I read through most of the posts here but didn't see a solution. If anyone could lend assistance I would appreciate it. 

Thank you.

Share this post


Link to post
Share on other sites

Posted (edited)

Do you have also compared the exile.ini from download with yours? (location downloadfolder: ExAd-master/@ExileServer/extDB/sql_custom_v2/exile.ini)

///Edit///

Quote

Not sure where else to look to uncover what is happening.

You can create a folder in the arma 3 rootdirection of your server: arma 3\ExAd_Logs (if you have enabled it in the customize.sqf at arma 3\mpmissions\Exile.map.pbo\ExAdClient\Core\customisze.sqf)

ExAd_Debug = true; 						//BOOLEAN - If you want the ExAd code to generate debug logs 
Exad_Logging = true;					//BOOLEAN - If you want the ExAd code to generate extra logs. - Requires InfiStar installed 
ExAd_Log_Folder = "ExAd_Logs";			//STRING - The folder ExAd writes logs to. You need to create the defined folder if it doesn't exist. If you don't create it - the DLL won't be able to write any Log files

 

Edited by CH!LL3R

Share this post


Link to post
Share on other sites
Advertisement

Posted (edited)

Exad_Logging = true;                    //BOOLEAN - If you want the ExAd code to generate extra logs. - Requires InfiStar installed 

Don't have infistar.

I think I know what I did wrong. 

I added all the lines from the scripts.txt to the end of the file. That probably doesn't make them function correctly right?

 

I see this in my scripts.log

_path = "ExAdClient\Core\customize.sqf";
call compile preprocessFileLineNumbers _path;

if(isNil "ExAd_Debug")then"
05.01.2017 10:40:44: OGMrClean4L (71.228.29.57:2304) d576d41d9261bbe00727fa02bbb373c0 - #21 "


_path = "ExAdClient\VirtualGarage\customize.sqf";
call compile preprocessFileLineNumbers _path;

if(isNil "ExAd_VG_MIN_ALLO"
05.01.2017 10:40:44: OGMrClean4L (71.228.29.57:2304) d576d41d9261bbe00727fa02bbb373c0 - #51 "


_path = "ExAdClient\VirtualGarage\customize.sqf";
call compile preprocessFileLineNumbers _path;

if(isNil "ExAd_VG_MIN_ALLO"
05.01.2017 10:40:44: OGMrClean4L (71.228.29.57:2304) d576d41d9261bbe00727fa02bbb373c0 - #21 ""_key is undefined/empty"] call ExAd_fnc_DebugHandler};call compile format['%1 = if(isLocalized "%1")then{localize "%1"}else{"%2"
05.01.2017 10:40:44: OGMrClean4L (71.228.29.57:2304) d576d41d9261bbe00727fa02bbb373c0 - #51 ""_key is undefined/empty"] call ExAd_fnc_DebugHandler};call compile format['%1 = if(isLocalized "%1")then{localize "%1"}else{"%2"
05.01.2017 10:40:44: OGMrClean4L (71.228.29.57:2304) d576d41d9261bbe00727fa02bbb373c0 - #22 "onConfigFile >> "CfgXM8" >> _x >> "onOpen"))then{
_code = compileFinal (preprocessFileLineNumbers getText(missionConfigFile >> ""
05.01.2017 10:40:44: OGMrClean4L (71.228.29.57:2304) d576d41d9261bbe00727fa02bbb373c0 - #51 "

 

Edited by Shreeden

Share this post


Link to post
Share on other sites

Hello there

Can someone tell me, how i can change the language? I ve tried to change it in german but it still stay in english:

			<Key ID="STR_ExAd_VG_NOTI_NOT_PERSISTENT">
				<Original>You can only store pincode protected vehicles into the garage!</Original>
				<deutsch>Du kannst nur Autos in die Garage packen, welche auch mit einem Pincode gesichtert sind!</deutsch>
			</Key>

tried it also in <german></german>

 

Can somebody eyplain how i can change it or put more languages into the stringtable.xml? My game and Steam is in German.


Thx a lot

Great Day for u :D

 

Share this post


Link to post
Share on other sites
Someone can help me please?

extDB2: SQL_CUSTOM_V2: Error No Custom Call Not Found: Callname deleteVehicle

Share this post


Link to post
Share on other sites
2 hours ago, Yann20QC said:

Someone can help me please?

extDB2: SQL_CUSTOM_V2: Error No Custom Call Not Found: Callname deleteVehicle

Have you added the ExAd parts to exile.ini and added the new entries to the database?

Share this post


Link to post
Share on other sites
14 hours ago, kuplion said:

Have you added the ExAd parts to exile.ini and added the new entries to the database?

Yes

Share this post


Link to post
Share on other sites
14 hours ago, kuplion said:

Have you added the ExAd parts to exile.ini and added the new entries to the database?

The virtual garage works but it has vehicles on the map that still respawn after reboot
Edited by Yann20QC

Share this post


Link to post
Share on other sites

I am getting an error when i am starting the server.

file mpmissions\_cur_mp.Altis\config.cpp, line 6421: .CfgExileCustomCode: Member already defined.

what is wrong?

6418 class ExAd_SB 
6419    {
6420        title = "Statsbar Settings";
6421       controlID = 50400;                    //IDC:50400 -> 50475 || These need to be unique and out of range from each other
6422        logo = "ExadClient\XM8\Apps\SB_Settings\Icon_SB.paa";
6423        onLoad = "ExAdClient\XM8\Apps\SB_Settings\onLoad.sqf";
6424    };

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.