Araknys

[Solved] BERCon could not connect to server

21 posts in this topic

Hello hello !

Well, an other day, an other problem ^_^

So, my server is running fine. But I wanted to use BERCon. Of course, It doesn't work. When I launch it, I enter : 127.0.0.1 for the IP, 2302 for the game server's port (tried with 2303 to 2307) and the RCon password set in my beserver.cfg

When I launch the server, I see :  

Spoiler

 8:57:41 BattlEye Server: Initialized (v1.212)
 8:57:41 Host identity created.
 8:57:41 Game Port: 2302, Steam Query Port: 2303
 8:57:41 Mission Exile.Altis read from bank.
 8:57:41 BattlEye Server: Ping detection currently not working, MaxPing command disabled
 8:57:41 Roles assigned.
 8:57:41 Reading mission ...
 8:57:51 Mission read.
 8:57:52 Game started.
 

But in my beserver.cfg I have just 2 lines : RConPassword XXX MaxPing 600

This file is in C:\Arma\Server\battleye whith other text files and beserver.dll

So... why BERCon could not connect to my server ? ^^

Share this post


Link to post
Share on other sites

As of 1.58 you need to define IP and PORT in BEServer.cfg

Spoiler

RConPassword RCONPasswordHere
RConIP 127.0.0.1 (If you use this, it'll only respond on 127.0.0.1 (Localhost), set the external IP, then you can connect with RCON tool from external location.)
RConPort 2312 (Port of your server)
MaxPing 600 (Broken right now, so why even bother.)

 

Share this post


Link to post
Share on other sites
Advertisement

Thanks for your answer. I edited my beserver.cfg like this:

Spoiler

RConPassword XXXX
RConIP 127.0.0.1
RConPort 2312
MaxPing 600

Same problem. Is there an other place to enter this settings ? Like in extdb.conf.ini ?

Share this post


Link to post
Share on other sites

If you use 127.0.0.1 as I just wrote, you won't be able to connect with a RCON tool from external source that be your computer or any other computer, you can only connect locally, that being a RCON tool running on the same server, in the LAN. 

If you enter your external address for the server in BEserver.cfg you should be able to connect to RCON from your own computer. 

1 person likes this

Share this post


Link to post
Share on other sites

Oh I thought it worked with 127.0.0.1 in local...

Nevermind, I changed my beserver.cfg and write my IP (checked with my-ip). And... same problem ^^

Share this post


Link to post
Share on other sites

Taken directly from BI Wiki: 

Spoiler

Since BattlEye server version 1.102 you can control your Arma game server remotely (without having to be in-game) using the BattlEye RCon tool.

Download the BattlEye RCon tool (BERCon.exe).
Create a file called "beserver.cfg" in BattlEye working directory on the server.
Set private RCon password in the beserver.cfg via setting "RConPassword"
Set custom BattlEye's RCON port defined in BEserver.cfg via setting "RConPort" (for Arma 3 update 1.58.135656 and newer builds)
Set optional BattlEye's RCON IP defined in BEserver.cfg via setting "RConIP" (for Arma 3 update 1.58.135656 and newer builds)
Start the RCon tool binary and connect to server with its IP, port and RCon password.
RconPort must avoid reserved ARMA3server port range (gameport *+0,+1,+2,+3))
default reserved ports are 2302 - 2305 (to clarify the reserved ports can't be used for BattlEye's RCON).
RconIP entry isn't needed as when undefined it equals to 0.0.0.0 (all IPv4 local IP addresses)
setting it to e.g. 127.0.0.1 will prevent it to respond on external IP
setting it to e.g. external IP will prevent it to respond on localhost 127.0.0.1

 

Share this post


Link to post
Share on other sites

Well... I did this... 

RConPassword XXXX
RConIP 109.190.***.***
RConPort 2312

And BERCon could not connect to server. (I opened port in my router, firewall, allowed BERCon etc...)
 

Share this post


Link to post
Share on other sites

Ok. 

I had the same issue with mine, this is a easy fix. The server remains on the same port 2312, however in your BEServer.cfg try RConPort 2315 for example, that should work. 

Share this post


Link to post
Share on other sites

Well no, doesn't work. :( Tried too with EPM and same error.

Share this post


Link to post
Share on other sites
5 minutes ago, Araknys said:

Well no, doesn't work. :( Tried too with EPM and same error.

Try back and forth as from the wiki, that's what fixed it for me, when I had the issue: 

RconPort must avoid reserved ARMA3server port range (gameport *+0,+1,+2,+3))
default reserved ports are 2302 - 2305 (to clarify the reserved ports can't be used for BattlEye's RCON).

Share this post


Link to post
Share on other sites
Advertisement
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.