StokesMagee

guide How to setup / use Battleye RCON

12 posts in this topic

Well to start off:

PLEASE MAKE SURE YOU HAVE A WORKING EXILE SERVER FIRST!

IF THE PROBLEM IS NOT RELATED TO RCON PLEASE DO NOT POST HERE!

if you have some problems look at notes

(I'm going to use TUT as a replacement for what you use)

*HOW TO:

Spoiler

 

  1. Look inside your server launch peramaters, and find -profile=tut
  2. If -profile=tut without anything else then there will be a folder called tut located in the root of the server (same location as arma3server.exe)
  3. Inside of tut locate the battleye folder.
  4. inside the battleye folder make a file called BEServer.cfg
  5. Inside BEServer.cfg put:

RConPassword ChangeMe
RConPort 2309

 

Once you have done "HOW TO" start your server, and inside the battleye folder once your server has fully loaded, you will see BEServer.cfg change to BEServer_Active_*random stuff*.cfg

 

 

*Notes:

Spoiler

 

*RConIP: Is only used for servers that have more then 1 IP (example: 521.251.223.45, 51.52.63.987,  72.22.78.59 )

If you want to use 51.52.63.987 instead of all of the others then you put RConIP 51.52.63.987 - Then you can only connect to RCon using 51.52.63.987

*RConPort: I recommend using 2309 (if your server is using 2302) From what i have learned 2304 does not work.

*MaxPing: Defines the max ping for when players get kicked for "ping to high" can make it so people in other country's not able to connect.

*RconPassword: Defines the password needed to connect to RCon with.

*If your BEServer.cfg does not change, then you are either in the wrong location, OR the server has a launch parameter called -bepath=tut - if so then locate that folder and do the "how to" with that folder.

*How do i connect to Rcon? Download a program called "Epm RCon" or "Dart"

*BEC: depending on the "port" you used for RConPort, BEC will have to be configured for that "port"

 

 

4 people like this

Share this post


Link to post
Share on other sites

Since A3 1.60 maxping has been moved to the server.cfg by BI and no longer works in the beserver.cfg

1 person likes this

Share this post


Link to post
Share on other sites
Advertisement
On 30.6.2016 at 8:57 PM, Stoll said:

Since A3 1.60 maxping has been moved to the server.cfg by BI and no longer works in the beserver.cfg

So in case of exile, we should move the maxping setting to the server config.cfg.
Making it look like this in the top?

MaxPing 							= 600;

 

Share this post


Link to post
Share on other sites

It's not on top for me, but yes, format is the same: maxPing = 250;
However, neither server.cfg nor beserver.cfg are working for me right now. 9_9

Share this post


Link to post
Share on other sites

But hey, wait... I noticed a new setting in the config. Maybe this is the new setup.
Exile server files comes with this and 0 set as default.

kickClientsOnSlowNetwork            = 0;

Hmm?

Share this post


Link to post
Share on other sites

i cant find server launch perimeters

Im useing filezilla and gtx gaming 

Share this post


Link to post
Share on other sites

hi, i've set up my BEServer_Active_*random stuff*.cfg file to have this RConPassword PASSWORD(not my real one) RConPort 2309 and when i attempt to connect via a rcon program it always fails to connect, i've check most other configs and if i seen a bit that mention rcon i put the same info there incase it was needed, i've been trying to get this to work for a few days now but all i get it could not connect to server, tried various ports as well. Any one have any idea that i could try?

Share this post


Link to post
Share on other sites
On 5/3/2016 at 11:29 AM, StokesMagee said:

Well to start off:

PLEASE MAKE SURE YOU HAVE A WORKING EXILE SERVER FIRST!

IF THE PROBLEM IS NOT RELATED TO RCON PLEASE DO NOT POST HERE!

if you have some problems look at notes

(I'm going to use TUT as a replacement for what you use)

*HOW TO:

  Hide contents

 

  1. Look inside your server launch peramaters, and find -profile=tut
  2. If -profile=tut without anything else then there will be a folder called tut located in the root of the server (same location as arma3server.exe)
  3. Inside of tut locate the battleye folder.
  4. inside the battleye folder make a file called BEServer.cfg
  5. Inside BEServer.cfg put:


RConPassword ChangeMe
RConPort 2309

 

Once you have done "HOW TO" start your server, and inside the battleye folder once your server has fully loaded, you will see BEServer.cfg change to BEServer_Active_*random stuff*.cfg

 

 

*Notes:

  Hide contents

 

*RConIP: Is only used for servers that have more then 1 IP (example: 521.251.223.45, 51.52.63.987,  72.22.78.59 )

If you want to use 51.52.63.987 instead of all of the others then you put RConIP 51.52.63.987 - Then you can only connect to RCon using 51.52.63.987

*RConPort: I recommend using 2309 (if your server is using 2302) From what i have learned 2304 does not work.

*MaxPing: Defines the max ping for when players get kicked for "ping to high" can make it so people in other country's not able to connect.

*RconPassword: Defines the password needed to connect to RCon with.

*If your BEServer.cfg does not change, then you are either in the wrong location, OR the server has a launch parameter called -bepath=tut - if so then locate that folder and do the "how to" with that folder.

*How do i connect to Rcon? Download a program called "Epm RCon" or "Dart"

*BEC: depending on the "port" you used for RConPort, BEC will have to be configured for that "port"

 

 

i have followed your instruction but when trying to connect via dart/epm it fails to connect

Share this post


Link to post
Share on other sites
On 10/19/2016 at 9:52 PM, XYZ Loki said:

i have followed your instruction but when trying to connect via dart/epm it fails to connect

Under your beserver.cfg  Set the RconIp to Nothing   So it should read this

RConPassword "yourPW"

Maxping= numbers

RConIp "should be blank"

Now when you start the server it should show in the log BE server: 0.0.0.0

WHen that is done,  Open Dart or your Rcon Tool   type in IP 127.0.0.1 * IF RCON is on the same machine as the server is on*

port should be Whatever you set it to in beserver Config and make sure its opened in UDP firewall

And then type your password in.   
 

If you still need help just shoot me a message and ill help ya

 

 

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.