Sign in to follow this  
Followers 0
TPGDagger

Weather settings - no actual effect

6 posts in this topic

Been having some issues with weather rotation not functioning on my server. Not sure what it is, maybe CBA?

 

Anyway, it seems to always be raining. My dynamicweather is as follows. The server starts and it is raining and it never changes.

 

Anyone know of a different way to gut the rain at least on start?

    class Weather
    {
        /*
            You can define multiple "keyframes" for the weather to change. The server will pick
            a keyframe randomly to simulate the weather. It will change the weather-keyframes
            based on the following interval
        */
        interval = 30;

        /*
            Add the keyframes here. The server will pick one random, so if you want one 
            weather type of be more dominant compared to others, add it multiple times
        */
        keyframes[] = {"Sunny", "Sunny", "Sunny", "Sunny", "Cloudy", "Thunderstorm"}; 

 

Share this post


Link to post
Share on other sites

I have noticed that the weather system in Exile DEFINITELY prefers the raining weather. I added in about 10 custom weathers, all variations of sunny and cloudy, and it still almost ALWAYS randomised to the Rainy setting.

Share this post


Link to post
Share on other sites
Advertisement
8 hours ago, kuplion said:

I have noticed that the weather system in Exile DEFINITELY prefers the raining weather. I added in about 10 custom weathers, all variations of sunny and cloudy, and it still almost ALWAYS randomised to the Rainy setting.

That's because you run a UK server.

1 person likes this

Share this post


Link to post
Share on other sites

Posted (edited)

On 5/5/2016 at 6:25 PM, kuplion said:

I have noticed that the weather system in Exile DEFINITELY prefers the raining weather. I added in about 10 custom weathers, all variations of sunny and cloudy, and it still almost ALWAYS randomised to the Rainy setting.

I removed the rainy option period and it is always raining on server boot. It also never transitions to the sunny weather, so something is borked I think.

Edited by TPGDagger
1 person likes this

Share this post


Link to post
Share on other sites

Posted (edited)

I know this is old, did you solve it?

 

Perhaps in the mission.sqm the mission is set to start rainy. and every x interval changes to the predefined weather.

Also check in the 'Sunny' config options that rain is set to 0.

Edited by CplNathan

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.