Prouxx

(Solved) scripts.txt not working

3 posts in this topic

Posted (edited)

Hi, 

So today I've been trying to set up an exile server on my linux machine. Everything seems to be working fine until I connect and get kicked by Battleye

22:25:02 x uses modified data file
22:25:02 BattlEye Server: Player #0 x (x) connected
22:25:02 Player x connecting.
22:25:04 BattlEye Server: Player #0 x - GUID: x (unverified)
22:25:05 Player x connected (id=x).
22:25:05 BattlEye Server: Verified GUID (x) of player #0 x
22:25:21 BattlEye Server: Script Log: #0 x (x) - #8 "BIS_fnc_initPlayable","BIS_fnc_missionTimeLeft","BIS_fnc_deleteVehicleCrew","BIS_fnc_MP","BIS_fnc_MPexec","BIS_fnc_netId","BIS_f"
22:25:21 Player x kicked off by BattlEye: Script Restriction #8
22:25:21 Player x disconnected.

This is the output I'm getting in scripts.log

#8 "BIS_fnc_initPlayable","BIS_fnc_missionTimeLeft","BIS_fnc_deleteVehicleCrew","BIS_fnc_MP","BIS_fnc_MPexec","BIS_fnc_netId","BIS_f"

I thought this was weird because the version of the mod I downloaded today already has the text I'm meant to add to line 10 (8+2):

7 deleteVehicle !="BIS_fnc_initPlayable\",\"BIS_fnc_missionTimeLeft\",\"BIS_fnc_deleteVehicleCrew\",\"BIS_fnc_MP\",\"BIS_fnc_MPexec\",\"BIS_fnc_countdown\",\"B" !="[\"exile_client\\trashBin\\fn_deleteVehicleCrew.sqf\",\".sqf\",0,false,false,false,\"A3\",\"MP\",\"deleteVehicleCrew\"]" !="dPlayerObject isKindOf \"Exile_Unit_GhostPlayer\") then \n{\ndeleteVehicle _oldPlayerObject;\n};\nplayer setVariable [\"ExileXM8IsOnlin" !="PlayerInSafezone) then \n{\nif (local _projectile) then \n{\ndeleteVehicle _projectile;\n};\n}\nelse \n{\nif (_ammo isKindOf \"Exile_Ammo_" !=" = _this;\nif !(isNull ExileClientModelBoxVehicle) then\n{\ndeleteVehicle ExileClientModelBoxVehicle;\n};\nExileClientModelBoxVehicle" !=" = _this;\nif !(isNull ExileClientModelBoxVehicle) then\n{\ndeleteVehicle ExileClientModelBoxVehicle;\n};\nExileClientModelBoxVehicle" !="inate\", \"back\"];\nterminate ExileClientModelThreadHandle;\ndeleteVehicle ExileClientModelBoxVehicle;\ndeleteVehicle ExileClientMode" !="jectile = _this select 6;\nif (local _projectile) then \n{\ndeleteVehicle _projectile;\n};\n" !=" >> \"Snow\" >> \"enable\")) isEqualTo 1) exitWith {false}; \ndeleteVehicle ExileSnowClose;\ndeleteVehicle ExileSnowNear;\ndeleteVehicl" !=" ExileClient_construction_simulationCountDown;\n}\nelse \n{\ndeleteVehicle ExileClientConstructionObject;\n};\n[\"ConstructionMovedTooF" !="e\n{\n_objects = _flag getVariable \"ExileRadiusObjects\";\n{\ndeleteVehicle _x;\n}\nforEach _objects;\n_flag setVariable [\"ExileRadiusSh" !=",-2])]) > 1\n||\n((getPosATL player) select 2) < 2\n)then\n{\ndeleteVehicle (vehicle player);\nplayer switchMove \"\";\nplayer setVelocit"

All that the log is telling me to do is move the first exception to the end of the line, or add it, or pretend like the first exception doesn't exist and go ahead and add the second one anyway. Basically, I tried all combinations. This wasn't working. So I came to the conclusion that scripts.txt might not be working at all. To check this, I changed the value of line 10 from 7 to 3 and then to 1 to try and see if it would stop kicking me from the server. No joy. 

Here is the latest 10th line of my scripts.txt
 

1 deleteVehicle !="BIS_fnc_initPlayable\",\"BIS_fnc_missionTimeLeft\",\"BIS_fnc_deleteVehicleCrew\",\"BIS_fnc_MP\",\"BIS_fnc_MPexec\",\"BIS_fnc_countdown\",\"B" !="[\"exile_client\\trashBin\\fn_deleteVehicleCrew.sqf\",\".sqf\",0,false,false,false,\"A3\",\"MP\",\"deleteVehicleCrew\"]" !="dPlayerObject isKindOf \"Exile_Unit_GhostPlayer\") then \n{\ndeleteVehicle _oldPlayerObject;\n};\nplayer setVariable [\"ExileXM8IsOnlin" !="PlayerInSafezone) then \n{\nif (local _projectile) then \n{\ndeleteVehicle _projectile;\n};\n}\nelse \n{\nif (_ammo isKindOf \"Exile_Ammo_" !=" = _this;\nif !(isNull ExileClientModelBoxVehicle) then\n{\ndeleteVehicle ExileClientModelBoxVehicle;\n};\nExileClientModelBoxVehicle" !=" = _this;\nif !(isNull ExileClientModelBoxVehicle) then\n{\ndeleteVehicle ExileClientModelBoxVehicle;\n};\nExileClientModelBoxVehicle" !="inate\", \"back\"];\nterminate ExileClientModelThreadHandle;\ndeleteVehicle ExileClientModelBoxVehicle;\ndeleteVehicle ExileClientMode" !="jectile = _this select 6;\nif (local _projectile) then \n{\ndeleteVehicle _projectile;\n};\n" !=" >> \"Snow\" >> \"enable\")) isEqualTo 1) exitWith {false}; \ndeleteVehicle ExileSnowClose;\ndeleteVehicle ExileSnowNear;\ndeleteVehicl" !=" ExileClient_construction_simulationCountDown;\n}\nelse \n{\ndeleteVehicle ExileClientConstructionObject;\n};\n[\"ConstructionMovedTooF" !="e\n{\n_objects = _flag getVariable \"ExileRadiusObjects\";\n{\ndeleteVehicle _x;\n}\nforEach _objects;\n_flag setVariable [\"ExileRadiusSh" !=",-2])]) > 1\n||\n((getPosATL player) select 2) < 2\n)then\n{\ndeleteVehicle (vehicle player);\nplayer switchMove \"\";\nplayer setVelocit" !="BIS_fnc_initPlayable\",\"BIS_fnc_missionTimeLeft\",\"BIS_fnc_deleteVehicleCrew\",\"BIS_fnc_MP\",\"BIS_fnc_MPexec\",\"BIS_fnc_netId\",\"BIS_f"


I've spent all evening trying to find a solution to this on my own and have just come up against a brick wall. Any sort of help would be vastly appreciated. 

I think the problem could be with my startup parameters. Will check in the morning. 

Edited by Prouxx
wikipedia

Share this post


Link to post
Share on other sites

Posted (edited)

Okay so here's the fix. From the Arma Wiki:

Quote

Some mods such as @ALiVE and @A3MP will not function if there are capital letters in any of their file names.

So, apparently, this applies to BE as well. to fix this I simply did the following:

cd /home/myarmadir/battleye

find . -depth -exec rename 's/(.*)\/([^\/]*)/$1\/\L$2/' {} \;

From there, I just used the scripts filters tool.  

Edited by Prouxx
added links

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.