Neurosys

Passwords, and DLC questions, oh and a3xai

8 posts in this topic

Hello,  I've got my first Exile server finally running (my own box, ubuntu server) and Having a blast.

Few questions, I realize it may not be good to roll without a password, but I'm curious if its possible.

I'm mostly playing, my configuration is backed up, and I know how to work the db when something goes wonky (it has a couple times playing namalsk, I'm back on atlis now)

So I dont see too much danger in swinging the doors open for a 'internet random crazies' test.

Right now, I've got the pass set to 'arma' and I'm just saying so in the server info, but only because when I set it blank, I cant login, is rolling with no password set a no-no?

Ofc, I still have my rcon, server passes set to properly complex passes, not opening that up to public obviously.

 

2nd Question.

I've got all the DLC (exile actually prompted me to buy it, so I could fly for our crew), and it looks like the ExileServer has it enabled too (steam account is GeekprojexGameHosting (I think)).

When I log in with a3launcher to my server however, it shows Exile Mod with a green dot (ie: I have it on client) but the 3 DLC (Karts,MarksMen and Helos) are showing RED Dots.

Does that mean what I think it means? Have I forgot to include this support somewhere on server? Or is it how I'm launching it, causing client to think its not available?

 

more questions!

I set up a3Xai before realizing DMS was what I needed to get some action going (missions, dynamic spawning of missions, etc), but a3xai was still neat, so I left it in when I configured,packed and installed DMS.

I saw a bit of the DMS log seemed to notice a3xai was there, the text output seemed to indicate it would be either taking over its role entirely, or forcing it to use DMS as a proxy, not sure which, just guessing here, is that how that works? Is DMS better than a3xai? Should I remove a3xai or just let DMS handle its presence as it seems to be doing...?

 

Further inquiry (ikr)

Vehicles, previously, I played on a server not run by myself, was following some friends, and it seems like vehicles like cars, were more frequently *found* everywhere.

I havent found one on my server yet (found a load of bikes!). Have I missed something here that I need to configure? Or is this simply a side effect of the server being brand new?

 

Any other tips for people who've got things running fine, but dont know what needs fine tuning (like myself) are greatly appreciated.

Its been awhile since I sat down and dedicated time to running a complex server, I'm enjoying it and I'd like to make mine a good one.

 

Thanks in advance,

Neurosys B|

Share this post


Link to post
Share on other sites

Not sure what you mean by no password. You need a password for MySQL, server admin, and server command. A password to join is 100% optional. As for DMS and A3XAI, I run them both with no issues. And the vehicles that spawn are configured in @ExileServer > addons > exile_server_config > config.cpp.

Hope this helps.

Share this post


Link to post
Share on other sites
Advertisement

to get rid of the red dots copy the DLC folders (curator,mark,kart,heli) from a client to the server (overwriting the server versions)

1 person likes this

Share this post


Link to post
Share on other sites
6 minutes ago, second_coming said:

to get rid of the red dots copy the DLC folders (curator,mark,kart,heli) from a client to the server (overwriting the server versions)

Thanks, I'll do that now.

13 minutes ago, oSoDirty said:

Not sure what you mean by no password. You need a password for MySQL, server admin, and server command. A password to join is 100% optional. As for DMS and A3XAI, I run them both with no issues. And the vehicles that spawn are configured in @ExileServer > addons > exile_server_config > config.cpp.

Hope this helps.

I meant the join password. Anytime I put password="" in the @ExileServer/config.cfg, It still wants a password (and empty didnt work).

I might just try commenting it out, probably should have done that first.

Right now, I've got a helo over me and rogue ais sneaking in on my innocent looting trip. Thanks for those tips, I'll try each of them asap.

 

Share this post


Link to post
Share on other sites

Hmm, "" didn't work? I see you said it was your own box, so I can't think of why it's not working. Have a look at your launch parameters, -config= that will point to the proper file. I probably don't need to say this, but just in case, make sure you save the file when server is completely offline.

Share this post


Link to post
Share on other sites

Posted (edited)

1 hour ago, oSoDirty said:

Hmm, "" didn't work? I see you said it was your own box, so I can't think of why it's not working. Have a look at your launch parameters, -config= that will point to the proper file. I probably don't need to say this, but just in case, make sure you save the file when server is completely offline.

Commenting it out completely did the trick, server is public now. I also made sure to shut the server down first, I probably had not been doing that either.

Also did:

- Shutdown the server

- Uploaded the DLC overwriting them with my own copies from client

- Downloaded exile_server_config.pbo, unpacked it with pbo manager, modified config.cpp (vehicles and weather(hiwind thunderstorms!morefog!), repacked it up, backed up old pbo, uploaded the new one, start server, 'KILLED', made a funny face, checked permissions, chmod 0664 on the new pbo, startup, yay it works

exileYAY.thumb.png.ca2f105b6ab859a87afff

Result: All green dots for DLC now, modified config.cpp and repacked without destroying the server, got rid of the join password.

And I found out autolock never unlocks automagically, so I turned it off. Still locking it on restart though for the 3 minutes.

Or that might be because I used grid size 500 and 8 vehicles per grid. (black screen for that next load) That earned me a db table cleanout, then I changed it to 1500 gridsize and 3 vehicles per grid, so far the results were very good. Dropped server load back down below 0.5 (instead of 1+) and I'm cruising around on my new Loot-Tractor that I saw before I hit the ground (didnt see any others, so feels sparse still)

I learned about a lot of settings id never seen too, THANKS You guys! Really having fun now. Lone admin merc! Im gonna die so much...

meandmytractor.thumb.jpg.6c586332edf9382

Edited by Neurosys

Share this post


Link to post
Share on other sites

Posted (edited)

Depending on how powerful your server is it may take a bit longer to unlock, the function works properly, anytime you edit a pbo, it needs to be extracted to folder form with pbo manager or something alike. Once you have the proper tools, right click the pbo, and select program you installed, find and click "extract to exile_server_config". Make and save the edits within the folder. Then right click folder and repack into pbo. Don't delete the pbo before packing the folder otherwise it will not generate a backup (exile_server_config.pbo.bak). If you make edits, and break your server, simply delete the broken pbo, remove .bak from generated backup and you're back in business to give edits another try.  Obviously exile_server_config.pbo isn't the only pbo you may edit, I am just using it as an example since the autolocking and vehicles are inside there and that's what you're working on atm. Also, 500 grid with 8 per, is BEGGING for performance issues. I used 2000 and 2 vehicles per grid on  our old Altis server and have more than enough to go around. 

Edited by oSoDirty
1 person likes this

Share this post


Link to post
Share on other sites

I use 2200 gridsize and 1 vehicle per grid and there are around 50  vehicles spawning on Chernarus, the number of vehicles of the map can have a real detrimental effect to sever performance.

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.