tom546

Server not starting

11 posts in this topic

As the titles says. I've only installed exile and exileserver. It simply hangs. My mod parameters are @Exile;@ExileServer and Command line:
Code:

-ip=ip -port=2302 -name=server -autoInit -config=cfg\server.cfg -cfg=cfg\basic.cfg -profiles=cfg -filepatching -mod=@Exile;@ExileServer

Any ideas? There's nothing in /logs or /cfg/myserver_logs.

Share this post


Link to post
Share on other sites

Posted (edited)

If you're working on a home server or dedi you need to follow this guide. Those parameters are quite off.

Edited by oSoDirty

Share this post


Link to post
Share on other sites
Advertisement

Posted (edited)

4 hours ago, oSoDirty said:

If you're working on a home server or dedi you need to follow this guide. Those parameters are quite off.

I have a shared server from a provider and only have ftp and the control panel access. Nothing there helps with what I need. Could you tell me what is wrong with the command line?

I found this log from the server, but don't see any errors that would cause it to not start. http://pastebin.com/UGPbWyJm

Edited by tom546

Share this post


Link to post
Share on other sites

The best thing i can suggest is go and download fire daemon HERE and use the following start up parameters that i use and you should be good to go pal.

-mod=@Exile;@extendedbase;@Ryanzombies;@CBA_A3;@ASDG_JR;@CUP_Terrains_Core;@CUP_Terrains_Maps;@CUP_Weapons;@CUP_Units;@CUP_Vehicles; -servermod=@ExileServer;@FuMS;@infiSTAR_Exile; -config=C:\Servers\Exile_Main\@ExileServer\config.cfg -port=2302 -profiles=SC -cfg=C:\Servers\Exile_Main\@ExileServer\basic.cfg -name=SC -autoinit

You do not need the IP in the start up and you need to change your ;

-config=cfg\server.cfg

to the full server path :)

-cfg=C:\Servers\Exile_Main\@ExileServer\basic.cfg

Let me know how you get on.

Share this post


Link to post
Share on other sites

If it's a rented server, it should have worked the moment the host gave you the login info. Put in a ticket and have your host fix it. And if they give you a runaround, switch hosts. 

Share this post


Link to post
Share on other sites

Your command line should look more like :

-ip=????? -port=2302 -name=server -autoinit -config=cfg\server.cfg -cfg=cfg\basic.cfg -profiles=cfg -filepatching -mod=@Exile; -servermod=@ExileServer;

 

Where I have put the question marks for -ip= this should be the IP of your server. Also the port should be the 'connection' port and not the 'query' port. It might be correct but worth checking it.

Share this post


Link to post
Share on other sites

Posted (edited)

Well I got it to work lol.... I went through every inch of the config files and referenced each command parameter and found that autoinit requires Persistent 1 and was set on 0. Guess that was it. Thanks for the help fellas.

Edit: When my friends join and myself it says @exileserver and @exile (not loaded unidentified). Guess that means its not loaded.. 

http://pastebin.com/Au83iyFQ

 

Edited by tom546

Share this post


Link to post
Share on other sites

In your mission.sqm in the mpmission file thier is a bit that says

 

addons {

};

 

add 'exile_client' to this list inside the 'addons'

Share this post


Link to post
Share on other sites

Posted (edited)

14 hours ago, Hell Raiser said:

In your mission.sqm in the mpmission file thier is a bit that says

 

addons {

};

 

add 'exile_client' to this list inside the 'addons'

The two files I have in MPmissions are Exile.Atlis and Exile.Namalsk both have exile_client under addons. Server shows 10 slots and a bunch of AIs.

Edited by tom546

Share this post


Link to post
Share on other sites

I think the next bracket down says 'serveraddons'or somthing, i c ant remember off the top of my head. Make sure 'exile_client' is thier aswell.

 

Exile.Altis and Exile.Namalsk, these two mission files, which ever map you are running if one you need to edit

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.