Sign in to follow this  
Followers 0
Warsheep

[GUIDE] Watermark

19 posts in this topic

Posted (edited)

here one of my old scripts:
Simple but worked Watermark 

1.

Exile.Altis/initPlayerLocal.sqf

add

Spoiler

//Wasserzeichen
_pic = "AC.paa";
[
    '<img align=''left'' size=''1.0'' shadow=''1'' image='+(str(_pic))+' />',
    safeZoneX+0.027,
    safeZoneY+safeZoneH-0.1,
    99999,
    0,
    0,
    3090
] spawn bis_fnc_dynamicText;

DOWNLOAD GUIDE

 

if anyone interrestet here some info about dynamicText
 

String: Text/Picture
Number: X coordinates (optional)
Number: Y coordinates (optional)
Number: Duration (Optional)
Number: FadeIn time (Optional)
Number: Delta Y, Text will move up or down depending on value (Optional)
Number: Resource layer (Optional)

 

Edited by Warsheep

Share this post


Link to post
Share on other sites

Hi @Warsheep,

Thank you for your script! It is simple but very useful ... Thanks again.
I make my logos with photofiltre or Paint.Net. I confess to you if it is to make stationery letterhead is great ... but then if it is to use it to make a watermark after converting with textview2 into * .paa. Tthe watermark is grayed out and not with its colors.
Did you make out a solution for the colors?

Share this post


Link to post
Share on other sites
Advertisement

simple used a png file , then u should no have problems with collored watermark. 

Share this post


Link to post
Share on other sites

Posted (edited)

19 hours ago, Warsheep said:

simple used a png file , then u should no have problems with collored watermark. 

Ok... Thanks

Edited by M-RYS

Share this post


Link to post
Share on other sites
7 minutes ago, Warsheep said:

works ?

Nope... sorry ! Do You do it just with letters ??

Share this post


Link to post
Share on other sites

Is your version any better than this version? Any advantage to it?

 

Share this post


Link to post
Share on other sites

Posted (edited)

my version is just eaysier to include, bec its only in one file. not with hpp files and some includes ec.

if u look the maincode of the shared post 

_pic = "serverlogo.paa";
[
    '<img align=''left'' size=''1.5'' shadow=''0'' image='+(str(_pic))+' />',
    safeZoneX+0.00,
    safeZoneY+safeZoneH-0.12,
    99999,
    0,
    0,
    3090
] spawn bis_fnc_dynamicText;

u see its the selm stuff, so no one is better. 

Edited by Warsheep

Share this post


Link to post
Share on other sites

Posted (edited)

On 24.6.2016 at 10:21 PM, M-RYS said:

Nope... sorry ! Do You do it just with letters ??

nah, u need to comtile it to a png file.

ps: i googled a bit and found that :
 

1:Open them in Texview2 and select DXT1 for regular images, or DXT5 for images with transparency such as logos. Save as a .paa from Texview2.  

2:In fact the issue was due to the fact that I was using a non squared format. Now that I have a 256x256 image, I have no problems. Thanks for the help. 

3:the texture it to big that is whats giving you that

 

Edited by Warsheep

Share this post


Link to post
Share on other sites

Posted (edited)

Where do we put it in the initPlayerLocal.sqf? I put it at the top:

Spoiler

///////////////////////////////////////////////////////////////////////////////
// Static Objects
///////////////////////////////////////////////////////////////////////////////

// Taken away for now
//#include "initServer.sqf"
[] execVM "custom\statusBar\statusbar.sqf"; 

_pic = "custom\logo\watermark.paa";
[
    '<img align=''left'' size=''1.0'' shadow=''1'' image='+(str(_pic))+' />',
    safeZoneX+0.027,
    safeZoneY+safeZoneH-0.1,
    99999,
    0,
    0,
    3090
] spawn bis_fnc_dynamicText;

if (!hasInterface || isServer) exitWith {};

///////////////////////////////////////////////////////////////////////////
// Hardware Trader
///////////////////////////////////////////////////////////////////////////

 

No watermark is showing. I see no errors in my log. I created a .paa file called watermark.paa and put it in the folder custom\logo.

*EDIT* I saved the .paa file to .jpg and changed it in the initPlayerLocal.sqf and the image showed, but I want it to show the .paa version because it's smaller and it has a transparent background.

Edited by BetterDeadThanZed

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0