Schmidtch.

Weird server FPS drop.

6 posts in this topic

Hello,

I have weird FPS drop - from 48 / 50 do 30 / 22 with 0 players. It's start, when count of AI > 130.

I using DMS mission system and A3 Exile Occupation (compatible with DMS).

My RPT: RPT Logs (1 hour 3 mins after restart)

I don't know why i have so many errors from clear arma3..
If you need something more to help me, post it, i want to fix this problem.

Thanks for any help,
Regards Schmidtch.

Share this post


Link to post
Share on other sites

Too many AI (you have over 250 at one point), reduce the number of AI vehicles, I would also suggest updating both DMS and Occupation to the latest version and you need to sort out the RPT spam about missing addons.

What is the spec of your server?

Share this post


Link to post
Share on other sites
Advertisement
8 minutes ago, second_coming said:

Too many AI (you have over 250 at one point), reduce the number of AI vehicles, I would also suggest updating both DMS and Occupation to the latest version and you need to sort out the RPT spam about missing addons.

What is the spec of your server?

I have ~16 roaming vehicle on serwer, yes i know, i must do something with this spam.
I using dedicated serwer on ubuntu (14.04), core Intel i7-4790K, 32 GB RAM DDR3 1333 MHz, 2 x SSD.

Is a newest version of DMS and A3 Occupation? OK i will check github, thanks ;).

Share this post


Link to post
Share on other sites

in the config.sqf for Occupation you should probably set this:

SC_occupyVehicleIgnoreCount	= false;

Otherwise the vehicles will spawn even when you are over the allowed amount of AI

Share this post


Link to post
Share on other sites
8 minutes ago, second_coming said:

in the config.sqf for Occupation you should probably set this:


SC_occupyVehicleIgnoreCount	= false;

Otherwise the vehicles will spawn even when you are over the allowed amount of AI

OK thanks, i will test it.
btw, servermod like ASR_AI3 can affect performance? 

Share this post


Link to post
Share on other sites

Posted (edited)

I've never tried it but it adds additional complexity to the AI so will definitely impact performance.

It will probably also interfere with DMS passing control of the AI to the client which would absolutely affect server performance.

Edited by second_coming

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.