• 0
Sign in to follow this  
Followers 0
OrbDamu

Script restriction #0 that will not filter.

Question

To be short and sweet, I updated to the newest Arma 3 and exile, added the exile hotfix and updated CBA_A3 and Infistar. Afterwards, I've been getting this script restriction regardless of having the correct filter for it in place:

Spoiler

12:55:12 PM | Script Log: #0 OrbDamu (235384a0j1317f900006b18793108a15d ) - #0 "on_waitUntilAndExecArray - [objNull];
};

};

 

addMissionEventHandler ["Loaded", {
private _tickTime = diag_tickTime;

{
_x set"
12:55:12 PM | Player #0 OrbDamu (25384a0j1317f900006b18793108a15d) has been kicked by BattlEye: Script Restriction #0

Using Filter:

!="on_waitUntilAndExecArray - [objNull];\n};\n\n};\n\n\n\naddMissionEventHandler ["Loaded", {\nprivate _tickTime = diag_tickTime;\n\n{\n_x set" 

I've tried this and every other variant of that. It simply won't take. I'm fairly certain these won't help but here's my server and client RPT's:

server: http://pastebin.com/bjykfgt2

client: http://pastebin.com/QUFfmHrt

I've tried reinstalling the the updates to no effect but I'll willing to take any and all suggestions to get this fixed. One this I have noticed is that the infistar script restrictions are entirely different then the exile ones this time around which may have something to do with it. If you need other info let me know.

Share this post


Link to post
Share on other sites

3 answers to this question

  • 0

Probably teaching you to suck eggs but when I ran your exception through this BE tool  http://a3ap.com/BEFv2.php it comes out slightly different to yours. Here's the code;

Spoiler

!="on_waitUntilAndExecArray - [objNull];\n }; \n\n}; \n\n  \n\naddMissionEventHandler ["Loaded", {\n private _tickTime = diag_tickTime; \n\n{\n _x set"\"

Credit to Jamie (I think) for the BE Tool.

1 person likes this

Share this post


Link to post
Share on other sites
  • 0

Appreciate your help but the thing just won't go away... I'm trying to find another way around it. Also running into another really odd script restriction with some funky stuff going on in it. Check this out:

"x) joinString ", "
];

_result pushBack _entry;
} forEach allVariables _hash1;

_result joinString "<br/><br/>";
};


private _f"

How the heck do you make a filter for something with breaks ("<br/><br/>") in it?!?!? Can't seem to get by that one either. It really isn't my week.

Share this post


Link to post
Share on other sites
  • 0

I'm no coder (was a crane driver) but aren't line breaks like that HTML? Is it something your linking to in the cfg? esc menu message, mission breifing or maybe the Xm8 info page, even the infiStar HTML update link? 

Anyways, I thought I'd go look at a BE guide or two. Apart from this.................If a keyword contains regex metacharacters ({}[]()^$.|*+? and \) they must also be preceded by a \ like so: "key \(word\)"...................... and a few similar I couldn't find anything about <br>'s or the like, anywhere.

Have you tried substituting them for \n ??? you see my logic.....\n for BE new line, <br> for new line....maybe?

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.