JerryAtricks

[SOLVED] Halp! Time is flying!

7 posts in this topic

Halp! My server time is flying and I don't know why! It's like 5 times as fast as it should be. O.o

 This is what I have in my Exile_Server_Config/config.cpp

	class Time
	{
		// Uses Dedicated Server time as ingame Time
		useRealTime = 0;

		// Will overide RealTime
		useStaticTime = 1;

		// time in ARMA FORMAT << CONFIG
		// https://community.bistudio.com/wiki/setDate

		staticTime[] = {2039,10,24,08,00};
	};

I tried putting setTimeMultiplier 3; at the top of my initServer.sqf as suggested here previously but that didn't work. 

This didn't happen before the latest Plum update so what changed? 

Where else should I be looking for time settings? 

Thanks!

Share this post


Link to post
Share on other sites
Advertisement
1 hour ago, JerryAtricks said:

Halp! My server time is flying and I don't know why! It's like 5 times as fast as it should be. O.o

 This is what I have in my Exile_Server_Config/config.cpp


	class Time
	{
		// Uses Dedicated Server time as ingame Time
		useRealTime = 0;

		// Will overide RealTime
		useStaticTime = 1;

		// time in ARMA FORMAT << CONFIG
		// https://community.bistudio.com/wiki/setDate

		staticTime[] = {2039,10,24,08,00};
	};

I tried putting setTimeMultiplier 3; at the top of my initServer.sqf as suggested here previously but that didn't work. 

This didn't happen before the latest Plum update so what changed? 

Where else should I be looking for time settings? 

Thanks!

have you got

a3_exile_occupation running on your server if so you may need to change this its in the config.cpp

 

SC_fastNights               = false;                // true if you want night time to go faster than daytime
SC_fastNightsStarts         = 18;                   // Start fast nights at this hour (24 hour clock) eg. 18 for 6pm
SC_fastNightsMultiplierNight= 16;                   // the time multiplier to use at night (12 = 12x speed)
SC_fastNightsEnds           = 6;                    // End fast nights at this hour (24 hour clock) eg. 6 for 6am
SC_fastNightsMultiplierDay  = 4;                    // the time multiplier to use during daylight hours (4 = 4x speed)

 

this is just a thought

 

 

Share this post


Link to post
Share on other sites

Hrmm... Mine looks like this

if(_useStaticTime isEqualTo 1)then
{
	setDate _staticTime;
}
else
{
	if(_useRealTime isEqualTo 1)then
	{
		setDate ExileServerStartTime;
	};
}

So it should be using the correct time. No?

Share this post


Link to post
Share on other sites

@hogansheroes Yes! OMG! I do have that installed. It was set to 4x. I will change it and see if that works after next restart. Thanks!

Share this post


Link to post
Share on other sites

We have closed this thread and marked it as solved.

Share this post


Link to post
Share on other sites
Advertisement
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.