• 1
[x] Splin

Markers on the map can be seen by everyone

Question

When you log in to server you see all markers on the map set by other players, even it they were set in group channel and you shouldn't really see them. And it makes using them quite pointless because of it.

Share this post


Link to post
Share on other sites

8 answers to this question

  • 1

Yep. We placed some markers in group channel, I'm dead and I'm still bleeding after respawn, so I leave a server and reconnect. After I rejoined - I see all markers set even I didn't joined a party yet.

Also we noticed this when someone from our team joined server in the middle of the game and saw many markers placed by us and not only right after he spawns, but he wasn't even in the group when they were placed and he wasn't invited in group yet.

Share this post


Link to post
Share on other sites
Advertisement
  • 1

Hm... the double-click markers are the ones built into Arma. I fear we cannot affect this behavior. The way they work is that everyone in the same group sees the same markers and only persons in that group.

I have an idea. Maybe Arma duplicates markers if you change groups? What happens if you join a party, have a friend place a marker and then leave the group? Do you then still see the marker on your map? Do other people that are not in a party see the same marker then?

I remember that a couple of months ago Bohemia has increased the group limit from 144 to 255 or so. If the above is true, we might be able to prevent this problem. We had to put all "lone wolves" into the same group due to the group limit so far.

Share this post


Link to post
Share on other sites
  • 1
On 2/22/2017 at 3:19 AM, Tebb said:

Hi Eichi, thanks for the reply! 

I'm talking about the dbl left click map-markers, in the 'group' (green) channel. Those seem to have the problem.

To clarify further, we've also been using the family markers (i.e. the mouse double-right-click) and those I dont have an issue with. We also use the 'yellow' 3d markers (using 'custom control action 2' mapped) and those I also don't have an issue with.

Note - we've subsequently moved to another local server, and the problem persists unfortunately :(

We see this group-markers-can-be-global behavior too sometimes.

Share this post


Link to post
Share on other sites
  • 0

Hi ExileMod team,
I experienced this bug last night - but slightly different circumstances, which I will describe below:

My squad-members and I (we were all in the same family, as well as all in the same party via xm8) had just completed a mission, and we had placed several map-markers in the "Group Channel" (green colour). These markers included simple place marker dots, as well as some objective marker / X's - that we had annotated with text such as pin-codes for the vehicles that we were rewarded with from completing the mission (so we didn't forget them during looting). 

Essentially what happened, was a member of a completely different squad (who was not, nor has ever been a part of our family or party - i.e. is a complete enemy), connected to the server and in side-chat (blue) mentioned to us that he could see our markers (he actually taunted us and said he's coming to snipe / steal etc). He should not have been able to see our markers as they were placed within our group channel, and not side-chat channel or any other channel (100% confident of this).

If you'd like to investigate further, this was on this server: https://arma3-servers.net/server/91280/   It is running the latest version of ExileMod.

PS: We have reproduced this fairly frequently over the last while - we just weren't certain it was actually happening, until last night when this random person taunted us and read back exactly the text/code markers we had written that shouldn't have been visible to him.

PPS: Not sure if related to this bug, because one can't see other players as such - only the map markers: 

 

Share this post


Link to post
Share on other sites
  • 0

The 3D markers are an Exile feature, while map markers (besides clan markers) are an Arma feature. Have you been using map markers or clan/family markers?

Share this post


Link to post
Share on other sites
  • 0

Hi Eichi, thanks for the reply! 

I'm talking about the dbl left click map-markers, in the 'group' (green) channel. Those seem to have the problem.

To clarify further, we've also been using the family markers (i.e. the mouse double-right-click) and those I dont have an issue with. We also use the 'yellow' 3d markers (using 'custom control action 2' mapped) and those I also don't have an issue with.

Note - we've subsequently moved to another local server, and the problem persists unfortunately :(

Share this post


Link to post
Share on other sites
  • 0

Hi Eichi - 

Ok, I'll try experiment with what you're saying when I get a chance, relay back findings.

As a work-around, we've been using family markers as those are guaranteed to only be seen by our family members (which we keep as everyone in our party).

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.