• 0
henry232323

MySQL Error: Unable to locate extDB2 extension!

Question

I've seen this answered by many other people, however none of their fixes work.

18:29:25 "ExileServer - MySQL connection error!"
18:29:25 "ExileServer - Please have a look at @ExileServer/extDB/logs/ to find out what went wrong."
18:29:25 "ExileServer - MySQL Error: Unable to locate extDB2 extension!"
18:29:25 "ExileServer - Server will shutdown now :("

I'm running an Arma 3 server hosted by ggservers https://ggservers.com with Exile installed.
Their support has not yet been able to help me.
Full RPT: http://pastebin.com/n70ba1rp

VC++ Redistributable is installed
extdb-conf.ini is configured
extDB2.dll is in the @ExileServer folder, tbbmalloc.dll is in the server folder.

Share this post


Link to post
Share on other sites

19 answers to this question

  • 0

Posted (edited)

I'm having the same problem and its really starting to annoy me could someone please point out what we are doing wrong and explain it like i'm a 5 year old lol.

Edited by Huskie19

Share this post


Link to post
Share on other sites
  • 0

What does the file in

@ExileServer/extDB/logs/

say?

 

(Could also be in @extDB2/logs)

Share this post


Link to post
Share on other sites
Advertisement
  • 0
30 minutes ago, Hell Raiser said:

What does the file in


@ExileServer/extDB/logs/

say?

 

(Could also be in @extDB2/logs)

Because the extension hasn't been found, the actual application is not running. No logs are created, no connection is attempted. 

Share this post


Link to post
Share on other sites
  • 0

Have you got a copy of your command line?

you should have on the Servermod line @ExileServer;@extDB2;

and on the Mod line @Exile;

Share this post


Link to post
Share on other sites
  • 0
14 minutes ago, Hell Raiser said:

Have you got a copy of your command line?

you should have on the Servermod line @ExileServer;@extDB2;

and on the Mod line @Exile;

The command line should be located at the top of the rpt, if not I can give it in a while. @extDB2 is on the command line. 

Share this post


Link to post
Share on other sites
  • 0

Appologies of course it is.... doing too many things at once is not a excuse! haha *goes back to the corner of the room in shame*

Share this post


Link to post
Share on other sites
  • 0

only thing I can see in your RPT which stands out is

18:28:16 File A3DS\server.cfg, line 33: '/Missions/Exile.template': Missing ';' at the end of line

right near the top (line 18), not sure if this could even effect the DB but this is ARMA haha

Share this post


Link to post
Share on other sites
  • 0

Just download extDB2.os and change it sorry but i dont have link i need too

Share this post


Link to post
Share on other sites
  • 0

Quick question, should extDB2.dll be in a folder?, mine is in the exileserver folder i'm wondering if it should be in its own folder named @extDB2 which may explain why it isn't being found just a thought.

Share this post


Link to post
Share on other sites
  • 0

Posted (edited)

8 hours ago, Huskie19 said:

Quick question, should extDB2.dll be in a folder?, mine is in the exileserver folder i'm wondering if it should be in its own folder named @extDB2 which may explain why it isn't being found just a thought.

Well the problem could be because your Db password and your ini Db settings password does not tally, that's one main reason you'll get that error

Edited by kayzee1

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.