• 0
z3sp

Issues with Exile_Server_Config

Question

I am having some issues (Again).

 

I am editing the starting loadout in Exile Server Config/Config.cpp.

 

I am literally adding 3 lines of code to add a few extra items.

Original:
loadOut[] = 
		{
			"ItemCompass",
			"Exile_Item_XM8",
			"ItemRadio",
			"Exile_Item_PlasticBottleFreshWater"




Edited:
loadOut[] = 
		{
			"ItemCompass",
			"Exile_Item_XM8",
			"ItemRadio",
			"Exile_Item_PlasticBottleFreshWater"
			"ItemMap"
			"Exile_Item_InstaDoc"
			"Exile_Item_BBQSandwich_Cooked"

And Also editing this:

Original:
class Frags
		{
			bambi = -500;				// Bambi slayers
			friendlyFire = -1000;		// For party members
			standard = 100;				// Normal kill
			domination = 80;			// Keeps killing the same guy
			letItRain = 150;			// MG, also vehicle MGs
			humiliation = 300;			// Axe
			passenger = 400;			// Out of car/chopper/boat
			roadKill = 200;				// :)
			bigBird = 600;				// Roadkill, but with chopper/plane
			chuteGreaterChopper = 1000;	// Someone flies into chute and chopper/plane explodes	
		};

Edited:
class Frags
		{
			bambi = -1000;				// Bambi slayers
			friendlyFire = -1000;		// For party members
			standard = 100;				// Normal kill
			domination = 80;			// Keeps killing the same guy
			letItRain = 150;			// MG, also vehicle MGs
			humiliation = 1000;			// Axe
			passenger = 400;			// Out of car/chopper/boat
			roadKill = 200;				// :)
			bigBird = 600;				// Roadkill, but with chopper/plane
			chuteGreaterChopper = 1000;	// Someone flies into chute and chopper/plane explodes
		};

Now when I repack and upload, my server does not load (It says 0/0 player) in my admin panel and does not show up in the server list.

 

Any Suggestions?

Share this post


Link to post
Share on other sites

8 answers to this question

  • 0

Posted (edited)

            "ItemCompass",
			"Exile_Item_XM8",
			"ItemRadio",
			"Exile_Item_PlasticBottleFreshWater",
			"ItemMap",
			"Exile_Item_InstaDoc",
			"Exile_Item_BBQSandwich_Cooked"

well you have forgotten a comma after waterbottle,instadocs and map

only the last item in an array has no comma

Edited by B.A.D.

Share this post


Link to post
Share on other sites
  • 0
9 minutes ago, B.A.D. said:

            "ItemCompass",
			"Exile_Item_XM8",
			"ItemRadio",
			"Exile_Item_PlasticBottleFreshWater",
			"ItemMap",
			"Exile_Item_InstaDoc",
			"Exile_Item_BBQSandwich_Cooked"

well you have forgotten a comma after waterbottle,instadocs and map

only the last item in an array has no comma

There are no commas in the file that works, so I shouldnt see why it makes a difference.

Share this post


Link to post
Share on other sites
Advertisement
  • 0
7 minutes ago, z3sp said:

There are no commas in the file that works, so I shouldnt see why it makes a difference.

I stand corrected, there is, ill test now.

 

Share this post


Link to post
Share on other sites
  • 0

Posted (edited)

ok!

its arma, a comma can kill your server. and semicolons are darth vader

 

 

Edited by B.A.D.
1 person likes this

Share this post


Link to post
Share on other sites
  • 0

// Fixed but I have another issue.

 

184a2416e73047cda6a19e2350dc1c18.png

 

I only have 3 circles on the map? No traders or names or anything.

Share this post


Link to post
Share on other sites
  • 0

Posted (edited)

thats most probably something inside initplayerlocal.sqf and/or mission.sqm depending on if there ARE actual trader npc or not

if you like to get some help get on our teamspeak ts.wshworld.de in like 10 mins,i am down in the exile player support channel then

Edited by B.A.D.

Share this post


Link to post
Share on other sites
  • 0
45 minutes ago, B.A.D. said:

ok!

its arma, a comma can kill your server. and semicolons are darth vader

Well said!

Share this post


Link to post
Share on other sites
  • 0

...or post your mission.sqm and initplayerlocal sqf from your mpmission pbo here if youre teamspeak shy,as it seems

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.