• 0
Sign in to follow this  
Followers 0
bobthemercenary

Exile mod not allowed

Question

Posted (edited)

Hello all,

Your install guide was very straighforward, but I've hit a snag.  Whenever anyone tries to join my server, they are kicked back to the lobby continually.  After trying it from my PC, I am seeing this:

 

http://img.photobucket.com/albums/v619/BobtheMercenary/exile.png

 

If you'd rather not hit the link, the server select screen shows that Exile mod is both required and not allowed.  I know there is just one step I missed in some config file somewhere.  If you'd like me to link any of them, I will.  Thanks in advance.

Edited by bobthemercenary

Share this post


Link to post
Share on other sites

14 answers to this question

  • 0

Posted (edited)

It seems as if you're not loading the mod on the server. What are your startup parameters? 

It should looks something like this:

-mod=@Exile -servermod=@ExileServer -config=Cfg\config.cfg -port=2302 -profiles=Profile123-cfg=Cfg\basic.cfg -name=Profile123 -malloc=tbb4malloc_bi -autoinit -exThreads=7 -noTexHeaders -maxMem=3072

 

Edited by Defent

Share this post


Link to post
Share on other sites
  • 0
10 minutes ago, Defent said:

t seems as if you're not loading the mod on the server. What are your startup parameters? 

It should looks something like this:


-mod=@Exile -servermod=@ExileServer -config=Cfg\config.cfg -port=2302 -profiles=Profile123-cfg=Cfg\basic.cfg -name=Profile123 -malloc=tbb4malloc_bi -autoinit -exThreads=7 -noTexHeaders -maxMem=3072

 

-mod=@exile;Kart;Mark;Heli; -servermod=@exileserver; -servermod=@marma; -config=C:\Arma\Server\@ExileServer\config.cfg -port=2302 -profiles=SC -cfg=C:\Arma\Server\@ExileServer\basic.cfg -name=SC -autoinit

 

I left it as it came with the mod.  Also, players are receiving an error that none of their PBOs are signed, but they actually are because they are able to log in to any other Exile server.  Changing verifySignatures to 1 or 2 gets rid of the original message that Exile is not allowed, but now they are receiving the unsigned error.

Share this post


Link to post
Share on other sites
Advertisement
  • 0

You have  servermod twice, change it to  -servermod=@exileserver;@marma;

Also you dont need  Kart;Mark;Heli;  in -mod i dont think

Share this post


Link to post
Share on other sites
  • 0

The signature is because you didnt place the content of the Keys folder in to the Keys folder in your root arma directory.

Should look like this: Server\Keys\exile.bikey <-- this needs to be here.

Disabling signatures is very bad for server security. 

It seems as if you might lack the @exileserver folder or the @Exile folder. Check for these and make sure they are updated and configured correctly. Especially the database files (extDB2).

Share this post


Link to post
Share on other sites
  • 0

I've removed the second servermod parameter (because I'm an idiot) and removed all but @Exile from the mod load list.  I've also verified the keys are in the correct folder.  Restarted server, still saying all of the PBOs associated with Exile are unsigned.  I also checked that @Exile and @ExileServer are where they should be.

Share this post


Link to post
Share on other sites
  • 0

I also have this set in config.cfg:

 

onUnsignedData                         = "";    
onHackedData                         = "kick (_this select 0)";
onDifferentData                     = "";

 

I'm sure that isn't secure, but I'm trying to isolate the problem, then put all of the security back in place.

Share this post


Link to post
Share on other sites
  • 0

Posted (edited)

I was also running 0.9.6.  Upgraded to 0.9.6.1, but the issue remains.

Edited by bobthemercenary

Share this post


Link to post
Share on other sites
  • 0

Found the problem.  I had not copied over the new keys from the upgrade package.  Thanks to all who assisted.

Share this post


Link to post
Share on other sites
  • 0

Im having the same issue with mod not allowed on the server and i think its some start up parameters that is not correct. Im using dedicated server from gtxgaming. I went to mod manager, found the extended base mod and clicked install. After that it told me to add @Extended_Base_Mod; in the -mod box.  This is how it looks:

█ MOD SETTINGS

-mod= @Extended_Base_Mod;@Exile;

-servermod= @ExileServer;

So when i find my server in the arma launcher its red and if i try to join i get kicked from the game right away. Yes i have the mod enabled cus i can join other servers with extended base mod enabled

If i unload all mods but Exile there is a green lamp on the server and i can join

 

Edited by Gjeewaytee

Share this post


Link to post
Share on other sites
  • 0
6 hours ago, Gjeewaytee said:

Im having the same issue with mod not allowed on the server and i think its some start up parameters that is not correct. Im using dedicated server from gtxgaming. I went to mod manager, found the extended base mod and clicked install. After that it told me to add @Extended_Base_Mod; in the -mod box.  This is how it looks:

█ MOD SETTINGS

-mod= @Extended_Base_Mod;@Exile;

-servermod= @ExileServer;

So when i find my server in the arma launcher its red and if i try to join i get kicked from the game right away. Yes i have the mod enabled cus i can join other servers with extended base mod enabled

If i unload all mods but Exile there is a green lamp on the server and i can join

 

Try removing the space between -mod= and the @ should look like this -mod=@ExileServer;

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.