• 0
Sign in to follow this  
Followers 0
dave.tf

New exile starting SQL server error

Question

Hi guys, maybe you can help me, I'm starting my server with the new exile 0.9.8 and it never finishes unlocking. I can see the following error in the logs;

Quote

[19:57:57:043578 --4:00] [Thread 8964] extDB2: SQL_CUSTOM_V2: Error StatementException: MySQL: [MySQL]: [Comment]: mysql_stmt_prepare error    [mysql_stmt_error]: Unknown column 'money' in 'field list'    [mysql_stmt_errno]: 1054    [mysql_stmt_sqlstate]: 42S22    [statemnt]: SELECT id,class,spawned_at,account_uid,is_locked,fuel,damage,hitpoints,position_x,position_y,position_z,direction_x,direction_y,direction_z,up_x,up_y,up_z,cargo_items,cargo_magazines,cargo_weapons,pin_code,vehicle_texture,deleted_at,money FROM vehicle WHERE id = ?
[19:57:57:043578 --4:00] [Thread 8964] extDB2: SQL_CUSTOM_V2: Wiping Statements + Session
[19:57:57:043578 --4:00] [Thread 8964] extDB2: SQL_CUSTOM_V2: Error: UniqueID: 1 Input String: loadVehicle:271
[20:21:13:133421 --4:00] [Thread 8964] extDB2: Stopping ...


 

Share this post


Link to post
Share on other sites

7 answers to this question

  • 0

[01:34:47:067928 +01:00] [Thread 2508] extDB2: Database Type: MySQL
[01:34:47:069283 +01:00] [Thread 2508] extDB2: Database Exception Error: Connection attempt failed: Access denied for user 'changeme'@'localhost' (using password: NO)
[01:34:47:069499 +01:00] [Thread 2508] extDB2: Sending Shutdown to Armaserver

this is mine I think we need to make a new data base


 

Share this post


Link to post
Share on other sites
  • 0

@Eichi I think you forgot to add the money column to vehicle and container in upgrade-0.9.60-to-0.9.80.sql. Please let me know if theres anything else missing.

Share this post


Link to post
Share on other sites
Advertisement
  • 0
12 hours ago, Rappidxshots said:

[01:34:47:067928 +01:00] [Thread 2508] extDB2: Database Type: MySQL
[01:34:47:069283 +01:00] [Thread 2508] extDB2: Database Exception Error: Connection attempt failed: Access denied for user 'changeme'@'localhost' (using password: NO)
[01:34:47:069499 +01:00] [Thread 2508] extDB2: Sending Shutdown to Armaserver

this is mine I think we need to make a new data base


 

You need to edit the database username and password, you replaced the old file with the credentials

Share this post


Link to post
Share on other sites
  • 0

Hello everyone,

I concur with dave.tf

Found the same error in extDB logs after upgrade. Couldn't join the server. Add 'money' field in both 'container' and 'vehicle' tables and now it works. :)

Share this post


Link to post
Share on other sites
  • 0

Yeah. Try to add field money to vehicle table is work 

Share this post


Link to post
Share on other sites
  • 0

I am not trying to be a pain but could some one show us a screenshot of what needs to be changed. I am lost... or simple directions, including file names and locations. This has been a long road over night trying to fix this.

Share this post


Link to post
Share on other sites
  • 0

Hi there,

Running these two sql requests on your Exile database should do the trick:

ALTER TABLE `container` ADD `money` INT NOT NULL DEFAULT '0' AFTER `deleted_at`;
ALTER TABLE `vehicle` ADD `money` INT NOT NULL DEFAULT '0' AFTER `deleted_at`;

Hope this helps.

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.